How to mount /usr file system  in read write mode

Posted on 2006-04-25
Last Modified: 2013-12-27
My sun solaris server version 2.8 showing /usr file system is mounted as read only because of that my veritas netbackup is not coming up

1)       How do I mount the /usr file system to read write

2)       Procedure for unmounting the  /usr file system and mounting read write.


Question by:nessmssit
    LVL 10

    Expert Comment

    Technically the command is:

    mount -o remount,rw /usr

    *BUT* I've never heard of Veritas NB stopping /usr from being mounted RW.  This usually happens when a system reboots but something is wrong with the file system on the box and the automagic fsck won't fix the problems its found because they are too severe.

    Did your system go down hard recently ?
    Have you had disk issues with this box recently ?
    Have the disks been making weird noises ?

    Expert Comment

    Check the /etc/vfstab - by the sounds of it there is an option in there that is telling the system to mount /usr with read only permission (usually a "-r" switch). You can remove this option. AFAIK - the system would need a reboot to apply these changes.

    Expert Comment

    sorry - will be a "ro" switch - not just an "r" as I previously stated.
    LVL 10

    Expert Comment


    Assuming there is nothing wrong causing the file system to be mounted a specific way (e.g. cuz an admin put something in /etc/vfstab like read-only mode), no, the system doesn't have to be rebooted.  See the mount and mount_ufs man pages and look at the "-o remount" switch.

    Expert Comment

    I was always under the impression that /usr could not be mounted/unmounted in "live" mode - however I now stand corrected!!
    LVL 10

    Expert Comment

    A "mount -o remount,...." doesn't physically unmount and then remount the file system.  It changes the various mount flags.  

    Author Comment


    hi all,

    / on /dev/dsk/c0t0d0s0 read/write/setuid/intr/largefiles/onerror=panic/dev=800000 on Tue Apr 25 13:27:51 2006
    /usr on /dev/dsk/c0t0d0s4 read only/setuid/intr/largefiles/onerror=panic/dev=800004 on Tue Apr 25 13:27:50 2006
    /proc on /proc read/write/setuid/dev=4400000 on Tue Apr 25 13:27:50 2006
    /dev/fd on fd read/write/setuid/dev=4500000 on Tue Apr 25 13:49:54 2006
    /etc/mnttab on mnttab read/write/setuid/dev=45c0000 on Tue Apr 25 13:49:55 2006
    /var on /dev/dsk/c0t0d0s5 read/write/setuid/intr/largefiles/onerror=panic/dev=800005 on Tue Apr 25 13:49:56 2006
    /var/run on swap read/write/setuid/dev=1 on Tue Apr 25 13:49:56 2006
    /tmp on swap read/write/setuid/dev=2 on Tue Apr 25 13:49:57 2006
    /opt on /dev/dsk/c0t0d0s3 read/write/setuid/intr/largefiles/onerror=panic/dev=800003 on Tue Apr 25 13:49:57 2006
    /cdrom/nb_45_opt on /vol/dev/dsk/c0t6d0/nb_45_opt read only/nosuid/maplcase/noglobal/rr/traildot/dev=16c0001 on Tue Apr 25 13:50:15 2006

    This is my /etc/vfstab file there is no read only given but still it shows the same

    :/root>more /etc/vfstab
    #device         device          mount           FS      fsck    mount   mount
    #to mount       to fsck         point           type    pass    at boot options
    #/dev/dsk/c1d0s2 /dev/rdsk/c1d0s2 /usr          ufs     1       yes     -
    fd      -       /dev/fd fd      -       no      -
    /proc   -       /proc   proc    -       no      -
    /dev/dsk/c0t0d0s1       -       -       swap    -       no      -
    /dev/dsk/c0t0d0s0       /dev/rdsk/c0t0d0s0      /       ufs     1       no      -
    /dev/dsk/c0t0d0s4       /dev/rdsk/c0t0d0s4      /usr    ufs     1       no      -
    /dev/dsk/c0t0d0s5       /dev/rdsk/c0t0d0s5      /var    ufs     1       no      -
    /dev/dsk/c0t0d0s3       /dev/rdsk/c0t0d0s3      /opt    ufs     2       yes     -
    swap    -       /tmp    tmpfs   -       yes     -

    i tried the command which is given but it does not seems to be working
    mount -o remount,rw /usr

    please advice me how to go a head.


    Author Comment

    Hi all,

    when i run the command
    mount -o remount,rw /usr
    i got this error
    mount: the state of /dev/dsk/c0t0d0s4 is not okay
            and it was attempted to be mounted read/write
    mount: Please run fsck and try again

    Then I went to single user mode and ran fsck -y /dev/rdsk/c0t0d0s4

    Then restarted the multiuser mode and now if i give the mount command it shows
    / on /dev/dsk/c0t0d0s0 read/write/setuid/intr/largefiles/onerror=panic/dev=800000 on Wed Apr 26 00:38:17 2006
    /usr on /dev/dsk/c0t0d0s4 read/write/setuid/intr/largefiles/onerror=panic/dev=800004 on Wed Apr 26 00:38:18 2006

    Now even my netbackup administration console also opens and backup is going on.

    Thanks to all for your support
    LVL 10

    Accepted Solution

    ... which is what I suggested in my first post.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    Join & Write a Comment

    My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (, discussed installing the Solaris Operating S…
    FreeBSD on EC2 FreeBSD ( is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

    732 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now