Exchange Error: This e-mail address already exists in this organization

Hi,

yet again Exchange is doing my head in:

I want to add a distribution group to our system with the email address jordans@mydomain.com, but every time I try, I get the message:

This e-mail address already exists in this organization.

ID no: c10312e7
Microsoft Active Directory - Exchange Extension


The object in question is a Public Folder called Jordans. The problem is that I have disabled Mail on the Public folders, propagated this down the tree , so as far as I know it shouldn't be holding on to this address.

When I perform a ldifde -f I get this result:

How do I make this folder release these addresses?


thanks,



dn: CN=Jordans 15802784,CN=Microsoft Exchange System Objects,DC=MyCompany,DC=local
changetype: add
homeMDB:
 CN=Public Folders,CN=Folder Hierarchies,CN=First Administrative Group,CN=Admin
 istrative Groups,CN=MyCompany,CN=Microsoft Exchange,CN=Services,CN=Configurat
 ion,DC=MyCompany,DC=local
cn: Jordans 15802784
displayName: Jordans
mail: Jordans@mydomain.com
instanceType: 4
legacyExchangeDN:
 /O=MyCompany/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=JORDANS14A0AA7C46
 B75E4319DB0E8C2E1F65580000B2
distinguishedName:
 CN=Jordans 15802784,CN=Microsoft Exchange System Objects,DC=MyCompany,DC=loca
 l
objectCategory:
 CN=ms-Exch-Public-Folder,CN=Schema,CN=Configuration,DC=MyCompany,DC=local
objectClass: publicFolder
objectGUID:: vhN9EU5260C9J7y9L0DbOQ==
proxyAddresses: smtp:Jordans@MyCompany.local
proxyAddresses: smtp:Jordans@MyCompany.co.uk
proxyAddresses: X400:c=US;a= ;p=MyCompany;o=Exchange;s=Jordans;
proxyAddresses: SMTP:Jordans@mydomain.com
name: Jordans 15802784
showInAdvancedViewOnly: TRUE
textEncodedORAddress: c=US;a= ;p=MyCompany;o=Exchange;s=Jordans;
uSNChanged: 199156
uSNCreated: 199131
whenChanged: 20050816130419.0Z
whenCreated: 20050816130409.0Z
msExchHideFromAddressLists: TRUE
mailNickname: Jordans
targetAddress: expf:JORDANS14A0AA7C46B75E4319DB0E8C2E1F65580000B2
msExchMailboxSecurityDescriptor::
 AQAEgHgAAACEAAAQEAAAAABQAAAEEAGQAAQAAAAACJAADAAIAAQUAAAAAAAUVAAAAcsxWBnw65sOaUG
 VbbgQAAEIANwA1AEUANAAzADEAOQBEAEIAAAAFADgAQwAyAEUAMQBGADYANQA1ADgAMAAwADAAMABC
 ADIAAQEAAAAAAAUSAAAAAQEAAAAAAAUSAAAA
deliveryMechanism: 0
msExchPFTreeType: 1
msExchALObjectVersion: 22
msExchPoliciesIncluded:
 {69D44916-1E45-4082-BE5B-7116D1895ADB},{26491CFC-9E50-4857-861B-0CB8DF22B5D7}
LVL 1
LetterpartAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cvanhoudtCommented:
Aslong as your Public Folder keeps the e-mail address (it is clearly shown in the SMTP proxy addresses which you provide in your question) you will keep getting the error.
Why don't you change te SMTP address(es) of your PF? Then the address you refer to will become available again. You can change them using the Exchange system manager.

You say "I disabled mail" - what exactly do you mean by that and how did you accomplish this?

Kris
0
rakeshmiglaniCommented:
are you able to see this PF in the MESO container when checking via adsiedit.msc

if yes then you can modify the attributes there.. you would find an attribute there which holds the smtp address and you can remove it from there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rakeshmiglaniCommented:
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

LetterpartAuthor Commented:
Thanks for your replies.

cvanhoudt:

I can't change the address on the PF as I disabled the mail through ESM, All Tasks > Mail Disable


rakeshmiglani:

Yes I can see this PF in adsiedit.msc, but when I tried to remove the proxyaddresses in Properties, Select a property to view and then remove, then apply. When I next open it up in adsiedit, the values have returned.

CN= Jordans LDAP://RACKSERVER.mydomain.local/CN=Jordans,CN=Microsoft Exchange System Objects,DC=letterpart,DC=local

Thanks for your replies.

cvanhoudt:

I can't change the address on the PF as I disabled the mail through ESM, All Tasks > Mail Disable

rakeshmiglani:

Yes I can see this PF in adsiedit.msc, but when I tried to remove the proxyaddresses in right hand click -  Properties - Select a property to view - remove - apply. When I next open it up in adsiedit, the values have returned.

thanks.
0
rakeshmiglaniCommented:
are you able to change the proxy address of this public folder via adsieidt.msc?
0
LetterpartAuthor Commented:
rakeshmiglani,

No, I only had the option of remove and add. I could not change via adsieidt.msc. Although now trying it again, when I click remove it brings it up into the Edit Atribute window and I can now edit and then Add. <silly me>

Seconds before your'e last post I had removed all the proxys and then added a new SMTP: and this appeared to work. Next time I will remove then edit then add.

Just before I give you your well deserved points and thank you for your help, it is appreciated. Any idea why the PF still has an address assigned to it after I had disabled Mail on the PF's using ESM?

thanks.

0
rakeshmiglaniCommented:
it could be a replication issue. what happens when you remove the address via adsiedit.msc and replicate the changes and dismount and mount the PF store. Do you still see an email address stamped on the PF?
0
LetterpartAuthor Commented:
If I remove the address via adsiedit it is fine. It is all the other folders which have had their mail disabled that are still showing proxyaddresses.

It doesn't really matter as I now know how to remove the address when I need to, but I would have thought that disabling mail would free up the emails, rather than just stopping you from emailing them. <sigh>
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.