Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Unable to get 100mbps on ethernet connection.

Posted on 2006-04-25
18
Medium Priority
?
1,478 Views
Last Modified: 2013-11-10
My onboard ethernet port of my motherboard "gave up the ghost" last week and I purchased a new Swann PCI ethernet card.
It uses the infineon AN938B chip.

The onboard ethernet port is disabled in BIOS.

However I can't get it to communicate at 100mpbs to my router only 10mbps.

If I select either "Autosense" or "100 TX Dual" in the preferences I get a random blinking of the lan led on the router (with no connection to the internet) , but if I select "10 TX Dual" in the preferences then I get a solid connection and no trouble with the internet.

I have changed the cable and which port I connect to on the router to no avail. I can connect a laptop and a xbox to the router and have no trouble with the internet.

I have the latest driver for the card from the manufacturers website.

I am running a P4 system using Windows XP SP2 with the latest updates.

This is driving me nuts.
0
Comment
Question by:clivewakeham
  • 7
  • 4
  • 3
  • +4
18 Comments
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 150 total points
ID: 16533582
Have you tried a different router/hub?  Whatever caused the demise of your onboard ethernet port may have also affected the router.  I would also try a clean installation on a new hard drive just to see if the old drivers are affecting the operation.
0
 
LVL 13

Expert Comment

by:compfixer101
ID: 16533591
what OS you running?

try XP

cf101
0
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 150 total points
ID: 16533641
Another possibility is that this new PCI card is faulty, so try a second card.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
LVL 32

Expert Comment

by:jhance
ID: 16533665
I'm not familiar with this board or chipset.  I'm assuming that it has 100Base-T capabilities.  If not, then there is no chance that it will work at 100M b/s.

It's also possible that it's defective or that its drivers are defective.  I prefer NOT to use no-name (like Swann) network adapters.  Driver support is often lacking or non-existent and quality is often questionable due to the need to sell at extrement low prices.

I've had the best results using Intel Pro/100 network cards.  They cost a bit more but I've never had any problems with them.
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 16533720
Have you tried to uninstall the card/drivers and then reinstall?
0
 
LVL 13

Assisted Solution

by:Nick Denny
Nick Denny earned 225 total points
ID: 16534141
It seems that the card is faulty.

If selecting autosense - it wants to communicate at 100mbps (as per the router speed) but this causes a problem.

Manually setting at 10 implies this is the only speed it can communicate at.

Conclusion is either faulty card or that the motherboard/drivers only support 10mbps.

I would, as suggested, try a new card 1st (perhaps borrow one).

Perhaps you could post the name/part number of your motherboard
If you cannot find it - use this software to identify all of your system: aida32
http://www.majorgeeks.com/download181.html

I would wholeheartedly agree with jhance re branded network cards. Intel are usually very reliable. As are most of the more common brands: netgear, d-link, linksys, belkin etc. My personal view is infineon appears to be cheap and cheerful.

However, would only running at 10 cause you a problem? If its just net access then unless you are on a super fast connection, this speed will more than cope with average speeds.
0
 
LVL 14

Expert Comment

by:tmj883
ID: 16536719
The NIC is not faulty...it is obsolete. Return the item for a name brand with the WindowsXP logo for compatibility.
http://www.newegg.com/Product/Product.asp?Item=N82E16833124107
Nice...cheap...T
0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16541131
Swann is a well known brand in Australia, they have a large range including wireless video and security.

I am using XP SP2.

According to the information with the card it is 10/100 T base compatible.

The driver provides quite a few options but only at 10 T base does it communicate with the router, and since I can connect a laptop to the router on the same cable and using the same port at 100 T base then its not the router. I also can connect my Xbox on live with a connection at 100 T base.

While at the moment it is sufficent for my 1.5MBPS broadband connection, it won't be when in due course I get ADSL2+.

The fault with the inbuilt ethernet port would freeze the boot up of Windows, so thats why it is disabled in BIOS.

My motherboard is a MSI 865PE - Neo2P


 
0
 
LVL 13

Accepted Solution

by:
Nick Denny earned 225 total points
ID: 16541924
Motherboard should be absolutely fine with a 10/100 card at 100.

Have you tried removing the card and all drivers, trying in a different PCI slot and reinstalling?

Have you tried the card in another PC?

If so, then that leaves a dodgy card and/or drivers.

For the cost of a new card you may find it easier (and more cost effective) to get a new one.

If you do go down this route and suffer the same problems, then its a fault on the motherboard or an unknown compatibility problem (by a process of elimination).

Good luck

Nick
0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16558890
I have ordered another ethernet card (different brand).

I expect this to arrive Monday/Tuesday.

I will install this to check whether the pci card is the problem.
0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16613895
Received a new card, should install it this weekend.

On another note, the manufacturers have finally replied to an email I sent and said that they believe it to be faulty.

I will notify when done.

Regards,
0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16635937
I have installed the new nic card.

The computer recognizes it as a  Reatek type card and installed with no trouble.

Same problem though. Unable to connect to the router at 100TX.

Then, moved the other nic to another slot and installed it there. Same problem.

Two cards, different chip manufacturers, same problem.

So its either the router, the OS (WinXP Pro SP2), or the motherboard.

Mmmmm?
0
 
LVL 69

Expert Comment

by:Callandor
ID: 16636059
It should be easy to make a new small partition for a clean OS install.  You should also check the cables or swap them.
0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16638495
The problem is with the router.

My step-son brought down his laptop to print a university assignment and when he connected it to the router he could only get a connection at 10TX speed not the normal 100TX he used to get.

Alot easier for him to use the 54mbps wireless connection.

The router is out of warrenty so I will have to wait until the new financial year to get another one.

I will contact the routers manufacturer and see what they can do.

Thanks for the help, opinons and ideas.
0
 
LVL 13

Expert Comment

by:Nick Denny
ID: 16639091
Glad you got it sorted, and thanks.

I think this line threw us all

-->"I can connect a laptop and a xbox to the router and have no trouble with the internet."<--

For good home use I would suggest either a Linksys (now part of Cisco) or a Netgear. I have had good experiences with both makes.

I have had troubles with a few Belkins (range, setting up, poor firmware), although when running they are not too bad.

Good Luck.
0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16644724
Actually I was able to connect the xbox to the router and it would connect at 100TX, and the laptop would also connect to the router via lan cable at 100TX.

But lately I can't get the xbox to connect to the router and yesterday when my step-son tried to print something from his laptop and he connected via the lan connection instead of the wireless (like he normally does) he could not connect.

Whatever fault with the lan section of the router has crept across all four ports. And even when I could connect the xbox on a particular port I could not connect my computer on that port. Very strange.

I am awaiting a reply from the manufacturer, but I expect that I will have to replace it sooner than later. It has been working well for me but sh*t happens.

Time to upgrade....
0
 
LVL 13

Expert Comment

by:Nick Denny
ID: 16647550
Have you attempted to update the routers firmware?

This can sometimes sort out problems.

If you fry it in the process - then nothing to lose as it isn't working anyway.

But if its an internal hardware issue - then unless you are an electronics whizz, time to replace...

0
 
LVL 1

Author Comment

by:clivewakeham
ID: 16647890
The last firmware upgrade for the router was last year in June.

In case the firmware was corrupted, I will update it again. (Whats to lose?)

Thanks for the suggestion.
0

Featured Post

Eye-catchers on the conference table

Challenge: The i-unit group was not satisfied with the audio quality during remote meetings. They were looking for a portable solution with excellent audio quality for use in their conference room but also at their client’s offices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
Backups and Disaster RecoveryIn this post, we’ll look at strategies for backups and disaster recovery.
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question