Veritas Backup Exec 9.1 SP3 Will Not Overwrite Existing Data on Tape

As the title says, we're having trouble getting Backup Exec to overwrite data on our tapes.

In the properties of the backup job, the option to "overwrite media" is clearly selected.  However when the job runs, it goes for the maximum 12 hours and doesn't grab a single byte of data.

The temporary fix we've been using is to manually perform a quick erase on the media when it's swapped out in the morning.  When we do this, the backup runs perfectly that night.

Not a huge problem, but it's one that doesn't make sense and therefore bothers me.  Any ideas?

Thanks!
rjander77Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kgreeneitCommented:
I've seen this problem previously and it could be caused by a number of issues. Firstly try a brand new tape for a few days and see if this rectifies the problem, if it does, then just replace your old media.

A complete shutdown of the server and then a reboot isn't a bad idea either.


You could try deleting the current backup job and creating a new one. This sometimes resolves strange issues such as that. You could create a backup job that includes just a few folders and files and see if the problem is still there. At least this will tell you if its the backup job or a hardware issue.

If that doesn't work, try uninstalling, then reinstalling Backup Exec.

Thirdly, you could try and upgrade the firmware of the tape drive. You can normally find instructions on the manufacturers website on how to do this.

As a last resort try replacing the SCSI cable and terminator thats connecting the drive to the scsi card/board.

If this doesn't work, then it's possibly the drive that is faulty although it seems unlikley since the backup job completes when you erase the tape.
rjander77Author Commented:
This is a server that was recently rebuilt, formatted and everything installed from scratch (there were other, unrelated issues we needed to fix).

I've tried using new tapes, cleaning the drive with a brand new cleaning tape, installing the updated driver for the tape drive and rebooting the server.  The only thing that came up during all of this was Backup Exec whined about the driver update and suggested using its own driver, which I let it do.  The backup had failed after the driver update until I went along with Backup Exec's version.
scrathcyboyCommented:
This is a well known fatal flaw in BE, dont know if it has ever been fixed.  The individual fix is to set each backup job so that it ERASES TAPE before it backs up.  This is a bad kludge, but it does fix the error in BE logic, in almost all cases.  So in BU job, you check the box "erase tape" before the BU job starts.  that does it.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

rjander77Author Commented:
Where do I find that option?  I viewed all the setup options for the job, and only saw the "overwrite media" option I mentioned above.

Thanks to both of you for your replies!
kgreeneitCommented:
Hi again, I'm not sure the option to erase the job first or even to schedule an erase job is valid in Version 9.1. You might want to just check these settings before going through the steps I've outlined above.

Click on the "Media" tab
Go to "Media Sets"
Right click on the Media Set you are using and go to "Properties"
Assign the Overwrite Protection accordingly.

Hope this helps.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rjander77Author Commented:
It was currently set to 'Infinite (Don't allow overwrite)'.  I wasn't able to set it to 'None', as this was not an option, but I was able to set to a small amount, like 1 hour.

I'm assuming this will be the solution that works, but I'll wait and see what happens tomorrow.

Thanks again!
kgreeneitCommented:
no problem, I'm sure it should solve the problem for you!
rjander77Author Commented:
This still didn't work!

We didn't have this problem before the server rebuild; I wonder what gives.

None of the hardware changed.  We did format the hard drive and upgrade from Windows Server 2000 to Server 2003.  We have the latest updates to everything.

Do we just give up and clean the tape each morning?  It only takes 60 seconds; I'm starting to wonder if it's all worth it.  I just can't stand problems that don't make sense!
kgreeneitCommented:
There's no reason why this shouldn't work. You should try uninstalling Veritas, then reinstalling it again before giving up and make sure that you select the overwrite protection accordingly when you're setting up the media sets. It's no problem at all to use Veritas own tape drivers for your device and the fact that you upgraded from Win2000 to Win2003 shouldn't make a difference either.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.