?
Solved

site-to-site VPN. moved corp office, changed ip, VPN doesn't work

Posted on 2006-04-25
15
Medium Priority
?
279 Views
Last Modified: 2013-11-16
I have a site-to-site VPN between two PIX 501's. The corp office moved, so the IP's changed. I changed the external IP's on the corp PIX, and also the IP's in the crypto maps on the remote site, but the VPN does not come up.

here's what i had on the remote PIX:

crypto map tooffice 20 ipsec-isakmp
crypto map tooffice 20 match address 101
crypto map tooffice 20 set peer X.47.128.10
crypto map tooffice 20 set transform-set myset
crypto map tooffice interface outside
isakmp enable outside
isakmp key ******** address X.47.128.10 netmask 255.255.255.255

then did this to change to new IP:

no crypto map tooffice 20 set peer X.47.128.10
crypto map tooffice 20 set peer x.xx.xx.xx (new IP address)
no isakmp key ******** address X.47.128.10 netmask 255.255.255.255
isakmp key ******** address x.xx.xx.xx netmask 255.255.255.255

clear crypto isakmp sa
clear crypto ipsec sa

clear xlate

Not sure why the VPN doesn't work now. Any thoughts?
thanks in advance

-delmarlocal



0
Comment
Question by:Trevor Local
  • 8
  • 7
15 Comments
 
LVL 20

Expert Comment

by:calvinetter
ID: 16537988
 Re-apply the crypto map to the interface:
crypto map tooffice interface outside

cheers
0
 

Author Comment

by:Trevor Local
ID: 16538240
ok, i reapplied and saved to mem. still get no response from pinging the remote network. do  i need to reload?
thanks.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16538316
Normally you shouldn't have to, but it couldn't hurt.
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 

Author Comment

by:Trevor Local
ID: 16538443
nope- that didn't work! should i post my configs or debugs? (not sure which debugs)
thanks.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16538486
On the remote PIX, did you also change the peer IP??
  eg:
no crypto map tooffice 20 set peer X.47.128.10
crypto map tooffice 20 set peer <new IP>
0
 

Author Comment

by:Trevor Local
ID: 16538533
yes, i did exactly that. i didn't touch the crypto's on the corp PIX.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16538569
Did you also re-apply the crytpo map on the remote PIX's interface? Or just reboot the other PIX if you've changed all references to the old IP to the new one.
0
 

Author Comment

by:Trevor Local
ID: 16538697
i reapplied the crypto map on the remote PIX to the outside interface, and also did a reload.

on the corp PIX i haven't done anything except change the configs for it's new IP's.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16539295
Please post the entire "sanitized" configs for both PIXes (passwords removed, public IPs masked like you've done above).
0
 

Author Comment

by:Trevor Local
ID: 16539702
corp PIX (moved, IP change, new router):

PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password Y4VhkpgwXuS6dpYQ encrypted
passwd Y4VhkpgwXuS6dpYQ encrypted
hostname xxx
domain-name xx.com
clock timezone PST -8
clock summer-time PDT recurring
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list 101 permit ip 192.168.102.0 255.255.255.0 10.1.1.0

255.255.255.0
access-list 101 permit ip 192.168.102.0 255.255.255.0 192.168.103.0

255.255.255.0
access-list 102 permit ip 192.168.102.0 255.255.255.0 192.168.103.0

255.255.255.0
access-list 103 permit tcp any host xx.xx.xx.xx eq www
access-list 103 permit tcp 64.18.0.0 255.255.240.0 host xx.xx.xx.xx

eq smtp
access-list 103 permit tcp any host x.xx.xx.xx eq https
access-list 103 permit tcp 207.126.144.0 255.255.240.0 host

x.xx.xx.xx eq smtp
access-list localtovpnclient permit ip 0.0.0.0 255.255.255.0

192.168.102.0 255.255.255.0
access-list nonatinside permit ip 0.0.0.0 255.255.255.0 192.168.102.0

255.255.255.0
access-list nonatinside permit ip 192.168.102.0 255.255.255.0

192.168.102.96 255.255.255.224
access-list nonatinside permit ip 192.168.102.0 255.255.255.0

192.168.103.0 255.255.255.0
access-list fromoutside permit tcp 192.168.102.0 255.255.255.0 host

192.168.102.2
access-list fromoutside permit udp 192.168.102.0 255.255.255.0 host

192.168.102.2 eq domain
access-list carlsbad_splitTunnelAcl permit ip 192.168.102.0

255.255.255.0 any
access-list outside_cryptomap_dyn_30 permit ip any 192.168.102.96

255.255.255.224
access-list icmp permit icmp any any echo-reply
access-list icmp permit icmp any any source-quench
access-list icmp permit icmp any any unreachable
access-list icmp permit icmp any any time-exceeded
pager lines 24
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside x.xx.xx.xx 255.255.255.248
ip address inside 192.168.102.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool jabuza 10.1.1.1-10.1.1.5
ip local pool vpnclientpool 192.168.102.100-192.168.102.120
pdm location 0.0.0.0 255.255.255.0 inside
pdm location 192.168.102.2 255.255.255.255 inside
pdm location 192.168.102.0 255.255.255.0 outside
pdm location 192.168.103.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonatinside
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp x.xx.xx.xx www 192.168.102.2 www netmask

255.255.255.255 0 0
static (inside,outside) tcp x.xx.xx.xx https 192.168.102.2 https

netmask 255.255.255.255 0 0
static (inside,outside) tcp x.xx.xx.xx smtp 192.168.102.2 smtp

netmask 255.255.255.255 0 0
access-group 103 in interface outside
route outside 0.0.0.0 0.0.0.0 x.110.144.225 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323

0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server west protocol radius
aaa-server west (inside) host 192.168.102.2 w3stbuz@ timeout 5
http server enable
http 192.168.102.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.168.102.2 /
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map mydynmap 30 match address outside_cryptomap_dyn_30
crypto dynamic-map mydynmap 30 set transform-set myset
crypto map mymap 10 ipsec-isakmp
crypto map mymap 10 match address 102
crypto map mymap 10 set peer x.229.60.249
crypto map mymap 10 set peer x.229.60.250
crypto map mymap 10 set transform-set myset
crypto map mymap 20 ipsec-isakmp dynamic mydynmap
crypto map mymap client authentication west
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address x.229.60.249 netmask 255.255.255.255
isakmp identity address
isakmp keepalive 15 5
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
isakmp policy 30 group 1
isakmp policy 30 lifetime 86400
vpngroup carlsbad address-pool vpnclientpool
vpngroup carlsbad dns-server 192.168.102.2
vpngroup carlsbad wins-server 192.168.102.2
vpngroup carlsbad default-domain westdevelopmentinc.local
vpngroup carlsbad split-tunnel carlsbad_splitTunnelAcl
vpngroup carlsbad idle-time 1800
vpngroup carlsbad password ********
telnet 192.168.102.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe 40
vpdn group 1 client configuration address local jabuza
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username db password ********
vpdn username staylor password ********
vpdn username richard password ********
vpdn username nevan password ********
vpdn enable outside
dhcpd lease 3600
dhcpd ping_timeout 750
terminal width 80
Cryptochecksum:d41f769d91d368746a2d29b3633be6cf

remote PIX:

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password Y4VhkpgwXuS6dpYQ encrypted
passwd Y4VhkpgwXuS6dpYQ encrypted
hostname xx
domain-name xx.com
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list outside_access_in permit tcp any host x.229.60.251 eq 8234
access-list outside_access_in permit udp any host x.229.60.251 eq 8234
access-list outside_access_in permit tcp any host x.229.60.251 eq 8235
access-list outside_access_in permit udp any host x.229.60.251 eq 8235
access-list outside_access_in permit tcp any host x.229.60.251 eq www
access-list outside_access_in permit tcp any host x.229.60.250 eq pcanywhere-data
access-list outside_access_in permit udp any host x.229.60.250 eq pcanywhere-status
access-list 101 permit ip 192.168.103.0 255.255.255.0 192.168.102.0 255.255.255.0
access-list icmp permit icmp any any echo-reply
access-list icmp permit icmp any any source-quench
access-list icmp permit icmp any any unreachable
access-list icmp permit icmp any any time-exceeded
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside x.229.60.249 255.255.255.248
ip address inside 192.168.103.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.103.3 255.255.255.255 inside
pdm location 192.168.103.2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) x.229.60.250 192.168.103.3 netmask 255.255.255.255 0 0
static (inside,outside) x.229.60.251 192.168.103.2 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.229.60.254 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.103.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto map tooffice 20 ipsec-isakmp
crypto map tooffice 20 match address 101
crypto map tooffice 20 set peer x.xx.xx.xx
crypto map tooffice 20 set transform-set myset
crypto map tooffice interface outside
isakmp enable outside
isakmp key ******** address x.xx.xx.xx netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 192.168.103.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:61546f416a23c9c467aafb9b5098f9bb
0
 
LVL 20

Accepted Solution

by:
calvinetter earned 2000 total points
ID: 16545015
>corp PIX (moved, IP change, new router)
  "new router" -> does this mean you put a new router in front of the corp PIX?? If so, make sure you're allowing the following protocols/ports to/from your corp PIX both inbound/outbound:
  UDP port 500
  ESP protocol (protocol 50, *not* port 50)

If you have current SmartNet on these PIXes, upgrade ASAP to 6.3(5).  Remote PIX is 6.3(1) which is a very buggy 6.3 version.  And the corp PIX is running a *very* old 6.2(2), which also has a lot of bugs & some security problems that are resolved in 6.3(5).

  On the corp PIX, why do you have 2 peers for the same specific crypto map entry?
>crypto map mymap 10 set peer x.229.60.249
>crypto map mymap 10 set peer x.229.60.250  <- remove this

  Both PIXes' isakmp & crypto map parameters need to match; add this to the remote PIX:
isakmp keepalive 15 5

Are you absolutely sure the remote PIX's isakmp key ("isakmp key ******** address x.xx.xx.xx...") *exactly* matches the key set on the corp PIX?

  On the remote PIX:
>crypto map tooffice 20 set peer x.xx.xx.xx
>isakmp key ******** address x.xx.xx.xx netmask 255.255.255.255
  I assume both of the above IPs are correctly set to the corp PIX's new IP?

cheers
0
 

Author Comment

by:Trevor Local
ID: 16545331
thanks calvin-
i deleted teh extra crypto entry, i added the isakmp keepalive entry, and re-entered the isakmp key on both PIX's and applied the map to the outside interface.
yes, the IP's are correct too.
ping'd the remote PIX from my server and didn't get a reply, but i ping'd a pc behind the remote PIX and I get a response. I assume that's good news!!
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16545402
>ping'd the remote PIX from my server and didn't get a reply...
  If you want to be able to ping the inside interface of the remote PIX, do this:
management-access inside   <- (not supported in PIX 6.2)

>but i ping'd a pc behind the remote PIX and I get a response.
  Yes, that's good news! Sounds like you're all set now with the site-to-site VPN.

cheers
0
 

Author Comment

by:Trevor Local
ID: 16545458
thanks for your help. much appreciated. i will clean up the configs as you such as well.

be well.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16545484
You're welcome! Take care.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question