Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

The item could not be deleted. It was either moved or already deleted...

Posted on 2006-04-25
4
Medium Priority
?
390 Views
Last Modified: 2011-08-18
I am running an exchange 2003 enviroment with SP1.  Platform is Server 2003 Sandard.

User is using oultook 2003 with windows XP.

Here is what happened earlier today:

I received the following event error at 9:14AM and repeatedly afterwards:

------------------------------
Event Type:      Error
Event Source:      ESE
Event Category:      Database Corruption
Event ID:      447
Date:            4/25/2006
Time:            9:11:58 AM
User:            N/A
Computer:      SERVER1
Description:
Information Store (3960) First Storage Group: A bad page link (error -327) has been detected in a B-Tree (ObjectId: 546, PgnoRoot: 6692) of database D:\exchsrv\mdbdata\priv1.edb (7218 => 2309730, 7219).

For more information, click http://www.microsoft.com/contentredirect.asp.
----------------------------------------------------------

Just as I received the error, one of our users had lost the ability to delete incoming email.  He was able to view it, but the mail could not be modiyed, deleted or marked as read.  (The user recevied the 'The item could not be deleted. It was either moved or already deleted, or access was denied' error)

Then about an hour later all of the mail in my account went blank (and so did everyone elses), so it was time to take down the stores and do a repair.

I ran the following:
eseutil /p
eseutil /d
isinteg -s servername -fix test alltests (twice to make sure nothing else needed to be fixed)

The repair process went through fine and when I mounted the stores my box as well as everyone elses were back to normal.  The original user with the "The item could not be deleted..." error still continues to have this problem.

The link below is almost exactly the same problem I am having, only the solution in this EE users case was to rebuild the account.  The difference is I ran the isinteg at the end of my repair.  Read the following for more information and responses from other people.

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21487192.html?query=The+item+could+not+be+deleted.++It+was+either+moved+or+already+deleted&clearTAFilter=true

As always this is a critical matter for us.  Thanks for taking the time to look this over with me.
0
Comment
Question by:CBIA
3 Comments
 
LVL 7

Expert Comment

by:vasanthgnb
ID: 16544335
Did you mount the database and dismount it after eseutil /d completed??? So try to run ISINTEG once again and that should fix your problem.

Vasanth.
0
 

Author Comment

by:CBIA
ID: 16598882
In order to fix this I had to follow the EE article I attached above.  Simply put, you must rebuild the user account.
0
 

Accepted Solution

by:
GranMod earned 0 total points
ID: 16782571
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
In my humble opinion (IMHO), TouchDown from Symantec is the best in class for this type of application, but Symantec has end-of-lifed it and although one can keep using it, it will no longer be supported or upgraded.  Time to look for alternatives t…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question