Language Bar Disabled

Suddenly the langauge bar is no longer in the task bar and when I right click on the task bar point to Toolbars -> Language Bar and click it, nothing happens the language bar doesn't show in the task bar and even the Left Alt+Shift keys are not working, I can't switch no more between input languages.

I checked in Regional & Languages Options --> Languages --> Details
and I found that the language bar under preferences is disabled, I can't click it.

So what's that thing that happend and caused my language bar to be disabled and how can I restore it back?

Thanks in advance.
LVL 3
JessyEzzyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
Recent windows update

Copy the following to the clipboard (it's all one line even if wrapped in your browser - paste into notepad and remove line breaks if necessary, and copy again)
click START, type RUN <enter>

=copy below here=
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Cached" /v "{A4DF5659-0801-4A60-9607-1C48695EFDA9} {000214E6-0000-0000-C000-000000000046} 0x401" /t REG_DWORD /d 1
=copy above here=
rae_raeCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Irwin SantosComputer Integration SpecialistCommented:
cool. thank you!
JessyEzzyAuthor Commented:
I'm sorry I didn't thank you as I was in a hurry, but thanks for offering your help that's exaclty what I always expect from experts their immediate respond to help, I didn't use any of the suggested solution, I fixed it in other way, I selected the check box "Turn off advanced text services" in the advanced tab in Langauges. I'm sure your offered solutions will be useful to me is some point in the future, may be this happens to me again and the solution I made won't work, I'll still have your two solutions to try.
And also I'm sorry for the small points as my account is a free one in which I get 5 points a day and I'm not capable of buying more points to assign them to a question.
Irwin SantosComputer Integration SpecialistCommented:
no problem.. regarding the points.. we already new what we were getting into...Glad it worked out for you.

Aloha from Hawaii,

Irwin
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.