IIS missing from Services

I'm not sure how or when, but IIS is missing from Administrative Tools > Services.  My OS is Windows XP Pro, SP2.

I've gone to control panel > add components and checked all the usual stuff for IIS - coommon files, documentation, snap-in, etc.  The wizard runs.  It does not prompt me for any CD.  Finishes in just a minute or so - but when I go to Services, IIS is not there.  http://localhost doesn't find the server.   I tried adding the component from my Gateway Operating System cd for Windows XP Pro - same result, no IIS.

Not that I know what this means, but I see that in the folder, C: i386, I have the following files:
IISRESET.EX_
IISRSTAS.EX_
IISSYNC.EX_

I also still have an Inetpub folder with all my html files, etc.

If this matters, I have the .Net 1.1 framework installed.

Any ideas how I can get IIS back?  Thanks - Sue
Sue WhiteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
uncheck the IIS box, then let it uninstall..  when done reboot your machine..

then reinstall the IIS component
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sue WhiteAuthor Commented:
Now I'm much closer to where I need to be!  After uninstall and reboot, the installation took longer and prompted me to insert my Win disk while copying files. I do see IIS in Services and it is started.  The only thing not working is http://localhost.  When I type that into my browser it redirects to localstart.asp and then "Page cannot be displayed".  Any idea what I need to do to make this work - it must be a .NET thing.  
0
Irwin SantosComputer Integration SpecialistCommented:
go into IE  TOOLS - INTERNET OPTIONS - ADVANCED tab, then uncheck  "SHOW FRIENDLY HTTP ERROR MESSAGES"..  

reload that URL you, post back the exact error message.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Sue WhiteAuthor Commented:
I've unchecked the "show friendly http error..."  and here is all the text on the localstart.asp page after reload:
error '8007007e'
/localstart.asp, line 46

The header says http 500 Internal server error.

0
Sue WhiteAuthor Commented:
BTW - I was poking around and found at least a way to get localhost to work with an .htm page - it is just asp that is having a problem.  I followed a KB article that said to set 500 errors to default - so that is why I didn't get much text on the localstart.asp page.   You've solved my original problem.  Thank you.
0
Irwin SantosComputer Integration SpecialistCommented:
cool. thank you.

as for your localstart problem.  make sure that ASP is ALLOWED under webserver extensions
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.