[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3235
  • Last Modified:

Exchange 2003 Queue filling up

I am new to this area of exchage 2003 and would appreciate some help.  I have a E2k3 server and it seems like emails are getting clogged up in the queue.  When I go to system manager /  Server / Server Name / Queues ->  I see over 1000 emails sitting in this area.  Some of them say  "Active"  "Ready" or "Retry"  This is causing emails to take a very long time to go out or some emails to come in to the users.  I see a lot of them that go to sites that I no one in the office have sent to, such as:

10000books.com
mda.org.il
0451.com
006.com
0733.com
etc....

Can anyone please tell me
a) how these emails got into the queue
b) How do i get rid of them so that the real emails can go out
c) How can i prevent these emails from getting into my queues

I would realy appreciate your immediate help since my client is getting a little anxious.

Regards,
K.
0
kfarhang
Asked:
kfarhang
  • 4
  • 2
  • 2
  • +2
1 Solution
 
rakeshmiglaniCommented:
all these domains appear to be SPAM..

How to prevent unsolicited commercial e-mail in Exchange 2003
http://support.microsoft.com/kb/821746/en-us
0
 
rakeshmiglaniCommented:
You can also check the following article

In Exchange Server 2003 or in Exchange 2000 Server, the Exchange Server queues are filled with many non-delivery reports from the postmaster account because of a reverse non-delivery report attack
http://support.microsoft.com/kb/909005/en-us

You can implement

The "Exchange Server Intelligent Message Filter Overview" white paper for Microsoft Exchange Server 2003 is available
http://support.microsoft.com/kb/842763/en-us

TechNet Support WebCast: Intelligent Message Filter in Microsoft Exchange Server 2003
http://support.microsoft.com/kb/885152/en-us

Intelligent Message Filter release notes
http://support.microsoft.com/kb/867633/en-us

The Microsoft Exchange Intelligent Message Filter Deployment Guide is available
http://support.microsoft.com/kb/870823/en-us

0
 
Irwin SantosComputer Integration SpecialistCommented:
delete the 1st message that appears in the queue
0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
rakeshmiglaniCommented:
To clear out those queues..

you need to stop the smtp service and then rename the vsi 1 folder and then create a new vsi 1 folder in the same place and then restart the smtp service.

this would clear the queue from all the messages (even valid messages as well)
0
 
IsigowCommented:
One possible cause is that they are NDR's trying to be returned from false spam sent to your organization. (Email received by your server to xxx@your.domain.com and that user doesnt exist so your server is trying to send an NDR to that organization.)
You can purge the queue by going to Program Files\Exchsrvr\Mailroot\vsi 1\Queue [or a variant of that directory depending on your installation, right click your smtp server and choose properties, messages tab for your exact location for your installation] and deleting the files contained within (suggesting to delete only the old ones in case of real queue messages attempting to go out or doing it at very off-peak when you know there is no real queue) On that previously mentioned messages tab you can also have the server forward a copy of all NDR's and unresolved messages to a certain address in order to see if that is your true culprit or to further determine if there is alot of spam or problems by users sending mail.
You can turn off NDR's if you dont want this queue, but then you wont have any notification to true users.

Isi
0
 
kfarhangAuthor Commented:
Isi,
Thank you for all the NDR information.  I think that is what is causing my queue fill up.  How do i turn off NDRs????  

Khaled
0
 
Irwin SantosComputer Integration SpecialistCommented:
@kfarhang...BEFORE you wipe out the entire queue..just delete the 1st message (oldest message)
0
 
rakeshmiglaniCommented:
You can check the following article to disable NDRs

How to control non-delivery reports when you use Exchange 2000 or Exchange 2003
http://support.microsoft.com/kb/294757/en-us
0
 
IsigowCommented:
Launch the Exchange System Manager, navigate to Global Settings, Internet Message Format, click properties on the right pane, (usually Default *).  Select the Advanced tab. (Un)check Allow non-delivery reports

Isi
0
 
SembeeCommented:
Could be NDR spam.
However the last thing you should be doing is disabling NDRs. That doesn't really fix the problem, just masks the underlying cause.

For some guidance on clearing the queues, see this article on my web site: http://www.amset.info/exchange/spam-cleanup.asp

If the machine is on Windows 2003 SP1 then I would also look at turning on recipient filtering and the tar pit feature.
http://www.amset.info/exchange/filterunknown.asp

Simon.

0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now