Tortoise CVS checkout error

Hi,

I have just installed Tortoise CVS on my windows 2000 machine and I am trying to checkout a repository from the remote CVS server. The protocol being used is Secure Shell (:ext:). Now when i try to check out a module, it does not go past the first step and I get an error "bad command or file name" from cvs server. Now my colleagues have the exact same settings as mine and they are able to checkout the repository successfully. When i try doing the same on a separate machine (Windows XP), i am able to checkout successfully. This means that this is a machine specific and not an account specific problem. The only difference that I can see is that I have a Windows 2000 machine, while everyone else has XP in them. The tortoise version is 1.8.25.

Any help would be highly appreciated.

coolpacificAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wnrossCommented:
Do you have an ssh client installed on the windows 2000 box?
0
coolpacificAuthor Commented:
I havent installed anything apart from the standard tortoise CVS installation. By SSH client do you mean Putty. Once we download it , what are the configurations that we must use. I am a newbie and not really clear about how tortoise CVS has to be synced up with putty.
0
wnrossCommented:
(From TortoiseCVS FAQ)

* Download PuTTY from the PuTTY website. (PS: get the "installer", not the putty.exe standalone file)
* Use PuTTY to create separate PuTTY sessions for each SSH server. Set the session parameters (server name,
   SSH version etc.) as you need them. Don't forget to save the session settings.
* Try to connect to your server using PuTTY and the newly created PuTTY session. If you're not able to establish a
   connection, TortoiseCVS won't be either.
* When doing a "CVS Checkout", specify the PuTTY session name instead of the actual servername. TortoiseCVS
   will connect to the server specified in the PuTTY session using the session's connection parameters.

You should be able to launch putty from one of the other stations and copy the relevant session data from them

Cheers,
-Bill
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
coolpacificAuthor Commented:
Hi,

I am trying to configure putty and connect to the repository server. So while entering the host name, do we enter the only the url (abc.xyz.com) or enter the complete path of the module (abc.xyz.com:/cvsroot/<module>).

When i try to connect, it gives an error message "This is a restricted shell account. You cannot execute anything here"



0
wnrossCommented:
Actually thats good, it means that you connected successfully but the server administrator won't
actually let you log in and do anything.

Thats ok, we don't WANT to do anything, we just need the connection.

Putty requires only the server name, as it has nothing to do with CVS.  If everything is going this well, you should be able
to fire up TortoiseCVS again.

Cheers,
-Bill


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.