Java Applet Error (java.lang.nullPointerException)

I'm using the CreditRoll.class applet (which I've used successfully before) and it's giving me fits. I get the "java.lang.nullPointerException" error every single time with nothing but a red x where the applet should be.

I'm on XP Pro SP2, using VS 2005 Web Developer, and have tested on IE 6, IE 7 and Firefox and get the same error on all of the machines/browsers. I've update Java to latest version, etc. I'm just not sure what else to check. Can someone give me some ideas as to why this is failing?

Here is the entire html script :

<%@ Page Language="VB" AutoEventWireup="false"  %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd" />
<html xmlns="http://www.w3.org/1999/xhtml" >
<head>
<title>
Test Page
</title>
</head>
<body>
<div>
<applet code="CreditRoll.class" width="450" height="30">
<param name="bgcolor" value="#FAEBD7" />
<param name="textcolor" value="#191970" />
<param name="fadezone" value="20" />
<param name="text1" value="Witticism #1" />
<param name="text2" value="Witticism #2" />
<param name="text3" value="Witticism #3" />
<param name="url" value="http://getsteno.com" />
<param name="repeat" value="yes" />
<param name="speed" value="20" />
<param name="vspace" value="3" />
<param name="fontsize" value="15" />
</applet>
</div>
</body>
</html>
Carla RomereDirector of Information TechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Carla RomereDirector of Information TechnologyAuthor Commented:
Well I picked this area because I was developing in dot net, but apparently the problem was with that particular applet because I used another one and it worked fine in the same set up.
0
raterusCommented:
Applets run in the browser, and really depend on the HTML source, and your webserver setup.  I can assure you asp.net is not to blame for the problem!  I wonder if the browser just can't find the "CreditRoll.class" file on your webserver?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Carla RomereDirector of Information TechnologyAuthor Commented:
I don't know - it was in the same directory as the aspx file, and the sample on the website from where I downloaded the applet played just fine. It was weird. I downloaded another one that did basically the same thing and it ran fine. I haven't a clue what the problem is with the other one.
0
raterusCommented:
Just to be sure, can you verify that if your url looks like this

http://mydomain.com/app/mypage.aspx

you do infact can make a request for this, and get the class?
http://mydomain.com/app/CreditRoll.class
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.