Change EHLO hostname for Exchange 2003 Server

Hi All,

I am currently experiencing an issue where messages are getting trapped in spam filters because of our outbound mail set up. Right when our Exchange 2003 server connects to another mailserver it uses it's true FQDN for the EHLO. I want it to use another which is registered as an MX record and has an A record for our domain. How can I force the Exchange server to do this?

Thank you.
sandvineAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rant32Commented:
If you have only one SMTP virtual server:

ESM > Servers > Protocols > SMTP Virtual Server, properties > tab Delivery > Advanced > Fully-qualified domain name

If you have multiple SMTP Virtual Servers, then you should change the one that's used in the Outbound SMTP connector for internet e-mail.

Also check any DNS or blacklist issues with your domain name on http://www.dnsstuff.com and http://www.dnsreport.com

Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sandvineAuthor Commented:
Thanks for the reply. I have tried that and it didn't seem to work. It still uses the real host name for in the EHLO. Does the SMTP service need to be restarted for this to take effect?
0
Rant32Commented:
There are no indications that you should restart the virtual service or SMTP service for this to work but it won't hurt to try.

Interesting quotes from RFC 2821:

1) "The SMTP client MUST, if possible, ensure that the domain parameter to the EHLO command is a valid principal host name"

2) "An SMTP server MAY verify that the domain name parameter in the EHLO command actually corresponds to the IP address of the client. However, the server MUST NOT refuse to accept a message for this reason if the verification fails: the information about verification failure is for logging and tracing only."
0
sandvineAuthor Commented:
Thank you for your responses. As its turns out the SMTP service has to be restarted for this change to take effect.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.