• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 315
  • Last Modified:

im running swat and i want to use it instead of webmin i cant seem to get a connection to it on port 901 ?

im running swat and i want to use it instead of webmin i cant seem to get a connection to it on port 901 ?
its running but not issuing a listen on port 901


tried using this link no luck either
http://www.experts-exchange.com/Networking/Linux_Networking/Q_21462277.html?query=swat+linux&clearTAFilter=true


***********attempted here to try to see if it responds

telnet 127.0.0.1 901

Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.





************* cat /etc/xinetd.d/swat



service swat
{

    port            = 901
    socket_type     = stream
    protocol        = tcp
    wait            = no
    user            = root
    server          = /usr/sbin/swat
    log_on_failure  += USERID
    disable         = no
    only_from       = localhost

}





**** ps -ax |grep -i swat


Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.6/FAQ
 6527 pts/0    T      0:00 swat -a
 7360 pts/0    S+     0:00 grep -i swat
0
aot2002
Asked:
aot2002
1 Solution
 
owensleftfootCommented:
You are running swat standalone and through xinetd. You can only have one or the other. Change disable=no to disable=yes, run "service xinetd restart" and "service swat restart" (without the quotes)
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now