Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cisco pix 506e

Posted on 2006-04-26
3
Medium Priority
?
305 Views
Last Modified: 2013-11-16
I am assisting withg a cisco pix506e that currently is setup to connect two vpn tunnels. We have to now also allow for connectivity via a vpn client from anywhere. Inorder to enable the vpn client in the configuration, it appears we have to remove the " nat (inside) 0 nonat " command . Does the cisco pix506e support concurrently vpn tunnels as well as vpn client connects? if so, how is this handled?
0
Comment
Question by:dseli
3 Comments
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 2000 total points
ID: 16548119
Sure does. Here's a sample configuration:

Configuring IPSec Between Two PIXes With VPN Client 4.x Access
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00800948b8.shtml

Look at PIX 1 configuration from the link above, that's what you need.

If you have any questions about the config, don't hesitate to ask.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16548398
>...it appears we have to remove the " nat (inside) 0 nonat " command...
  Don't delete your 'nat (inside) 0...' statement.  You can add to/modify what the 'nonat' ACL references, but you must have a 'nat (inside) 0 <ACL_name>' statement for both site-to-site & client VPN to work.

>Does the cisco pix506e support concurrently vpn tunnels as well as vpn client connects?
  Certainly, as stressedout2004 mentioned.  Both site-to-site & client VPN connections can co-exist nicely.

Good URL provided by stressedout2004.  As you can see in the example, your client VPN pool IP range ("ip local pool") must be different than the LAN behind the PIX 506e, as well as different from the LAN where the remote VPN client resides, or you'll run into a "routing loop."

Also be sure to add this on any PIX running 6.3:
  isakmp nat-t

Highly suggest you use the latest 4.8 series of Cisco VPN client software.

cheers
0
 

Author Comment

by:dseli
ID: 16552712
Good information provided. This config is 6.2 and the client is 4.8. I know I need to modify the ' nat (inside) 0...' statement- (by the way- this was very helpful to know). I was not sure if I need to create an additional access list. Here is the current config:
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 6GdrbAhENbpr1YbB encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname SMC
domain-name smc.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.6.0 255.255.255.0
access-list nonat permit ip 172.19.30.0 255.255.255.0 192.168.6.0 255.255.255.0
access-list nonat permit ip 172.19.30.0 255.255.255.0 192.168.5.0 255.255.255.0
pager lines 24
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside 24.202.79.26 255.255.255.248
ip address inside 172.19.30.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 24.202.79.27
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 24.202.79.30 smtp 172.19.30.11 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.202.79.30 www 172.19.30.11 www netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.202.79.29 3389 172.19.30.11 3389 netmask 255.255.255.255 0 0
conduit permit icmp any any
conduit permit tcp host 24.202.79.30 eq smtp any
conduit permit tcp host 24.202.79.30 eq www any
conduit permit tcp host 24.202.79.29 eq 3389 any
route outside 0.0.0.0 0.0.0.0 66.202.79.25 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set myset esp-3des esp-sha-hmac
crypto dynamic-map cisco 1 set transform-set myset
crypto map dyn-map 65000 ipsec-isakmp dynamic cisco
crypto map dyn-map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0 no-xauth no-config-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 3600
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
vpnclient vpngroup smgvpn password ********
vpnclient username test password ********
vpnclient server 24.202.79.26
vpnclient mode client-mode
terminal width 80
Cryptochecksum:3b6f020b5df57b071a5601ecf7e9c5f5
: end

[OK]
Also- how do you account for the  VPN pool IP range on the LAN where the VPNclient resides, if it is potemtially mobil?

Thanks to stressedout2004 & calvinetter
0

Featured Post

Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses
Course of the Month10 days, 15 hours left to enroll

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question