OMA Error HTTP/1.1 5-1 Not Implementeed

I'm attempting to setup active sync via a PPC.  From all my readings, it appears oma needs to be functioning.  I have gone through the settings and everything looks to be set properly for oma.  I'm unable to reach oma from the net or from the exchange server.  I'm receiving a HTTP/1.1 501 Not Implemented Error.  I'm assuming this is impacting my ability to sync via my PPC.  Any ideas or solutions would be greatly appreciated.  Running MS Small Business Server 2k3 sp1 and MS Exchange 2k3 SP2.
dshedrickAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
Go and take a look at my web site here: http://www.amset.info/exchange/mobile-eastrouble.asp
OMA does need to be working for EAS to work, so get one to work and the other usually follows.

Simon.
0
dshedrickAuthor Commented:
Sembee,

Thanks for the assistance.  I went through the settings listed on your website and I still receive the 501 code.  I'm thinking OMA is not setup properly w/in IIS.  Any other things I can check?
0
SembeeCommented:
You could try resetting the virtual folders...

http://support.microsoft.com/default.aspx?kbid=883380

However I don't think you have go as far as that.

Does OWA work correctly?
Are you using SSL and/or FBA?
Sharepoint installed on this machine?

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

dshedrickAuthor Commented:
Simon,

Does OWA work correctly?
Yes, OWA works correctly.  It is accessible at https://www.domain.com/exchange.

Are you using SSL and/or FBA?
Using SSL and there is an ssl cert and it has the correct domain name associated with it (no FBA).  

Sharepoint installed on this machine?
Yep Sharepoint is on the server as well.  Though my client does it use it.  ;-)

In the morning I'm going to attempt to reinstall the virtual directories via the link you provided, unless I hear otherwise.

Any other ideas and Thanks for you help Simon.
0
dshedrickAuthor Commented:
Well I decided to go fwd w/ the virtual directories reinstall and still no joy.  :-(    

Still receiving error code 501 when I attempt to connect to http://www.domain.com/oma.
0
SembeeCommented:
Have the correct exclusions been put in place for the Exchange virtual directories in sharepoint?

http://support.microsoft.com/default.aspx?kbid=823265

Are you using host headers in anyway?

Does it work if you test OMA on the server itself?

Is OMA enabled in ESM?

Simon
0
dshedrickAuthor Commented:
Simon,

I went through the exclusions and they are all set properly.  I didn't have a Microsoft-Server-ActiveSync folder.  There are host headers associated with the share.domain.com site.  The main site does not have any configured, but there is only 1 IP on this server.  The test of OMA on the server itself fails with the same HTTP Code (501).  OMA is enabled on ESM.

When I redid the virtual directories, the Microsoft-Server-.. folder was not created.

Other thoughts?
0
dshedrickAuthor Commented:
Does anyone have any other ideas for me?  Is it unusual not to have the Microsoft-Server-ActiveSync folder.  I guess I'll try to reinstall the virtual directories again.
0
SembeeCommented:
Other ideas?
The folder should be there.
If it doesn't get created then you could try reinstalling Exchange.
Otherwise it is probably a call to Microsoft.

If you can get your hands on another Exchange server then you might be able to create it by hand, although that isn't recommended because the virtual directories are more than just the bits you can see in the IIS Manager.

Simon.
0
dshedrickAuthor Commented:
Apparently that looks like the only fix (reinstall exchange).  I tried to do the virtual restore again using a different method and still didn't get the Microsoft-Server-ActiveSync virtual folder.  

Thanks for your assistance on this.

- Dominic
0
dshedrickAuthor Commented:
Simon,

I made a few changes (mainly moved a web.confg file over).  I'm not sure if I made any progress now or not, but when I goto http://fqdn/exchange-oma, I get the following:

Unable to connect to your mailbox on server RDRSERVER. Please try again later. If the problem persists contact your administrator.

Am I chasing a ghost?

Thanks,
0
SembeeCommented:
Moving configuration files around may not recreate the folder exactly right, as the Exchange folders are move than what you see in IIS Manager. There is a lot of other settings in the IIS Metabase that aren't seen in IIS Manager.

If it is the most common cause of the problem, then you should see an error message in the event viewer of the Exchange server at the same time that you tried to connect.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.