Websphere 5.1 problem in rational application developer while running an application

I'm getting following error while trying to request index.jsp:
[4/26/06 18:04:10:385 EDT] 509db122 OSEListenerDi E PLGN0021E: Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group /index.jsp has not been defined
[4/26/06 18:04:16:510 EDT] 6e68b122 OSEListenerDi E PLGN0021E: Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group /index.jsp has not been defined
[4/26/06 18:04:23:713 EDT] 509db122 OSEListenerDi E PLGN0021E: Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group /index.html has not been defined
[4/26/06 18:14:19:792 EDT] 6e68b122 OSEListenerDi E PLGN0021E: Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group / has not been defined
[4/26/06 18:14:26:510 EDT] 509db122 OSEListenerDi E PLGN0021E: Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group /index.jsp has not been defined
 Any solutions?
Thanks
KirtipurItagolAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rama_krishna580Commented:
Hi,

We had a similar problem with WSAD.  It got rectified when we entered [Virtual Host Name : default_host] in web.xml.
(Open web.xml in WSAD and select Overview tab. Look for Websphere Bindings at bottm right.)

And...

Follow the steps.
1) import the war file from out side
2) click on project(war name)
3) click on project->properties
4) select javabuildpath and copy rt.jar file from jdk directory
5) rebuild the application(rebuild all)(select project->rebuild all)
6) restart the server
7) Run the application

it will do...

R.K
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rama_krishna580Commented:
And You need to update your plugin, then restart IHS.  

R.K
0
rama_krishna580Commented:
Hi,

Problem :
When accessing the WebSphere administrative console, you could see an error similar to the following:

Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group /favicon.ico has not been defined  
 
Cause :
This can occur when accessing content directly from a WebSphere Application Server internal port, bypassing the plug-in, when there is no Web module with the context root of "/". You could also see this error when using the WebSphere Administrative Console because it accesses the administrative console application through an internal port.
favicon.ico is an icon displayed by browsers next to the URL or in the favorites menu and is purely aesthetic. The condition causing the favicon.ico request by the browser is browser dependent.
 
Solution :
This message can be safely ignored. To avoid this messages in the logs, you could deploy a Web module (WAR) with a context root of "/" that contains a favicon.ico file. A sample WAR file to deploy can be found at the bottom of this page.

You will be unable to install the WAR to dmgr via admin console. You should use wsadmin to do so. Here are the instructions:

1. Start the wsadmin tool from the Install_Root/bin directory:
wsadmin.sh/bat

2. Install
$AdminApp install Install_Root/installableApps/favicon.war {-node <<NodeName>> -cell <<CellName>> -server dmgr -appname favicon -contextroot /}

3. Save the changes
$AdminConfig save

4.List all the applications:
$AdminApp list

For further information on deploying a WAR, please refer to the appropriate documentation in the WebSphere Application Server InfoCenter.
If you encounter similar problem for you application rather than admin console application, you can install the below war file to fix the problem.
 
http://www-1.ibm.com/support/docview.wss?uid=swg21193379

R.K
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java App Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.