Toshiba Satellite A10-sp1001 no modem detected

Hi!
I have a Toshiba notebok (Satellite A10-sp1001) working with Windows XP-SP2 and it has a Toshiba V.92 56Kbs internal modem. I installed a usb connection to use the cell phone as a modem and now the notebook doesn't detect the internal modem. I reinstalled the drivers (from the original disk) and downloading it from Toshiba's site with no success. Also, the manual says the modem port is COM3 however, the only available COM ports are 5 and 6 (actually only 6). How do I solve this problem?
SpuriousquintanaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
Wast this working before?
nobusCommented:
maybe a system restore can help you
SpuriousquintanaAuthor Commented:
irwinpks: Yes, it was working before.
nobus: Maybe that's a good solution... however... however... It has been a while since I installed the usb modem connection and a lot of water has passed under the bridge. I'm afraid that a system restore will be a lot of trouble (to reinstall several programs and so on...). If you think there is no other solution...
Need More Insight Into What’s Killing Your Network

Flow data analysis from SolarWinds NetFlow Traffic Analyzer (NTA), along with Network Performance Monitor (NPM), can give you deeper visibility into your network’s traffic.

nobusCommented:
>>   It has been a while since I installed the usb modem connection   <<  you mean its a long time ago it happened, an d you ask now? yes, then it can cause problems
SpuriousquintanaAuthor Commented:
nobus: I usually connect via LAN or wireless connection, but my internet connection shuted off (I don't know why, a problem with my internet provider) and I tried, yesterday, to connect to my dial-up internet provider and then I realized the problem. I mean, it has been more than a year ago since I used the modem...
nobusCommented:
>>  now the notebook doesn't detect the internal modem  << you mean it does not show the modem? in device manager? or does it show with errors? try to revert to the earlier driver
SpuriousquintanaAuthor Commented:
The device manager does not show the internal modem. If I give the option to detect new hardware the device manager says there is no new hardware found. In "add new hardware" or in "telephone options" it doesn't detect any modem neither...
SpuriousquintanaAuthor Commented:
Since it is an internal modem, I believe it has something to do with a motherboard driver...
Irwin SantosComputer Integration SpecialistCommented:
How about going into the BIOS, is there any modem option in there?

Also, we can't rule out that the modem has gone bad.

But here is what you can do.

Boot into SAFE MODE....go to DEVICE MANAGER, then REMOVE  and MODEMs, COM, LPT ports.  Shut your machine down.  wait 10 seconds...power it back up.. and see what is being detected.
nobusCommented:
did you remove the usb connection? uninstall it also.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SpuriousquintanaAuthor Commented:
I did remove Modems, com & LPT ports, however I didn't boot in safe mode. On this first attempt nothing happened: once restarted the device manager only detected de LPT port. I will do it agan in safe mode and I will remove the usb connection.
Irwin SantosComputer Integration SpecialistCommented:
you MUST do this in SAFE MODE
SpuriousquintanaAuthor Commented:
Now I removed all Modems, com & LPT ports and usb connections in safe mode... And once in restart de device manager didn't detect the modem.
I tried to install COM 3 communication port (using Add new Hardware wizzard) and in advance options it says that COM3 was already used...
Do you think I should format de HD and reinstall everything?
Irwin SantosComputer Integration SpecialistCommented:
That is surely a possibility if you don't mind doing that.

Before you do, repeat...

"Boot into SAFE MODE....go to DEVICE MANAGER, then REMOVE  and MODEMs, COM, LPT ports.  Shut your machine down.  wait 10 seconds...power it back up.. and see what is being detected."

Don't install anything...post back what you have listed in device manager.
SpuriousquintanaAuthor Commented:
Back into safe mode I removed COM & LPT ports, Modems and USB ports. I turned it off and waited 10 seconds and restarted y n safe mode. What was detected is:
USB controlers:
USB root concentrator
USB root concentrato
universal host improved driver 2.0 USB Intel 82801DB/DBM-24CD
Universal host driver USB Intel 82801DB/DBM2-24CD2

It didn't detected any modem at all

Ports (COM & LPT)
Printer port ECP (LPT1)

and everything else seems unchanged...
SpuriousquintanaAuthor Commented:
By the way... How can I copy as text the information of the device manager? and How do I reboot back in normal boot without any changes?
Irwin SantosComputer Integration SpecialistCommented:
Screen capture is the way to go...other than that, typing it out will work for now.  As for rebooting back...you won't be able to stop plug n' play.

At this point...is there any modem listed?

If not, we can't rule out that the modem may have just died.
SpuriousquintanaAuthor Commented:
No modem listed...
Maybe the last resourse would be to format the disk and reinstall everything from scratch. If that doesn't work the ... the modem is dead...
Irwin SantosComputer Integration SpecialistCommented:
Well, if you don't mind doing that...a fresh reinstall is like spring cleaning..ultimately the most brute force solution.

Back your information up before you do so.

One more thing to check... can you go into the BIOS, and see if there is a modem selection to ENABLE or turn on?

Let me know how that goes.
SpuriousquintanaAuthor Commented:
No, no modem selection in BIOS...

I remember that back when I installed the motorola usb modem (in order to use the cell phone) there was a lot of conflicts with the internal modem so I uninstalled the latter... and there was a serious warning about doing precisely that. Now I'm paying my dues I'm afraid...
Irwin SantosComputer Integration SpecialistCommented:
Bummer. Ok... when you install, make sure no USB anything is attached.

Before you kill the OS, note the display adapter, network adapter, and IDE controller in device manager.. just write it down as these are the main drivers to install if it doesn't pop up automatically
SpuriousquintanaAuthor Commented:
I will. I will restart everything from scratch so I won't be able to connect or see what happens in a few days. I hope there is no hurry in order to assing points or give a final acceptance...
Irwin SantosComputer Integration SpecialistCommented:
no hurry..i've got 383079 points this month and 3rd on the list of 6000+ experts that participated here..

so no problem :D

get a beer and take your time
Irwin SantosComputer Integration SpecialistCommented:
cool. thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.