Windows XP PC's are slow browsing a novell network

We have around 120 client PC's or so on a novell netware network.  All of the clients are either running Win 2K or Win XP.  
With Win 2K, the users can browse our network drives with no problems.
The new PC's (and the ones with higher specifications) have Windows XP, but when clicking on folders on the network drives it can sometimes take about 3 mins to open!  This is becomming very problamatic for my users.  
It seems to mainly occur on folders that are 3 sub folders deep - for example browsing H:\folder1\folder2 is no problem, but if we try to click on Folder 3, in other words H:\folder1\folder2\folder3 it will just hang.  

Any ideas?  
MrMoo123Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rvthostCommented:
Which Novell client version are you using?
rvthostCommented:
4.91 SP2 is the current version for XP workstations.  If you're not on the latest, that would be the first thing I would suggest.
MrMoo123Author Commented:
Yep thats the first thing I thought too.
But ive installed the service pack, and still no such luck.  
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

rvthostCommented:
Hmm :)

What is the XP SP level at?  What are your server versions?

Couple of suggestions:  Do you have file caching enabled?  I would suggest turning that off.

Client:  Within the Novell Client Properties, click Advanced Settings.  Toggle File Caching to "Off"

Server:  SET LEVEL 2 OPLOCKS ENABLED = OFF
SET CLIENT FILE CACHING ENABLED = OFF

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MrMoo123Author Commented:
Your a genious!
The disabling of the File Caching seems to have done it!

If I set that on the server, will it then be the default for all clients here on in ?
rvthostCommented:
Excellent!  

I believe it can just be set on the server, but I remember way back when that I was recommended to do both.  In addition to the server setting, it can be deployed to the clients relatively easy.  It can be done as you deploy the client, or if that is not feasible, you can just push the registry key to flip it.  In my environment, I have it set on both server and client.
MrMoo123Author Commented:
Ok thanks!
rvthostCommented:
Here is the key if you need it:
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetwareWorkstation\Parameters]
"File Caching"=dword:00000000
rvthostCommented:
You're welcome!  
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.