Workstation failing to map network drives despite running batch file

I have just joined a new workstation (WinXp Pro) to our domain and appear able to log on to the domain by entering username and password in the usual way. However, no network drives appear in My Computer. Normally there would be two network drives visible: Shared Work (T:) and the user's home folder (H:).  All the network printers are also visible. The batch file which maps the network printers has as its first line the mapping of the home drive and its second line the mapping of the Shared Work folder. There are no problems logging on to other workstations on the network, only this one machine. Having tried several log ons with different accounts, strangely, on rare occasions, the Shared Work folder has appeared, but not so far any user's home folder. I have never come across this issue before. The computer account for the workstation is visible in Active Directory. I have disjoined the workstation from the domain and rejoined it with no difference in behaviour.  I have just upgraded this machine to WinXP Sp2. I cannot be absolutely certain, but I seem to recall that the network drive issue started to occur after the upgrade.  I am not yet in a position to reboot the domain servers, so have not tried this. I am completely stumped! Any ideas for things to try?
serendippityAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mrwaqarCommented:
Did you try mapping the drive with a admin account? Are you able to map the drives manually instead of running the batch file? Type first line from batch file on command prompt and see what error it gives.
0
kfullartonCommented:
Verify that the workstation firewall has exceptions enabled for file and printer sharing.  Right click on the network connection, properties, advanced, settings.  Make sure "Don't allow exceptions" is unchecked, then go to the exceptions tab.
0
serendippityAuthor Commented:
For mrwaqar: I tried mapping the drive with an admin account and the error given was "the user's home directory could not be determined".

For kfullarton: all is as it should be on the Windows firewall front.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kfullartonCommented:
Can you map to any of the shares on the server, the netlogon share for example?

Start, run,
\\servername\netlogon
0
serendippityAuthor Commented:
No problem mapping to the netlogon share. Can also map \\servername\d$ and get the expected result, including all the User shares (all this when logged on as administrator).
0
kfullartonCommented:
From a command prompt, run "net use x: \\servername\<some-home-directory>"

Does this return an error?
0
jli168Commented:
serendippity,

When you log into windows, did you select domain you joint to? You will have to click option for you to select your domain. You might be still on the local machine? Also, did you put the login file with the profile tab users account in AD?
0
serendippityAuthor Commented:
k fullarton: I think I have typed exactly what you asked, without the inverted commas, i.e. net use x: \\xanadu\ssmith (Xanadu is not our real server name). The error I receive is System error 85, the local device name is already in use.
 Does this help?


jli168: I do select the domain and not the local machine. Not sure about your second point: I have done nothing differently with this workstation than I do with the hundred or so other clients on our network.
0
serendippityAuthor Commented:
To All:   I'm not sure whether it is of any relevance, but I was just looking in the Event Viewer at the Security section. There is only one audit shown, dated 9 April 2006. The system date of the workstation is correct, i.e. 28 April. If I try to refresh the security, a later date does not appear and the 9 April 2006 entry remains there alone. There are also many entries in the System section, viz "the Security Centre service has been stopped. It was prevented from running by a software group policy."  Just thought I would mention.
0
kfullartonCommented:
Is there some other device using x: in My Computer?  The error indicates that something else is using that drive.  Try using q, r, or s instead of x.
0
serendippityAuthor Commented:
kfullarton:  You were right: the message I now receive is" system error 53 has occurred: the network path was not found" when trying to access any user's home folder.
0
serendippityAuthor Commented:
Kfullarton:  did I mention that the Shared Work network drive at least appears when logging on as administrator to this workstation, but not when logging on as a limited user.
0
kfullartonCommented:
So this regular user account can logon to other machines without an issue?  Have you tried other accounts on this box?  Was this a new installation or as you said, an upgrade?
0
jli168Commented:
Serendippity,

Do you have login script in place? Check your AD. Type: "\\yourserver" in Run. Look for the NETLOGON and see if you have a script in there.
Example: login.bat

Try to double click and launch the script and see if it create the drives for you.

If it creates the drives, then it is issue on the account.

You must add this login.bat in the profile tab, active directory user and computer for that user.
0
serendippityAuthor Commented:
kfullarton:  I can log on to other machines with any account that I wish without an issue. It is only when I log on to this particular workstation that the account's home folder does not appear and, unless logging on as administrator, the shared work folder as well. This workstation is running Windows XP Professional and I recently upgraded it to Service Pack 2.

jli168: there is a login script in place which includes the printer mappings using con2prt.exe. The mapping of the home folder is the first line of the login script and the shared work folder is the second line. Then come the various printers, which all map okay. I will try running the script manually as you suggest on Tuesday when I return to the office.
0
kfullartonCommented:
Have you tried disjoining and rejoining it to the domain?  Not sure what else to suggest.  BTW, Is the firewall completely disabled?  If not, try disabling it then test.
0
serendippityAuthor Commented:
Kfullarton and all:  SOLVED!  The reason why the computer was unable to map any user's home folder was because there was a USB multi-card reader attached and the home drive drive letter (H:) was already taken up by one of the drives Windows had created when the card reader was installed. I simply changed the drive letter of the (card reader) H: drive to J: and, hey presto, the user's home drive now appears. Thanks to all for your attempts to help me solve this mystery.
0
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.