• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 363
  • Last Modified:

Weblogic 8.1 SP5 -- EJB

Hi

I have deployed my ejb onto on a cluster with 2 server on different machine but when I test my web application,

1) I faced the following error on one of the server while it is working fine on another server.

2) when I check the Weblogic console, it say my ejb has been deployed successfully

3) however, when I click on the "Testing" tab in the EJB, it say the ejb has not been tested successfully.

Please advise. Lots of thanks for your help

<Apr 26, 2006 2:05:56 PM SGT> <Warning> <RMI> <BEA-080009> <Error thrown by RMI server: [BaseEJBObject] home: ReportSession_68t828_HomeImpl@1b02985 invoking: updateMainReport(Ljava.lang.String;Ljava.lang.String  >
[ERROR] Exception.java:handleException - 26042006@14051146031556267: java.lang.NoClassDefFoundError
at weblogic.rmi.internal.ServerRequest.sendReceive(ServerRequest.java:186)
0
glnnca
Asked:
glnnca
1 Solution
 
rama_krishna580Commented:
Hi,

This error message can be caused by inadequate file permissions OR
Include the lib path of java directory which contains tools.jar or dependent jar files in the classpath environment variable. This will solve the problem.

R.K
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tackle projects and never again get stuck behind a technical roadblock.
Join Now