Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

listen on port 1080

Posted on 2006-04-27
9
Medium Priority
?
1,322 Views
Last Modified: 2010-03-04
I have apache running on a solaris 9 server, also have sun calendar running on it, the calendar is using port 80 for web access to calendars so I had to change the apache
server to listen on port 1080. I added a seconed ip address and gave that IP address a name in the host file, then added a Address record in DNS for that name and IP address.

I can get to the apache home page by going to    http://my.server.com:1080   but want it to go by not putting in the port :1080

is there a way to create a alieas in DNS to map http://my.server.com  to http://my.server.com:1080 or do it in apache config?

Thanks,

0
Comment
Question by:bt707
  • 5
  • 4
9 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 16555666
this is not an DNS issue, you need a proxy or firwall for that
but if you already have a new IP, why do you need 1080 then?
0
 

Author Comment

by:bt707
ID: 16556010
I have Sun Iplanet Calendar running on port 80 and Apache running on port 1080

I have 2 ip's for 1 nic card

host file looks like this

127.0.0.1       localhost      
167.32.44.33   calendar.xyz.com  calendar   loghost
167.32.44.34   tst.xyz.com       loghost

in dns I have a Address record for each
167.32.44.33   calendar.xyz.com
167.32.44.34   tst.xyz.com


Problem is if I use a browser and put in:

http://calendar.xyz.com  it takes me to the Calendar login page which is correct.

If I put in

http://tst.xyz.com  it also takes me to the Calendar login page whic is NOT correct.

If I put in

http://tst.xyz.com:1080   then it takes me to the Apache home page.

I must not have something set correct here, but not seeing it.

Thanks












0
 

Author Comment

by:bt707
ID: 16556032
only thing I can see here is that may I have to have two seperate nic cards to do this with, but seems like I could do this somehow with only one?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 51

Expert Comment

by:ahoffmann
ID: 16557279
aha, I understand,
your calender web server probably listens on all interfaces, you can test with
  netstat -an
you need to configure your calender server so that it listens on one IP only
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 16557289
> .. may I have to have two seperate nic cards to do this with ..
no, you can use one NIC with multiple IPs
0
 

Author Comment

by:bt707
ID: 16557575
ahoffmann,

the calendar is only listing on port 80
calendar config:
service.http.port = "80"

I also tested by downing the calendar then going to

http://tst.xyz.com   # with calendar down I get connection refused with this, with calendar up I get the calendar page with this

http://tst.xyz.com:1080 # with this I can get to the page any time.

I just can't make it go to http://tst.xyz.com without putting a port with it and the calendar will not work if anything is bound and listing on port 80

seems like I need to change something in the apache.conf but it I let it listen to everything or 80 then it kills the calendar.
0
 

Author Comment

by:bt707
ID: 16557611
I just want to be able to give the apache servers page a address easy for the users, like  http://calendar-help.xyz.com and they can remember that and get to it
that way, don't want to have to put a port on the address, but that does work.
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 2000 total points
ID: 16557612
sorry, don't have a calender config handy, but ther must be somthing like
   server-http.ip=
you have to set it to one IP, if it is unset the server uses all IP (0.0.0.0)

After changeing that, restart the server. then netstat should show somthing like
  ... 167.32.44.33   80   LISTEN
then you can configure apache to listen on 167.32.44.34 port 80
after restart proofe again with netstat
0
 

Author Comment

by:bt707
ID: 16558467
Thanks ahoffmann,

That was correct, I just couldn't find it, after reading your post I went back and dug back into it and found the setting you said to look for.

on the Sun calendar it was:

service.listenaddr = "INADDR_ANY"  # so changed it from defaut "ANY" and put in my first address and now both services are listing on port 80.

Thanks,

0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
Screencast - Getting to Know the Pipeline
Is your OST file inaccessible, Need to transfer OST file from one computer to another? Want to convert OST file to PST? If the answer to any of the above question is yes, then look no further. With the help of Stellar OST to PST Converter, you can e…
Suggested Courses
Course of the Month11 days, 22 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question