Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 603
  • Last Modified:

Can't ping WS - Urgent 500 Points

I have a WK2 Server and some XP pro clients.  Everything works just fine almost all the time.
Since yesterday one of the clients keeps "loosing" connection to the server while connected to a database (Quickbooks). I used quotes for loose because when that happends the LAN icon in the taskbar doesn't show anything.

The client can:
 -Ping the server or any other WS
 -Remote desktop the server
 -Browse the internet (using the router)
 -Print to the network printer (IP)
 -Access mapped drives

The client cannot:
-be pinged or accessed from any PC or Server on the network

Right now I'm seating at the WS and have a Remote Desktop session to the Server. Is like from the WS to de Server everything is Ok, but for the server the ws doesn't exist.


The WS:
=====
 -WinXP pro SP2
 -Obatin IP (auto) working fine (I tried static IP and registering in the server's DNS but didn't solve my problem)
 -I turned off windows Firewall to discard any related problems
 -Tcp over Netbios - Enable
 -Ran Intel test on NIC - no errors
 -Ip config is Ok, checked gateway, dns, subnet etc.
 -This machine has been working just fine for at least a year problem s - Nobody else in the LAN  have a problem

Sadly someone cleaned the WS event log so I don't have much there except for:
-------------------------
Event ID: 11165
Source: DNSAPI

this might be (a) you are not allowed to update the specified DNS domain name, or (b) because the DNS server authoritative for this name does not support the DNS dynamic update protocol............
-------------------------
 
Please let me know what info you guys need. I have access to both WS and Server right now.
I will really appreciate any help ASAP.
0
qqso
Asked:
qqso
  • 7
  • 6
  • 3
  • +2
1 Solution
 
Rob WilliamsCommented:
Probably a DNS related issue. The particular error you referenced is often due to either DNS names not being dynamically updated or you have a simple domain name such as MyDomain rather than MyDomain.local  Active directory does not like the latter. However, a few things to try. I am assuming your sever is 2000 or 2003 and you have DNS and Active Directory installed

-When in doubt, disable the Windows firewall at least for test purposes

Make sure DNS is configured correctly. You can verify by going to a command prompt and enter
nslookup  YourServerName
or
nslookup YourDomainName
Should return the correct IP address

The following should be verified if there are any name resolution issues:
-The server's NIC should be configured with a static IP, the Internet router as the gateway, and only the server itself as the DNS server. Do not use an ISP DNS server here
-Each workstation should be configured using DHCP (obtain and IP address and DNS automatically) or if configured with static addresses; a static IP in the same subnet as the server, same subnet mask as the server, the gateway pointing to your Internet router, and the DNS server pointing ONLY to the server/domain controller. Again do not put an ISP's DNS server here
-In the DNS management console under Administrative tools, right click on the server name and choose properties. On the Forwarders tab add your ISP's DNS servers
If using DHCP it should be configured on the server, not the router
-DHCP on the server; open the DHCP management console on the server under Administrative tools and click on the server name to expand it, click on the scope to expand it, right click on scope options and choose configure options. On the general tab add the Internet router's IP in #003 router and the server's IP in #006 DNS Servers

Also where you have been having problems, on the workstations that have been having problems you should clear the DNS cache by entering at a command line  IPConfig  /flushdns

If you need immediate access to QuickBooks try connecting to it by IP rather than using UNC names. Try  \192.168.1.123\ShareName\QBData.qbw
0
 
Rob WilliamsCommented:
ps-  Also on the XP workstation under the properties for the network adapter, TCP/IP properties, advanced, DNS make sure "Register this connections addresses in DNS" is enabled.
0
 
qqsoAuthor Commented:
--Probably a DNS related issue.
     I can't ping using the WS IP address

---When in doubt, disable the Windows firewall at least for test purposes
    Is disabled

--- or you have a simple domain name such as MyDomain
    Simple domain

---Make sure DNS is configured correctly. You can verify by going to a command prompt and enter
    nslookup  YourServerName:

    C:\Documents and Settings\Administrator>nslookup MYSERVERNAME
    *** Can't find server name for address 192.168.3.5: Non-existent domain
    *** Default servers are not available
     Server:  UnKnown
     Address:  192.168.3.5

     Name:    MYSERVERNAME.MYDOMAIN
     Address:  192.168.3.5   <=== This is the correct address


---The server's NIC should be configured with a static IP
      192.168.3.5

---the Internet router as the gateway, and only the server itself as the DNS server. Do not use an ISP DNS server here.
      That's the way we have it

---Each workstation should be configured using DHCP (obtain and IP address and DNS automatically) or if configured with static addresses; a static IP in the same subnet as the server, same subnet mask as the server, the gateway pointing to your Internet router, and the DNS server pointing ONLY to the server/domain controller. Again do not put an ISP's DNS server here
      That's the way we have it


---In the DNS management console under Administrative tools, right click on the server name and choose properties. On the Forwarders tab add your ISP's DNS servers
      That's the way we have it

---If using DHCP it should be configured on the server, not the router
        We are using the router - (for a long time - no problems unitl yesterday and just with this WS, the other are
         working just fine)

---DHCP on the server; open the DHCP management console on the server under Administrative tools and click on the server name to expand it.
         Not installed

---Also where you have been having problems, on the workstations that have been having problems you should clear the DNS cache by entering at a command line  IPConfig  /flushdns
          Done that already - Just one WS with issues

---If you need immediate access to QuickBooks try connecting to it by IP rather than using UNC names. Try  \192.168.1.123\ShareName\QBData.qbw
        Thanks for the advice. But what I am looking for is to be able to ping the or access the share drives on the WS
         from the network
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
qqsoAuthor Commented:
"Register this connections addresses in DNS" is enabled
     IT IS
0
 
Rob WilliamsCommented:
Highly recommend switching DHCP to the server to allow dynamic updates to DNS, and more manageability to DHCP scope options, however, that has nothing to do with the basic problem.

If you cannot ping the workstation, by IP address, from from another, it has to a be a software firewall on the PC or a basic problem, with the network adapter. Can the problematic PC ping itself, both with 127.0.0.1 and it's own IP? You could try replacing or re-installing the network adapter, or resetting it by entering at a command prompt:
 Netsh  int  ip  reset  c:\reset.txt
This completely resets the network adapter and registry settings to it's initial installation state.

Sorry, NIC problem or firewall are only 2 suggestions I have for ping issue, assuming the problem is not pinging by name only.
0
 
danormeCommented:
to add to RobWill, I would not use Netbios under any circumstance, unless you are using older OS'.  Netbios creates tons of traffic and can cause issues in the long run.
0
 
qqsoAuthor Commented:
I can ping 127.0.0.1 and 192.168.3.80 (the DHCP assigned address)

I just replaced the NIC with no luck.

Where should I look next?
0
 
qqsoAuthor Commented:
Windows firewall is disabled
0
 
qqsoAuthor Commented:
I also changed the port on the switch?

I'm thinking in doing a peer-to-peer test between to WS. I'm just trying to rule out a layer 1 issue
0
 
Rob WilliamsCommented:
>>"Where should I look next?"
Don't know. I have a network analyzer I insert between the PC and switch that assist me, but I assume that is not an option. <G>
No chance of a duplicate IP, though that should be reported automatically?
0
 
qqsoAuthor Commented:
I installed just two PC connected using a small hub. I am going to call them BadPC and GoodPC.

BadPC can ping itself and GoodPC

GoodPC can ping itself but cannot ping BadPC.

I also have a Fluke network analyzer (but have to wait until tommorrow to bring it). At this point I am more incline to think is an isolated WS issue (maybe windows related) and not a network infrastructure issue.  

0
 
Rob WilliamsCommented:
Very bizarre, especially after swapping out the network card. Anxious to hear how you make out.
--Rob
0
 
HolcombglCommented:
It sound like an issue with the IPStack.
The following link will show you how to reset that
http://support.microsoft.com/default.aspx?scid=kb;en-us;299357

Are you positive there is no other firewall software on the PC something is killing it or its just not responding to the broadcast.
0
 
RiDo78Commented:
As far as I can tell your WS behaves exactly like an machine with a stealthed firewall:
- DHCP traffic is possible, so the WS is capable of sending and receiving broadcasts.
- MSTSC is working, so the WS is perfectly capable of sending and receiving TCP-traffic.
- Ping to itself is working, but ping from another machine is refused... so something is making a clear destinsion between local and remote traffic.

So I would let go the idea that there's something with the hardware and the network itself, as everything works as expected there. Instead I suggest you check the software installed for any software with possible firewall-functionality. Also disable the Internet Connection Service and all services it depends on and restart. Just to ensure that Windows Firewall is not running secretly.

If you cannot find anything, use hijackthis, adaware and/or spybot S&D to see if there's any unwanted software on the machine.
0
 
RiDo78Commented:
Sorry, I meant disable ICS and all services DEPENDING ON it... (not the services ICS depends on)
0
 
qqsoAuthor Commented:
It is working now!

I just removed and re-installed the "Client for Microsoft Networks" and now everything is working good.

Thanks for the help guys. I think RobWill deserves the points for his prompt response and continue follow-up since this morning.
0
 
RiDo78Commented:
Always nice... the world wide web... Right now I'm eating my lunch in the nightshift! (localtime 1:09 AM)

But I'm glad it is working now.
0
 
Rob WilliamsCommented:
Thanks qqso . Glad to hear you were able to resolve. Surprised Client for Microsoft Networks wasn't re-installed when you swapped network cards. I have a college who says uninstall the NIC, all associated clients, protocols, and services, reboot the computer 3 times, then re-install. Always thought it was overkill, but maybe he is right.
Cheers,
--Rob
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 7
  • 6
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now