Sun E4800 devalias boot problems

Posted on 2006-04-27
Last Modified: 2013-12-27
you know how it goes down, your life is hell until its up...

so with that being said, the E4800 was sitting at the ok prompt, It was due to a kernel panic.  I synced and reset the box and then at the "ok" prompt(auto-boot false, corp standard) I issued the standard "boot disk" and i kept getting a "ERROR: cannot open boot-device".  At that point I did a probe-scsi-all and my two 36gb fujitsu disks showed up.
Target 0
  Unit 0   Disk     FUJITSU MAN3367M SUN36G 1804
Target 1
  Unit 0   Disk     FUJITSU MAN3367M SUN36G 1804
Target 2
  Unit 0   Processor     Sun     D240            1.09
Target 3
  Unit 0   Processor     Sun     D240            1.09
Target 4
  Unit 0   Removable Tape     HP      C5683A          C005
Target 6
  Unit 0   Removable Read Only device    TOSHIBA DVD-ROM SD-M14011009

From there I did a devalias and this showed up....


{10} ok devalias
Alias                 Device Path
xdisk                 /ssm@0,0/pci@1c,700000/lpfc@3/sd@0,0
xnet                  /ssm@0,0/pci@19,700000/pci@1/SUNW,hme@0,1
diskc                 /ssm@0,0/pci@1c,700000/pci@1/SUNW,isptwo@4/sd@0,0
netc                  /ssm@0,0/pci@1c,700000/pci@1/SUNW,hme
cdrom                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@6,0:f
disk                  /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@0,0
disk0                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@0,0
disk1                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@1,0
disk2                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@2,0
disk3                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@3,0
disk4                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@4,0
disk5                 /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo@4/sd@5,0
def-cn                /sgcn
diskifp               /ssm@0,0/pci@19,700000/SUNW,ifp@1/ssd@0,0
diskglm               /ssm@0,0/pci@18,700000/scsi@2/disk@0,0
scsi                  /ssm@0,0/pci@18,700000/pci@1/SUNW,isptwo
net                   /ssm@0,0/pci@18,700000/pci@1/SUNW,hme

I tried to boot from disk, disk0 and disk1, but still got the same error.  Then I did a "printenv" and saw something interesting...

nvramrc=devalias vx-c2t1d0 /ssm@0,0/pci@19,700000/pci@1/SUNW,isptwo@4/sd@1,0:a

The root disks are mirrored with veritas(FYI), so a co-worker suggested i try to boot the exact path of the vx-c2t1d0 alias...and to my suprise, it worked?

e.g. <OK> boot /ssm@0,0/pci@19,700000/pci@1/SUNW,isptwo@4/sd@1,0:a

so I am trying to figure out what the ':a' signifies at the end of the device path, the dev alias look spot on except there missing the ':a' at the end of there, and they would not boot the system.  but booting to this exact device path with that ':a' brougt the box up.....what gives???? any ideas????
Question by:jedblack
    LVL 10

    Accepted Solution

    We stupid humans use the notation of s0, s1, s2, and so on to designate the partitions.  The OBP and OS (at a low level) as you see above use the notation :a (first partition), :b (second partition), and so to designate the partitions.  Ultimately, the c#t#d#s# files we all know and love (and understand) are symbolic links back to the ugly sd@#,#:<letter> files.

    This more then likely means your primary boot disk has failed.  You need to run vxstat to ascertain the state of all your VxVM devices.  Even though your root disks are mirrored the OBP doesn't know that.  It still hits one disk intially as part of the boot cycle.  Then /etc/system is read and the VxVM device drives are force loaded which makes the other mirror disk start to be used.
    LVL 27

    Expert Comment

    I suggest you should use 'boot', not 'boot disk', first command will select default boot device, which is probably your vx mirror alias.
    LVL 1

    Author Comment

    thanks Nukfor, I had a feeling the ':a' was probably slice notations....

    I told the sun tech the same thing about booting with regards to the vx mirrors.  He kept telling me that i should be booting to my vxmirror, and i kept saying that we are at the hardware level and not volume managment is running and i just need to boot from one of the disks on the internal array.  He was the one tha t finally suggested booting from that "nvramrc" variable that showed up in the 'printenv'

    I'm still confused as to how the hell this box was booted in the past if the engineer was not sure of the exact device path to the boot disk?  I mean if you look at the 'devalias', they are all pointing to pci@18, I booted the box from pci@19 from the printenv nvramrc variable (nvramrc=devalias vx-c2t1d0 /ssm@0,0/pci@19,700000/pci@1/SUNW,isptwo@4/sd@1,0:a), is pci@19 just another scsi path to the same disks/devices listed on pci@18 in the 'devalias'?

    also one last thing....what the heck does (nvramrc=devalias vx-c2t1d0 /ssm@0,0/pci@19,700000/pci@1/SUNW,isptwo@4/sd@1,0:a) mean?  I'm still sorta green with the sun hardware aspect, been doing os engineer work for awhile...but we have infrustructure engineers that handle the hardware setup/maintainence portion of the workload.... dont ya just love it when the workload micro-distributed(*sigh....)

    thanks guys/gals

    LVL 27

    Assisted Solution

    is pci@19 just another scsi path to the same disks/devices listed on pci@18 in the 'devalias'?
    not always true, it's platform and your connection topology dependant
    what is true - its another PCI card in another i/o board
    to check all your scsi devices run 'probe-scsi-all' and refer to its output, not to 'devalias'

    printenv boot-device

    this variable defines default boot device when you type 'boot' without parameters or when auto-boot is performed.
    Probably thats why this box was booted with a single 'boot' command. Or may be admin always was using 'boot vx-c2t1d0', who knows...

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    Join & Write a Comment

    Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
    FreeBSD on EC2 FreeBSD ( is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
    This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now