[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Dell Poweredge 4300 RAID Configuration - new OS and RAID setup

Posted on 2006-04-27
16
Medium Priority
?
3,446 Views
Last Modified: 2012-06-22
I am trying to reformat a Dell Poweredge 4300. I have wiped the drives clean. (3 SCSI)

I have a SCSI controller card(long type):
The name of the card is American Mega Trens Inc.
It has 2 16mb Dimms on the card.(32mb total)
It also has an Intel i960 as well.
There is a SCSI cable that is connected to the top of the card, this cable runs to the backpane.

The main question is....How do I configure my 3 SCSI drives? I want a RAID 5. I need to then run SErver 2003 setup.

I start the server. In the startup boot process, I press <CTRL>M
This brings me to the PERC BIOS Configuration Utility where is I try to make an new configuration.
I then select the 3 SCSI disks (they say READY) by pressing the space bar (they then say ONLINE)
I then end the configuration and press ENTER
I then go to another screen where it asks me to ACCEPT.
I press ENTER
I get an ERROR message saying.....ERROR WRITING CONFIGURATION  PRESS ANY KEY TO CONTINUE

How else can I configure my raid?
Am I even taking the proper approach?
Should I be doing this before I intstall the OS?
I am want to run OPEN MANAGEMENT ARRAY.

Can you explain step by step?
Starting from powering on the server......

Please help me.
Thanks
Mancoi




0
Comment
Question by:mancoi
  • 9
  • 6
16 Comments
 
LVL 30

Expert Comment

by:Duncan Meyers
ID: 16558514
>I get an ERROR message saying.....ERROR WRITING CONFIGURATION  PRESS ANY KEY TO CONTINUE
Hmmm, that isn't good.

The AMI PERC controllers store the RAID configuration in both NVRAM on the controller card and also on the discs themselves. Try erasing the existing configuration first. Go into Objects - Controller. You'll find an option (I don't remember exactly what it says) for 'Clear Configuration'. Then try configuring the array again.
0
 
LVL 30

Expert Comment

by:Duncan Meyers
ID: 16558541
You could also try the following: clear the configuration then update the NVRAM with COD information. Select "Objects", "Adapter", "Force Boot" then set this to "Yes". The Force Boot option will overwrite the NVRAM with the COD. COD = Configuration On Disk.

Note that your older card *may* not support this option.

(From solution ID ict6212 from http://www.lsilogic.com)
0
 

Author Comment

by:mancoi
ID: 16558630
No Luck,

I tried clear the configuration under the Objects-Adapter - Clear Configuration .....But it says NO EXISTING CONFIGURATION TO CLEAR

I even tried to go to CONFIGURE - Clear Configuration .....But it says NO EXISTING CONFIGURATION TO CLEAR

I could not find the "Force Boot"

What else would you like me to do?

What other info do you need to help me?

I even separatley formatted each SCSI.

Please help,,,
Thanks
<Mancoi
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 30

Expert Comment

by:Duncan Meyers
ID: 16558702
I don't think that this will work, but it's worth a try - you could try disconnecting the cache backup batteries, leaving it for 30 minutes or so then reconnect the batteries. You could also try flashing the firmware of the PERC card. The firmware and drivers are available here: http://supportapj.dell.com/support/downloads/devices.aspx?c=au&l=en&s=bsd&SystemID=PWE_PNT_PII_4300&os=WNET&osl=EN

You'll need the model of the card - from what you've posted it's either a PERC 2 or a PERC 2/DC - but check before you flash the card.

If neither of these work, I'd suggest that the card is faulty and will need to be replaced.
0
 

Expert Comment

by:ParksConsulting
ID: 16559471
Try going into the BIOS (probably F2) and looking at the settings for SCSI cards.  As I recall, if the PERC is installed it can be run in SCSI, RAID, or OFF mode.  It sounds like you were previously not using RAID functionality, so your setting may be SCSI.  Just a guess, but if not set to RAID then the configuration may be unmanageable.
0
 
LVL 30

Expert Comment

by:Duncan Meyers
ID: 16559784
>As I recall, if the PERC is installed it can be run in SCSI, RAID, or OFF mode.
True, but only for the Adaptec PERCs, unfortunately...
0
 

Author Comment

by:mancoi
ID: 16561187
I will test out all the replys tonight. ( EST.)

I hope there are other ways of thesting if that SCSI Controller is faulty.

Lets flash it and do as much to make sure we can honestly rule out the SCSI card. I hope it is not the card. I other Adaptec cards(short types) available. I also have a HP card ( long type) if needed.

You will see my reply later tonight after work.
Thanks
0
 

Author Comment

by:mancoi
ID: 16564888
How do I flash the card?
After I download from dell.com?
0
 

Author Comment

by:mancoi
ID: 16565297
No luck,
I took out the battery for only 10 Minutes, I am planning to take it out again for another 30 minutes.
I found that in the F2 BIOS that the SCSI were set to OFF...So I set them to ON (Primary and Secondary)
But no luck configuring the RAID

This is what my startup reads.......

RAID II controller Bios 1.63
Copyright American Megatrnds
Press <CTRL><M> to run configuration

HA-0 Type: PERC (bus 2 Dev 10) Standard FW u.84  DRAM = 32MB
Battery module is present on the adapter
0 logical drives found on host adapter
0 logical drives handled by Bios
unresolved configuration mismatch on adapter

Adaptec SCSI Bios v3.10.0
Press <CTRL><a> for SCSI select Utility
Slot    CH .......
01      A           5        0       nec     CDRomDrive:466


Scsi BIos not installed!
Adaptec AIC-9890 SCSI Bios 2.01 DEll 001
Press <CTRL><a>

No SCSI boot device found
SCSI Bios not installed.


I hope this helps.
What is my next step?
Thanks
Mancoi
0
 

Author Comment

by:mancoi
ID: 16566422
I press CRTL M
I go to the configure - New configuration - I select all 3 drives using the space bar - I press accept - enter - Save configuration

Then I get the Error

I have already formatted all 3 drives independently.

AM I doing anything wrong,

0
 

Author Comment

by:mancoi
ID: 16566489
Remember I have no OS installed.

If you think the problem is updating the driver or flash please let me know how I go about doing it.

Step by Step.

I hope someone can help me.

Thanks
Mancoi
0
 

Author Comment

by:mancoi
ID: 16566590
meyersd I thank you.

I got the new flash update and the configuration works now.

I need help on the next steps:

I made a new configuration.....
I initialized it......
What is next?
How should I go about installing Windows Server 2003?
Please walk me through the steps....from the very beginning.
Do I need to press F5 to install a third party RAID controller? or is it already done.

Anyone??
Thanks
Mancoi
0
 

Author Comment

by:mancoi
ID: 16566666
Sorry Sorry Sorry for all the questions

I should've asked them all in one. I keep running into more.

I created the logical drive and initialized it, but now should I set up the SCSI setup by pressing <CTRL><A>?

Thanks
Mancoi
0
 
LVL 30

Accepted Solution

by:
Duncan Meyers earned 2000 total points
ID: 16567370
>I got the new flash update and the configuration works now.
Excellent!

Download the driver for your card (the one that matches the firmware you loaded) and extract it to a floppy disc. Boot your server from the W2K3 CD. I would expect W2K3 to find the right driver for your card, but it may not - in whicch case, you need to hit F6 when prompted at the start of the installation process.

>I created the logical drive and initialized it, but now should I set up the SCSI setup by pressing <CTRL><A>?
<CTRL><A> affects the on-board Adaptec SCSI controller so you can safely ignore that.
0
 

Author Comment

by:mancoi
ID: 16569286
Well I ran into another road block....

I installed the OS and pressed F6 and inserted the floppy with the correct driver.... It said that Windows had newer drivers...

That was OK.

I then selected what partition which was C: to install OS.

I then selected the C: and it copied all the files.

It then rebooted and and the computer asked me to press F1 to continue  or F2 for system setup... ( should it enen ask me for a choice??)

I then press F1 and it says.....A DISK READ ERROR OCCURED....PRESS <CRTL><ALT><DEL> to REBOOT.

What do you think the problem is???

I am very confused
Thanks
Mancoi
0
 
LVL 30

Expert Comment

by:Duncan Meyers
ID: 16570611
Try the install again with the older driver and see how you go.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The question appears often enough, how do I transfer my data from my old server to the new server while preserving file shares, share permissions, and NTFS permisions.  Here are my tips for handling such a transfer.
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month18 days, 3 hours left to enroll

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question