• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2255
  • Last Modified:

gtk-config command not found

I am trying to install cheaps on ubuntu... i have reached a dead end on the following error, please help.
i had to install gcc for ubuntu to fight previous errors. Here is the log.

user1@localhost:/home/user1/cheops-0.61# ./configure
loading cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for fcntl.h... yes
checking for sys/ioctl.h... yes
checking for sys/time.h... yes
checking for unistd.h... yes
checking for working const... yes
checking for size_t... yes
checking whether time.h and sys/time.h may both be included... yes
checking for ucd-snmp... no.  -- snmp disabled
checking for gtk... ./configure: line 1309: gtk-config: command not found
configure: error: Check that gtk-config is in path
  • 3
  • 3
  • 2
1 Solution
jibranilyasAuthor Commented:
if someone wants to give me a link or explain the ./configure process, it will be much appreciated.
..."explain the ./configure process"...
./configure has nothing to do with your problem so the explanation of the ./configure innards wont help here.
The last line in your error message :
configure: error: Check that gtk-config is in path
is actually tyhe critical point!!!

So make sure to include the  full PATH to the gtk-configure in your environment variable(s) !

I'm not currently on Ubuntu box and I cant tell you exactly where to look for gtk-config file,  so I cannot give you  right answer, but if your gtk-configure ( executable) file is located , for instance, in:    
open your console ( terminal ) window and define the path environment variable by adding
in your path variable following this instruction :
You may have to run locate or slocate command to find where is the gtk-configure  file located within your
Ubuntu installation to give gcc installer right direction (path).
good luck
BTW , you cannot install gcc as a regular user ( in your case: user1 ) ; you have to install it with superuser ot root privilegies.
So try this comand to install gcc on your Ubuntu PC :
      sudo apt-get install gcc
      sudo apt-get install gcc-3.4

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

maybe you just don't have gtk-config?
it's part of the GTK library version 1.x (GTK 2.* doesn't have or need gtk-config, but programs written for GTK 1.* can't compile on GTK 2.* alone)
jibranilyasAuthor Commented:
nedvis and jack, i had gcc
atlast, i ran the following command to build the dependencies
'apt-get build-dep gcc'

after that, i was able to install my software.

thanks for the assistance.
congratulations! you should probably award points to nedvis
oh, you've already done it, sorry :)
jibranilyasAuthor Commented:
^ :D
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now