Cannot connect to DB2 second instance

Posted on 2006-04-28
Last Modified: 2012-06-22
  I had 5 databases running in the same instance. All good until now.

  I created a second instance and a third instances.

As I know for each instance, 2 processes has to start on db2start (db2tcpcm)

But for the second instance does not start any.

Any idea?

mariuso@themachine:~> ps aux | grep db2tcpcm
inst1 32421  0.0  0.0 44956  988 ?        S    Apr20   0:00 db2tcpcm
inst1 32422  0.0  0.0 44956  984 ?        S    Apr20   0:00 db2tcpcm
inst3 32423  0.0  0.0 44956  1984 ?        S    Apr20   0:00 db2tcpcm
inst3 32424  0.0  0.0 44956  1984 ?        S    Apr20   0:00 db2tcpcm

no db2tcpcm on inst2

Question by:mariuso
    LVL 7

    Expert Comment

    any messages in db2diag.log file ??
    LVL 2

    Author Comment

    I see:
    2006-04-27-   Instance:inst2   Node:000
    PID:22462(db2batch)   Appid:*LOCAL.inst2.060427131317
    oper_system_services  sqloclose   Probe:36

    errno: 0900 0000                                     ....

    2006-04-28-   Instance:inst2   Node:000
    PID:9776(db2wdog)   Appid:none
    oper_system_services  sqloRunInstance   Probe:98

    0100 0000                                     ....


    In jdbcerr.log:
    (Fri Apr 28 07:35:29 2006) pid= 32298 jdbcServiceConnection(): Invalid Request R
    eceived., einfo= 0 (client IP =

    LVL 7

    Expert Comment

    try dropping the instance and re-creating it.
    LVL 13

    Expert Comment

    you probably have run out of memory, therefore the service cannot start and neither can the instance.
    Or, make sure you have the node set to zero and that you have swithced instances

    db2 get instance-this command tells you which instance is the active instance
    to set the instance:
    set db2instance=INSTANCE NAME
    then, start the instance
    LVL 2

    Author Comment

    Solved in this way:

    enter 'db2set DB2COMM' If you get a line reading 'DB2COMM=tcpip' the server is enabled for TCP/IP communication.
    If not: enter 'db2set DB2COMM=tcpip' and then restart the database manager: db2stop<enter> db2start<enter>

    see also :

    Accepted Solution

    PAQed with points refunded (500)

    Community Support Moderator

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    November 2009 Recently, a question came up in the DB2 forum regarding the date format in DB2 UDB for AS/400.  Apparently in UDB LUW (Linux/Unix/Windows), the date format is a system-wide setting, and is not controlled at the session level.  I'm n…
    Recursive SQL in UDB/LUW (you can use 'recursive' and 'SQL' in the same sentence) A growing number of database queries lend themselves to recursive solutions.  It's not always easy to spot when recursion is called for, especially for people una…
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now