How to change the icon of each file's extension ?

I have Windows XP, and I installed WinZip, WinRar, and WinAce, and the compressed files' extensions (zip, rar, ace, others) have changed its icon 3 times... How can I change the icon of each file's extension ? (for example - for zip files I want the WinZip's icon; for rar files I want WinRar's icon). Thanks in advance.
asgarcymedAsked:
Who is Participating?
 
SheharyaarSaahilCommented:
open My Computer or Windows Explorer
Goto Tools>Folder Options>File Types
Select the File Type from the list for whom you want to change the icon
Click Advanced
Click Change Icon
Choose your desired icon and hit Ok
Apply and it should change the icons for these file types.
0
 
asgarcymedAuthor Commented:
SheharyaarSaahil  - I did the following steps :
"open My Computer or Windows Explorer
Goto Tools>Folder Options>File Types
Select the File Type from the list for whom you want to change the icon"
but I can not see the other steps you said :
"Click Advanced
Click Change Icon
Choose your desired icon and hit Ok"
The options that appear are :
New (to create a new extension)
Opens With - change
Restore (back to windows' default)
Can you help me ?
0
 
SheharyaarSaahilCommented:
Click the Restore button, and apply
It should be changed to Advanced now.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
asgarcymedAuthor Commented:
In the case of zip files, when I click the restore button and apply, I really can change the zip extension's icon and zip files will be opened with Windows itself. If I do open with => WinZip, the Advanced button disappears, and the icon goes wrong again and I can not change it... Maybe my registry needs a hack, but I know little about registry's hacks... What do you say about this ?
0
 
SheharyaarSaahilCommented:
if your zip files are set to open with WinZip, you shouldn't get that Restore button
open Winzip goto Options>Configuration>System and click on Associations button
you will get a list of file types, tick the ones which you want to associate with WinZip
apply and close WinZip, open explorer and goto File Types now
the Restore button should go now
if its not gone, restart your system and check now.
0
 
asgarcymedAuthor Commented:
Now it is OK, thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.