External USB drive 300gig - can only partition 24 gig

I use win 2000 pro with sp4 and have partitioned and formatted a number of external usb drives with between 200 and 300 gig.
I'm talking about the external boxes into which you install the harddisk of your choice.

This time I partitioned and then formatted the new 300 gig drive as usual with NTFS. It worked fine.
It was then taken home by a teacher and connected to windows ME, and did not work of course, needing to see FAT32.

So I reformatted the drive with FAT32 but received a warning on completion that there was not enough room.
So I deleted the partition, created a new one, (always leaving the last 7 meg untouched), tried formatting again. Same result.

Finally I discovered that when I try to alter the partition size, the size available instantly dropped to 24 gig and cannot be taken higher.

What's happening here?

I think the hardisk was a Maxtor.  The teacher installed the harddisk without moving the jumper from cable select to Master.
That did not stop me from formatting with NTFS successfully the first time round. I have since moved it to Master.
Alistair7Asked:
Who is Participating?
 
Gary CaseRetiredCommented:
"... When you partition a drive to fat 32 with a w2k or xp box, it will only allow you a max partition size of 24Gig's ..." ==> NO !!  The FAT-32 limit with XP is 32GB, not 24.

Not sure what's happened here -- there are a variety of possibilities, but not enough detail to isolate them.   What I'd suggest you do is install the drive on an internal controller in your XP system (one which you're CERTAIN has 48-bit LBA support);  "nuke" the drive (use dban from http://dban.sourceforge.net/); then create a 32GB FAT-32 partition; and then partition the rest with NTFS.   Then reinstall the drive in the external case.

One other question:  You didn't indicate whether you originally formatted this drive in the external case or on an internal connection.   If in the external case, then the case obviously has 48-bit LBA support.   If you formatted it with in internal connection; are you SURE the external case you're using has 48-bit LBA support ??
0
 
JimsZCommented:
Is the hard drive show full size in NTFS ?  Could it be that you had partitioned the drive on a machine where the bios has a hard drive size limit?  Some of the older machines didn't allow hard drives over a certain size so the machine couldn't see larger size
0
 
Alistair7Author Commented:
Yes it showed full size in NTFS.
But I can no longer format the full size with NTFS either.

My PC is a Pentium 4 and is used with other similar external harddrives 200 to 300 gig.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
rindiCommented:
When you partition a drive to fat 32 with a w2k or xp box, it will only allow you a max partition size of 24Gig's. Either create more partitions to use the full drive or use a win98 or me box to partition it to a larger size. Possibly you could make a lerger size if you use a 3rd party tool like acronis diskdrirector or similar.

http://acronis.com
0
 
Alistair7Author Commented:
Sorry for taking so long to respond.

garycase: I use win2000pro.  Everything has been done externally with the drive installed in the external case.

Is it worth me driving around to my friends home (the guy who bought the drive) and trying to install FAT32 on his winME PC?
0
 
Gary CaseRetiredCommented:
"I use win2000pro..." ==>  ahhh yes, I knew that -- just had a "senior moment" !!  (I was responding to rindi's comment which mentioned "w2k or XP")

If the PC this drive will be used on is a winME PC you may very well want to format the whole drive as FAT32.   However, first you need to get it to show the full size.   Did you try directly connecting it to an internal controller and using dban to "nuke" it ??

0
 
Alistair7Author Commented:
I removed the Maxtor, put it in another Pentium 4, ran THE ULTIMATE BOOT CD, ran one of the Maxtor disk utilities which enabled me to remove the existing partition and repartition FAT32 for windows ME.  I made three 100 gig partitions and then reinstalled the Maxtor into the external USB case.

Thanks for the help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.