Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 278
  • Last Modified:

URGENT!!! VPN PROBLEM WITH PIX AND ROUTER ADSL 837

hello to all.  I have a problem, profit not to mount the following VPN, with himself that work,
Somebody does not know because?  
the configuration of the PIX copies it of examples but there is line that stops my do not have much sense, because I do not have RADIUS
crypto map outside_map client configuration address initiate
crypto map outside_map client configuration address respond
crypto map outside_map client authentication RADIUS


Thanks for its aid!

RANGE REMOTE SITE: 192.168.3.0 *******OUT IP : 217.***.***.188 255.255.255.192

RANGE LOCAL SITE: 192.168.1.0  *******OUT IP : 195.**.**.70 255.255.255.248


***************************************************ROUTER 837***********************************************
Cisco827Menorca#show running-config
Building configuration...

Current configuration : 2231 bytes
!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco827Menorca
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip ips po max-events 100
no ftp-server write-enable
!
!
username admin privilege 15 password 7 ******
!
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key ****** address 195.**.**.70
!
!
crypto ipsec transform-set setmenorca esp-3des esp-sha-hmac
!
crypto map palma 10 ipsec-isakmp
 set peer 195.**.**.70
 set transform-set setmenorca
 match address 100
!
!
!
interface Ethernet0
 ip address 192.168.3.251 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 ip address 217.***.***.188 255.255.255.192
 ip nat outside
 ip virtual-reassembly
 crypto map palma
 pvc 8/32
  encapsulation aal5snap
 !
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
no ip http secure-server
ip nat inside source route-map nonat interface ATM0.1 overload
ip nat inside source static tcp 192.168.3.251 23 217.***.***.188 23 extendable
ip nat inside source static tcp 192.168.3.20 3389 217.***.***.188 3389 extendable
ip nat inside source static tcp 192.168.3.20 6129 217.***.***.188 6129 extendable
!
!
access-list 100 permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 120 deny   ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 120 permit ip any host 192.168.3.251
access-list 120 permit ip 192.168.3.0 0.0.0.255 any
snmp-server community private RO
snmp-server enable traps tty
route-map nonat permit 10
 match ip address 120
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end

Cisco827Menorca#

***************************************************PIX***********************************************

PIX Version 6.3(5)
interface ethernet0 auto shutdown
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password gjwrYCM7X6Ww82Zx encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix
domain-name comib.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit icmp any any unreachable
access-list outside_access_in permit icmp any any time-exceeded
access-list outside_access_in permit icmp any any
access-list outside_cryptomap_dyn_20 permit ip any 192.168.3.0 255.255.255.0
access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 195.**.**.70 255.255.255.248
ip address inside 192.168.1.251 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 195.***.***.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.23 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 30 ipsec-isakmp
crypto map outside_map 30 match address 102
crypto map outside_map 30 set peer 217.***.***.188
crypto map outside_map 30 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client configuration address initiate
crypto map outside_map client configuration address respond
crypto map outside_map client authentication RADIUS
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 217.***.***.188 netmask 255.225.255.192
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:dfa3cd1ba4ecbc6680b8cc8d7352ce3e
: end
pix#

0
lidium
Asked:
lidium
1 Solution
 
stressedout2004Commented:
On the PIX, run the following commands:

no crypto map outside_map client configuration address initiate
no crypto map outside_map client configuration address respond
no crypto map outside_map client authentication RADIUS
no crypto map outside_map 65535
no crypto dynamic-map outside_dyn_map 20
no access-list outside_cryptomap_dyn_20 permit ip any 192.168.3.0 255.255.255.0
isakmp identity address


The 1st five commands above are for remote access VPN, not site to site so you can remove them from the configuration.

Also, change the subnet mask of the peer ip to /32.

no isakmp key ******** address 217.***.***.188 netmask 255.225.255.192
isakmp key ******** address 217.***.***.188 netmask 255.225.255.255 no-xauth no-config-mode

Now, from the config, I noticed that interface e0 of the PIX is shutdown. Not sure if you did that deliberately or you forgot to enable it. But you definitely need that interface enable to have the VPNs working. Just run the command:

interface ethernet0 auto

On the router, you can get rid of the following line since it is really not doing anything and is incorrect.

access-list 120 permit ip any host 192.168.3.251

Other than that, the rest of the config looks good.

0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now