qfe0 will not hold the netmask setting through reboots

Posted on 2006-04-29
Last Modified: 2013-12-27
I have this F**** crazy issue, we use ldap to authenticate user and app daemon.  LDAP client is running through the qfe0 adatper to comm. with the LDAP server.  The only problem that the damn adapter is not holding the correct netmask setting.  Its supposed to be FFFFFc00( but instead it changes to ff000000( on every reboot, yet the IP address remains static!.  We have check the /etc/netmasks file and the correct setting seem to be in place but it still happens, any thoughts? i have never seen thsi problem before

have been up to 24hr already, dealing with SUN ...and there not sure what it is, they are thinking of deleting and creating the /etc/netmasks and /etc/hostname.qfe file again, dont see how that will really help?

please help guys...i wish i could give a trillion points for this one + lifetime supply of hotpockets
Question by:jedblack
    LVL 5

    Expert Comment

    And you've checked all of your /etc/init.d startup scripts?  I've worked in environments before where people would add configuration changes to routes and interfaces in rc2.d and rc3.d....why...I have no idea, but it can happen.  Also, did you check /etc/system?  I would just run a recursive grep in /etc and check for any file containing the qfe0 interface.  
    LVL 14

    Expert Comment

    it is possible that in the process of trouble shooting, that someone deleted and recreated the netmasks file, which would break it...

    the file /etc/netmasks is actually a link to /etc/inet/netmasks

    Check /etc/inet/netmasks

    the system looks at the file why we humans look at the link, if the link is broken that would explain your symptoms.

    Good Luck!
    LVL 48

    Expert Comment

    Show us the contents of /etc/inet/netmasks

    LVL 27

    Expert Comment

    Probably you are using 10.x.x.x network.
    Also it's possible that you have more than one interface in more than one 10.x.x.x network with different netmasks, in that case 'man netmasks' to get more info.

    Suppose you are using single network interface with IP address and netmask, and your hostname is 'myhost'
    My steps in resolution are the following:
    1) check /etc/netmask (it should contain line):
    # also please be shure that line above contains NEWLINE character at the end (not endo of file)
    # Note, that it ends by .152 which is your network address, not IP
    2) Check /etc/hostname.qfe0 (it should contain your hostname):
    #also be shure that this line is newline terminated
    3) Check /etc/hosts (it should contain same hostname and your IP address)  myhost

    4) Reboot if possible
    5) IF netmask still broken, check if /etc/netmasks is a link to /etc/inet/netmasks (as arthurjb) suggested
    6) IF netmasks file is OK, grep entire /etc/ directory for your hostname or your IP address  (myhost or

    LVL 16

    Expert Comment

    by:Hanno Schröder
    The /etc/netmasks (or better /etc/inet/netmasks) should contain
    Also, verify that /etc/nsswitch.con contains
     netmasks:      files
    If you see something like
     netmasks:      nis
    you either have to add "files" before the "nis" keywork or apply the change to your
    NIS map "networks" instead.

    Expert Comment

    Just to try and tackle this from a different direction you could place the netmask into the hostname.qfe0 file along with the ipaddress this should rule out links to the netmasks file and the hosts file.

    Contents of hostname.qfe0

    LVL 1

    Author Comment

    in my nsswitch.conf file, it states ldap, files

    is it possible ldap could be adjusting the netmask, i'm not sure if LDAP can do that?
    LVL 16

    Accepted Solution

    With LDAP you can (nearly) provide anything you like ;-)

    To make sure Solaris takes the entries in /etc/netmasks before asking LDAP, change it to read
     netmasks:   files ldap
    LVL 7

    Expert Comment

    > seems not to be a valid network number with that subnet mask...;)

    LVL 16

    Expert Comment

    by:Hanno Schröder
    XoF, if you want to use subnetting, you can use any netmask you like with this 10,* network.
    There is nothing that disallows you to do that ;-)
    LVL 1

    Author Comment

    it turns out it was LDAP that was changing the netmask settings.

    Featured Post

    Find Ransomware Secrets With All-Source Analysis

    Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

    Join & Write a Comment

    Suggested Solutions

    Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
    Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
    This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now