• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 581
  • Last Modified:

qfe0 will not hold the netmask setting through reboots

I have this F**** crazy issue, we use ldap to authenticate user and app daemon.  LDAP client is running through the qfe0 adatper to comm. with the LDAP server.  The only problem that the damn adapter is not holding the correct netmask setting.  Its supposed to be FFFFFc00(255.255.252.0) but instead it changes to ff000000(255.0.0.0) on every reboot, yet the IP address remains static!.  We have check the /etc/netmasks file and the correct setting seem to be in place but it still happens, any thoughts? i have never seen thsi problem before

have been up to 24hr already, dealing with SUN ...and there not sure what it is, they are thinking of deleting and creating the /etc/netmasks and /etc/hostname.qfe file again, dont see how that will really help?


please help guys...i wish i could give a trillion points for this one + lifetime supply of hotpockets
0
jedblack
Asked:
jedblack
1 Solution
 
devrick0Commented:
And you've checked all of your /etc/init.d startup scripts?  I've worked in environments before where people would add configuration changes to routes and interfaces in rc2.d and rc3.d....why...I have no idea, but it can happen.  Also, did you check /etc/system?  I would just run a recursive grep in /etc and check for any file containing the qfe0 interface.  
0
 
arthurjbCommented:
it is possible that in the process of trouble shooting, that someone deleted and recreated the netmasks file, which would break it...

the file /etc/netmasks is actually a link to /etc/inet/netmasks

Check /etc/inet/netmasks

the system looks at the file why we humans look at the link, if the link is broken that would explain your symptoms.

Good Luck!
0
 
TintinCommented:
Show us the contents of /etc/inet/netmasks

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
NopiusCommented:
Probably you are using 10.x.x.x network.
Also it's possible that you have more than one interface in more than one 10.x.x.x network with different netmasks, in that case 'man netmasks' to get more info.

Suppose you are using single network interface with IP address 10.20.30.153 and netmask 255.255.255.252, and your hostname is 'myhost'
My steps in resolution are the following:
1) check /etc/netmask (it should contain line):
10.20.30.152 255.255.255.252
# also please be shure that line above contains NEWLINE character at the end (not endo of file)
# Note, that it ends by .152 which is your network address, not IP
2) Check /etc/hostname.qfe0 (it should contain your hostname):
myhost
#also be shure that this line is newline terminated
3) Check /etc/hosts (it should contain same hostname and your IP address)
10.20.30.153  myhost

4) Reboot if possible
5) IF netmask still broken, check if /etc/netmasks is a link to /etc/inet/netmasks (as arthurjb) suggested
6) IF netmasks file is OK, grep entire /etc/ directory for your hostname or your IP address  (myhost or 10.20.30.153)



0
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
The /etc/netmasks (or better /etc/inet/netmasks) should contain
 10.20.30.0     255.255.252.0
Also, verify that /etc/nsswitch.con contains
 netmasks:      files
If you see something like
 netmasks:      nis
you either have to add "files" before the "nis" keywork or apply the change to your
NIS map "networks" instead.
0
 
birthstarCommented:
Just to try and tackle this from a different direction you could place the netmask into the hostname.qfe0 file along with the ipaddress this should rule out links to the netmasks file and the hosts file.

Contents of hostname.qfe0

10.10.10.152/22

0
 
jedblackAuthor Commented:
in my nsswitch.conf file, it states ldap, files

is it possible ldap could be adjusting the netmask, i'm not sure if LDAP can do that?
0
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
With LDAP you can (nearly) provide anything you like ;-)

To make sure Solaris takes the entries in /etc/netmasks before asking LDAP, change it to read
 netmasks:   files ldap
0
 
XoFCommented:
JustUnix:
> 10.20.30.0     255.255.252.0

10.20.30.0 seems not to be a valid network number with that subnet mask...;)

SCNR,
-XoF-
0
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
XoF, if you want to use subnetting, you can use any netmask you like with this 10,* network.
There is nothing that disallows you to do that ;-)
0
 
jedblackAuthor Commented:
it turns out it was LDAP that was changing the netmask settings.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now