• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2223
  • Last Modified:

Help with multilink ppp on Cisco 2821

Our office has 3 point-to-point T1's that connect us to our home office. The lines connect to a Cisco 2821 that is configured with a multilink ppp dialer interface. The router at the home office is the exact same model configured the same way. There is also some traffic to their mainframe that is in encapsulated in dlsw.

Here is the problem. We connected all three lines and only 2 of them are lighting up. The status shows that they are Administrativly up but Protocol is down. When I first discovered this problem it was Serial0/0 that was down and 0/1 and 0/2 were up. We did a reboot on the router the other day and now it's 0/1 that is down.

Traffic moves fine over the 2 lines that are connected and there are no drops or packet loss. I am just wndering why the 3rd line won't light up. I read online that sometimes ISP's do not allow multilinking on their circuits. I don't know if that is the case here since 2 of the 3 lines in the multilink work fine.

Here is the config on the router in our office. If anyone has any ideas as to something I may have missed or need to do different, please let me know.

!
version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Extranet1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -6
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
ip subnet-zero
!
!
no ip cef
no ip dhcp use vrf connected
!
!
no ip bootp server
no ip domain lookup
no ftp-server write-enable
!
username admin privilege 15 secret 5
username Extranet2 password 7
!
!
dlsw local-peer peer-id 10.90.90.1 lf 1500
dlsw remote-peer 0 tcp 10.131.128.4 lf 1500
dlsw bridge-group 45
dlsw udp-disable
!
interface Loopback0
 ip address 10.90.90.1 255.255.255.0
!
interface GigabitEthernet0/0
 description To LAN
 ip address 20.8.9.1 255.255.248.0
 ip route-cache flow
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
 bridge-group 45
 bridge-group 45 spanning-disabled
!
interface GigabitEthernet0/1
description Not Used
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
!
interface Serial0/0/0
 description 1st T1 To Home Office
 bandwidth 1536
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 dialer in-band
 dialer rotary-group 1
 dialer-group 1
 no fair-queue
 pulse-time 1
 no cdp enable
!
interface Serial0/1/0
 description 2nd T1 To Home Office
 bandwidth 1536
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 dialer in-band
 dialer rotary-group 1
 dialer-group 1
 no fair-queue
 pulse-time 1
 no cdp enable
!
interface Serial0/2/0
 description 3rd T1 To Home Office
 bandwidth 1536
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 dialer in-band
 dialer rotary-group 1
 dialer-group 1
 no fair-queue
 pulse-time 1
 no cdp enable
!
interface Dialer1
 description Multilink Dialer To Home Office
 bandwidth 4608
 ip address 192.168.1.1 255.255.255.252
 encapsulation ppp
 load-interval 30
 dialer in-band
 dialer idle-timeout 200000
 dialer map ip 192.168.1.2 name Extranet2 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp direction callout
 ppp multilink
 ppp multilink load-threshold 2 outbound
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.8.8.5
ip route 10.126.0.0 255.255.0.0 192.168.1.2
ip route 10.131.128.0 255.255.255.0 192.168.1.2
ip route 65.119.139.226 255.255.255.255 200.8.8.125
ip route 192.168.1.3 255.255.255.255 200.8.8.125
ip route 192.168.1.4 255.255.255.255 200.8.8.125
ip route 192.168.1.10 255.255.255.255 200.8.8.125
ip route 199.107.68.166 255.255.255.255 200.8.8.125
ip flow-export source GigabitEthernet0/0
ip flow-export version 5
ip flow-export destination 20.8.11.120 9996
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
logging trap debugging
dialer-list 1 protocol ip permit
snmp-server community netadmin RW
snmp-server community net RO
snmp-server enable traps tty
no cdp run
!
!
!
control-plane
!
bridge 45 protocol ieee
banner login CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!
!
line con 0
 login local
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login
 transport input telnet
!
no scheduler allocate
!
end
0
Hallmark1
Asked:
Hallmark1
  • 2
  • 2
2 Solutions
 
calvinetterCommented:
>I read online that sometimes ISP's do not allow multilinking on their circuits.
  Right. Your ISP must allow Multilink PPP & already be configured for it on their end for everything to work; also they'll typically provide you with an example config.

  Here's an example from a working 2821 (IOS 12.4) w/ multilink PPP configured, but you'll need to work with your ISP to get specifics for your scenario sorted out:

controller T1 0/0/0
  framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24

controller T1 0/1/0
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24

controller T1 0/2/0
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24

interface Multilink1
 ip address x.x.x.2 255.255.255.252
 ip nat outside
 no ip virtual-reassembly
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1
 ppp multilink mrru local 1524

interface Serial0/0/0:1
 no ip address
 encapsulation ppp
 ppp chap hostname myhost
 ppp multilink
 ppp multilink group 1

interface Serial0/1/0:1
 no ip address
 encapsulation ppp
 ppp chap hostname myhost
 ppp multilink
 ppp multilink group 1

interface Serial0/2/0:1
 no ip address
 encapsulation ppp
 ppp chap hostname myhost
 ppp multilink
 ppp multilink group 1

cheers
0
 
Hallmark1Author Commented:
Does the multilink/ISP issue still apply if the lines are point-to-point between buildings?
0
 
lrmooreCommented:
The issue with multilink is that both ends must be configured. You can't just set one end for multilink and not the other end.

BTW, IMHO, it is far more efficient to simply have two links with same cost routing and let CEF load balance for you. Far less CPU overhead than Multilink and just as good.
0
 
Hallmark1Author Commented:
Multilinking is setup on both ends. We own and configured the routers on both ends. As I mentioned, two of the 3 lines are working like they are supposed to and balancing traffic. The other one won't come up.

I send a message to our ISP to verify that they support what we are trying to do. I will let you know what they say.
0
 
lrmooreCommented:
If you're determined to go the Multilink direction, I'd certainly go with calvin's example of using multilink interfaces instead of the dialer interface that you are using.

Here's another example using a virtual template instead of multilink interface
http://www.cisco.com/en/US/tech/tk713/tk507/technologies_configuration_example09186a0080093d69.shtml

Here's a reference for IP CEF if you're interested
http://www.cisco.com/en/US/products/hw/modules/ps2033/prod_technical_reference09186a00800afeb7.html


0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now