No buffer space is available

Posted on 2006-04-30
Last Modified: 2008-02-01
Hi, I have problem with my Win2000 machine - P4 3 GHz, 1 GB RAM. After few hours of work I start to get "No buffer space is available" errors from various programs - Firefox, MS Access (connecting to Sybase database via TCP/IP), Java aplications etc.
I seems to me like the problem has started when I tried to minimize swap file usage after I have upgraded RAM from 512 MB to 1 GB. I have set swap file size to minimum (as I usually use far less memory than 1 GB) and the problem with "No buffer space is available" started to occure. I have increased swap size, but it didn't help.
I have checked for Serflog virus mentioned in Q_21648906 but didn't find it in my PC.

Any ideas before I do reinstall ?
Question by:Jan_Franek
    LVL 30

    Expert Comment

    remove that added RAM, as it is a suspect in the problem that you have.. when you do, is the experience the same?
    LVL 14

    Author Comment

    How can added RAM cause such behaviour ? Machine is stable, just this problem with buffers occurs.
    It seems to me like some internal system memory for these buffers was decreased when I minimizes swap size and didn't come back to normal after restoring swap size to normal.
    LVL 30

    Expert Comment

    well.that's what we're attempting to figure out... did you apply my comment?

    Expert Comment

    Check your Swap file and make it 1.5 times your total RAM
    Check your registry size as well, insure that it is not listing an abnormal number

    Any information from Task Manager as to what is using up your memory?
    Are you doing programming on system and have you recently written any programs or scripts that you have running?
    Does the problem present if you run in Safe Mode?
    LVL 14

    Author Comment

    I did try to remove added RAM but it didn't help.

    But I have solved my problem - my machine was scheduled for upgrade, I got new motherboard with embedded network card, so I had to install new drivers for motherboard and network and the problem has disappeared. I guess that reinstallation of network driver was crucial, because problem was clearly related to network communication.

    Accepted Solution

    Closed, 500 points refunded.
    The Experts Exchange
    Community Support Moderator of all Ages

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    As with any other System Center product, the installation for the Authoring Tool can be quite a pain sometimes. This article serves to help you avoid making these mistakes and hopefully save you a ton of time on troubleshooting :)  Step 1: Make sur…
    NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
    This video discusses moving either the default database or any database to a new volume.
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now