ip address / dns problems

Hi Experts,
I have my laptop (using xp) connected to the internet via a network cable into a 4 port modem that I have 2 desktop computers in also. The desktops are conecting and talking to each other no problem but the laptop won't connect and my msn messenger trouble shooter tells me that my 'default gateway appears to be offline'
I went into the LAN (appears that the LAN in 'Enabled') tcp/ip settings and tried to configure an ip address manually, but after getting that in there, now the msn error message is telling me that the ip address is ok, but the dns settings are at fault.

Not sure why this laptop was working fine, but now decides to not connect?
Any ideas ?
Who is Participating?
kgreeneitConnect With a Mentor Commented:
it seems that there may be a problem with the DHCP server on your network. The DHCP server is responsible for distributing IP information to pc's and it may be that the gateway address is not configured in DHCP correctly.

You could make a note of the IP address and subnet mask that is currently assigned to the laptop and then assign these exact details manually and also add the gateway address manually that the other pc's have.

Dont forget to add the DNS addresses that the other pc's are looking at either.

I'm guessing that the 4 port modem is the DHCP server and it would do no harm to get access to its login control panel and have a look at the DHCP and LAN settings on it. You should be able to get login details for your modem/router from the user manual supplied with it.

Hope this helps!

Hi there, make sure that in TCP/IP settings, that you have configured the IP address, subnet mask, default gateway and very important - DNS entries. It would do no harm to copy the ip configuration exactly from one of the other pc's that do work but make sure that the last digits of the IP address is different to all other devices on the network.

Then log into command prompt -'start', 'run', type 'command' and then hit 'ok' From here, type this:

ping gatewayaddress   {where gatewayaddress is the ip address of your gateway}

you should get 4 replies from the ping indicating network connectivity between the laptop and the gateway. If you don't get a reply, try disconnecting one of the pc's from the modem and connecting the laptop using the cable and modem port of one of the pc's that is working.

Also, make sure that the laptop isn't trying to use a wireless lan connection to get out - it would do no harm to disable any wireless lan connections in the network connections window while you are testing this problem.
zorro2250Author Commented:
Hi, thanks for your response.
I have checked the other 2 computers and they don't have any configurations on view as they are both set to 'obtain ip automatically' so when i 'ping' ...which address do I ping? can I ping one of the other computers by their name?
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

zorro2250Author Commented:
I tried to ping to and from the laptop but get the message " ping request could not find host ****. Please check te name and try again"
Not sure where to go from here.
 What it sounds like is that you use your laptop elsewhere and you have not released the old IP address.  Here is what you need to do.  

First, Set your laptop back to "Obtain an address automatically" for both the IP address and the DNS.  Once you do that, your laptop should start working.

When you go from one location to another, click on "Start", "Network Connections"

Double click on your Network Connection (Ethernet card), click on the "Support" Tab, then click on "Repair".

That will release the old connection and lok to create a new connection on the new network.

Good Luck

if the desktops work, and the laptop has dns problems, you need to compare their respective addresses in a command window.

(Windows) Start menu --> run --> cmd --> ipconfig/all

the laptops DNS IP Address may be different, if so change it; i would expect it to be the same as the default gateway or an isp address. You will need to reboot.

if you are still having problems, check the dns client in the services; you probably wont need to do this step.

(Control Panel) administrator tools --> services --> dns client ... you will want to double click it and set the startup type to Automatic, and then start the service.
zorro2250Author Commented:
immediateAction, I did all that and still no luck. set all the same settings as my desktop (with the exeption of changing the last digit on the ip address of course) and it still didn't work, so went back to set the tcp/ip settings to auto detect and nothing still. (also went to the admin tools/services/dns client etc) This is a real puzzle.
There is a difference between 'auto Detect" and "Obtain an Address automatically".  Please ensure that you are in the correct area.


What type of device are your laptop/desktop plug to? Is it router or switch? If they are plugged into a router, the default gateway is normally the ip address of the router.

Check your desktop by typing in "ipconfig /all" in the dos prompt. It will provide you with the information including IP address, DNS servers and Dault Gateway..

Make sure your laptop is reset back to get an ip automatically. Then plug the ethernet cable back to the it and do an ipconfig /all on the laptop. Check if it got an ip address. If it is not reboot the laptop and check again. Try different cable if you have to.

If you still not able to get ip address afterward, check when you plugged the laptop to the do you get a link light on the nic. If you do, it is possible that you DHCP server is not working correctly (the router) Try assigning a static ip address to the laptop.

Make sure you do not duplicate the ip address you already have for the 2 desktop. Enter the DNS server and gateway ip address that you got when checked on the desktop.

zorro2250Author Commented:
the computers are plugged into a router.
I have tried that with still no luck. One thing I have noticed however is that when I instruct the tcp/ip settings to 'obtain ip address auto' and then run the ipconfig/all, it tells me that the ip address is and the subnet mask is - the default gateway is simply blank and the DHCP server is ( different that both my desktops, which both have the same numbers)
hi there again, have a look at the following information on microsoft's website and see if it helps:

zorro2250Author Commented:
Thanks kgreeneit, I tried all that and all the settings were ok. now when I ipconfig/all I get an ip address and a subnet mask number but no default gateway number and that is what 'msn messenger' troubleshooter is telling me is wrong.
zorro2250Author Commented:
thanks. turns out that the port that the laptop was plugged into is faulty as i changed to the last port available and it worked. so don't know whats wrong with number 3 but hey, at least its working now!

good work mate.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.