Mail server access thru pix

Hello everyone.

  I am having a small problem on my pix.

  We have just installed a mail server (exchange) 111.222.333.62 (not actual) I have made the changes I believe are needed in the Pix but cannot get to the server from the web.

   Below is my config, Any suggestions

 PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 1111111 encrypted
passwd 11111111 encrypted
hostname pixfirewall
domain-name mypix
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list mypix_splitTunnelAcl permit ip 10.0.0.0 255.255.255.0 any
access-list outside_cryptomap_dyn_20 permit ip any 192.168.7.0 255.255.255.224
access-list inside_outbound_nat0_acl permit ip any 192.168.7.0 255.255.255.224
access-list fromoutside permit tcp any host 111.222.333.62 eq smtp
access-list fromoutside permit tcp any host 111.222.333.62 eq https
access-list fromoutside permit tcp any host 111.222.333.62 eq www
access-list fromoutside permit tcp any host 111.222.333.62 eq 81
pager lines 24
logging on
logging console emergencies
mtu outside 1500
mtu inside 1500
ip address outside 111.222.333.50 255.255.255.240
ip address inside 10.0.0.243 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 192.168.7.2-192.168.7.22
pdm location 10.0.0.242 255.255.255.255 inside
pdm location 192.168.7.0 255.255.255.224 outside
pdm location 10.0.0.0 255.0.0.0 inside
pdm logging errors 100
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 111.222.333.62 10.0.0.14 netmask 255.255.255.255 0 0
access-group fromoutside in interface outside
route outside 0.0.0.0 0.0.0.0 111.222.333.49 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.0.0.242 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup mypix address-pool VPN
vpngroup mypix dns-server 10.0.0.7 10.0.0.3
vpngroup mypix wins-server 10.0.0.7
vpngroup mypix default-domain mypix
vpngroup mypix split-tunnel mypix_splitTunnelAcl
vpngroup mypix idle-time 1800
vpngroup mypix password ********
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:00000000000000000000000000000000
: end
FPCSAsked:
Who is Participating?
 
lrmooreCommented:
You have all the components that you need:
 
no fixup protocol smtp 25     <= Disable fixup for Exchange - check
access-list fromoutside permit tcp any host 111.222.333.62 eq smtp <== allow smtp inbound to public ip - check
static (inside,outside) 111.222.333.62 10.0.0.14 netmask 255.255.255.255 0 0  <== static nat for public ip to private ip - check
access-group fromoutside in interface outside  <== acl actually applied to interface - check

Now check on the server itself to make sure it has the proper IP address, netmask and default gateway assigned to it.

Given:
 >ip address inside 10.0.0.243 255.255.255.0

Server IP is 10.0.0.14, mask 255.255.255.0, default gateway is 10.0.0.243
What do you have set for primary nameserver on this server? Public DNS, or a private DNS?

Also, check your domain here:  http://www.dnsreport.com  to make sure the correct MX records point to the correct public IP address




0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.