Firefox: QuickTime failed to initialize. Error # 0

Hi all,

I've encountered the following problem on a system running Firefox on Windows XP: when you go to a page that has Quicktime movie(s) embedded (not sure if that's the word; I mean, that you can play directly on the page, as opposed to clicking on a link to open the file), the following error message comes up:

QuickTime failed to initialize. Error # 0

Please make sure QuickTime is properly installed on this computer.

That's in one dialog box. After clicking OK, another dialog box comes up, with the message

The plug-in performed an illegal operation. You are strongly advised to restart Firefox.

and a checkbox to "not display this message again in the future", or something like that. (sorry, I'm not in front of the system right now)

This second dialog box apparently comes up once for each quicktime object in the page (or so it seems; I haven't counted them exactly, but in one page with several QT movies it came up several times, in another one with just one it came up only once)

Before this error came up, someone had installed iTunes on the system, but the error didn't start appearing immediately. Apparently the computer was running for about 3 days without any problems, although I suspect in that time the system wasn't rebooted, and after it was rebooted it started acting up. Before iTunes, QuickTime always worked correctly.

Before I started trying to fix this, the Firefox version was 1.0.x, I believe it was 1.0.7. In the process of trying to fix it I upgraded it to the latest version (1.5.2?)

QuickTime plays fine when running stand-alone, after clicking on a local MOV file; it also runs ok from inside IE (tested with the same sites I was trying Firefox on).

I tried, over and over and in different sequences, to uninstall and reinstall Firefox, QuickTime and iTunes. I tried erasing the directories for Firefox (c:\program files\mozilla firefox) and QuickTime (c:\program files\quicktime), as well as deleting some registry entries related to them, after uninstalling them, to try to get a clean installation. Nothing seemed to make any difference.

Any clues?
zabumbaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

war1Commented:
Greetings, zabumba !

After installing Firefox, you need to reinstall the Quicktime plugin.  Unistall the Quicktime plugin for Firefox. Then download and reinstall the plugin from here

http://www.apple.com/quicktime/download/standalone.html

Best wishes!
0
zabumbaAuthor Commented:
Hi war1, thanks for the input. As I said, I reinstalled Quicktime, several times. I'm not sure, though, what you mean by "uninstall the Quicktime plugin for Firefox". My understanding is that the only way to do that would be to uninstall all of Quicktime -- unless I were to manually delete de DLLs from the Firefox plugin directory -- which I did at least once.
0
war1Commented:
zabumba,

Have you uninstall QuickTime after you installed iTunes.  iTunes comes with QuickTime and may have done something with the original install of QuickTime.

Yes, you need to uninstall QuickTime from Add/Remove Programs.  Then use Windows Installer cleanup utility to remove the last bits of QuickTime
http://support.microsoft.com/default.aspx?kbid=290301

Then install the standalone QuickTime.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

zabumbaAuthor Commented:
I'll try running the cleanup utility, but I'm not too thrilled. As I said, I made sure I removed the directories and registry keys left over by the uninstallers.

And most of the times I uninstalled and reinstalled the software (as I described in the initial post) I reinstalled just the standalone Quicktime, and not iTunes, to keep it simpler.

What I'm thinking now is that I didn't wipe out the Firefox directory under the user's Application Data directory but, looking at the one in my computer, I can't see anything that seems like it could make any difference... But who knows; it's something to try.

I won't be seeing that computer again for a few days (and I want to make sure I have new stuff to try once I do get there), so all I can do for now is collect information, and sometimes ask the user, by e-mail or phone, to test something (nothing too technically complicated). I just wrote to him asking him to try to create a new Windows user and test that, to see if the problem is user-specific.

Thanks!
0
Marc ZCommented:
zabumba,
Here you go.  You may need to reset the Quicktime Browser plugins.

1. Close Firefox or Mozilla Suite.
2. Delete all "npqtplugin*.dll" files (npqtplugin.dll, npqtplugin2.dll, etc.) from your browser's installation directory plugins folder.
3. Delete all "npqtplugin*.dll" files from the Quicktime plugins folder (usually C:\Program Files\QuickTime\Plugins).
4. Go to "Start -> Control Panel -> Quicktime -> Browser (tab) -> Mime Settings" and reselect your preferred media types.

If you still have problems, close Firefox or Mozilla Suite, open the "Mozilla" or "Firefox" folder in the profile folder location and delete the file "pluginreg.dat".


This has some info to help you troubleshoot.  http://kb.mozillazine.org/Quicktime
http://forums.mozillazine.org/viewtopic.php?t=206210
0
war1Commented:
zabumba, any update?
0
zabumbaAuthor Commented:
Hi war1. Sorry, I still haven't had a chance to go see that computer. I'll post news I soon as I go there.
0
war1Commented:
zabumba, keep us undated.
0
zabumbaAuthor Commented:
Hi all, I tried what mtz1of4 suggested, but it didn't make any difference. I tried a few times.

If no one has a solution, can someone at least please direct me to the correct place to ask this question? (like the official Mozilla Firefox support forum)

Thanks a lot
0
Marc ZCommented:
http://forums.mozillazine.org/viewtopic.php?t=206210 Is from the Official Mozilla Support Forum.

Here is the standard diagnostic link also for Firefox.
[url=http://kb.mozillazine.org/Standard_diagnostic][u]Standard Diagnostic[/u][/url]


So you followed my above directions and are still getting that error?  What version of Quicktime?
0
Marc ZCommented:
0
war1Commented:
zabumba,

Did you followed what I posted above on Date: 05/01/2006 06:07PM PDT?
0
zabumbaAuthor Commented:
Ok: I tried to do what you suggested too, but after uninstalling Quicktimes or iTunes the regular way (add/remove programs) they don't show up on Microsoft Install Clean Up Utility, so there's nothing I can do from there. I tried once again uninstalling both of them, erasing all the files including pluginreg.dat and I still get exactly the same thing.

The Quicktime version is 7.0.4.80, about:plugins shows 7.0.4, npqtplugin.dll through npqtplugin7.dll. Firefox was 1.5.0.something and, while I was trying this, upgraded itself to 1.5.0.4. Windows XP Home, SP2.

Thanks folks for all your help.
0
Marc ZCommented:
You've got me stumped on this one.

If you've uninstalled and rebooted and then reinstalled quicktime and Firefox and then checked off the appropriate MIME types you want to use in Quicktimes Control Panel, I'm lost.
Maybe just try Default settings for the MIME types.

What extensions do you have installed?
0
Marc ZCommented:
This was one of many I could find on Apples site
http://discussions.apple.com/thread.jspa?messageID=2354054�
0
zabumbaAuthor Commented:
Hi mtz1of4,

The thing that bugs me is that the MIME Settings inside Quicktime won't let me uncheck the "quicktime" (.mov) option, so I can't really manually unregister it, apply the changes and then re-register it. I do change other filetypes to try to force a re-write of those settings, but I can't be 100% sure that it's physically re-registering the Quicktime file type itself.

The user doesn't have much installed in Firefox -- I think the only thing is the Real multimedia plugin(s).
0
Marc ZCommented:
You know what, it doesn't let me uncheck the .mov files in the MIME settings either, but what program do you have installed to play the Quicktime Movies? The only other thing I can think of at this point would be to go to Firefox, Tools->Options->Downloads->Download Actions->View & Edit Actions , select the .mov and then Change Action to either Open with Default Application or Use this Plug-in.

Have you seen that options page yet?
0
zabumbaAuthor Commented:
Hi mtz,

Sorry I haven't posted anything yet. Had to travel overseas (where I still am) due to an emergency health situation (things are under control now, fortunately). Will post news as soon as I can... Once again, sorry.
0
Marc ZCommented:
Thanks for the update.  Take your time and keep us in the loop.
0
Marc ZCommented:
Zabumba,

Is everything well?

Marc
0
zabumbaAuthor Commented:
Sorry, Marc.

Everything is alright... But I haven't had much time to look into this... I'd like to solve it eventually, but I just can't devote more resources to this at this moment; I don't have much time to either go to the person's to test and try things, nor to participate effectivel in an Internet forum... :(

 I assume it's bad practice, or even forbidden by policy, to leave a question opened indefinitely, am I right? Should I close it somehow? How would I go about this?

Thanks for your help, guys
0
Marc ZCommented:
We would like to be able to help, but if you won't have  access to your problem computer for a while, you might want to consider closing the question.    If you think you'll be able to get back to it within a week or so, just let us know, keep us in the loop and we'll be around.
Typically, if no one posts anything in a question anywhere from 21 days to months, a clean up crew will come by and remind and possibly close a question.  
See http://www.experts-exchange.com/help.jsp#hs5 for your options.

You may want to consider, the person you are helping may eventually work out the problem, give up on the application he/she is having problems with, or may find another solution.  Just let us know what you would like to do.
0
SowyCommented:
Hi,

Dunno if this is the right procedure - but I'm encountering the same exact problem as zabumba.  Already tried uninstall of Quicktime, removed the npqt plugins from both Quicktime and Firefox directories, and also pluginreg.dat, then reinstalled Quicktime and adjusted the MIME settings.

I still get the error when I try opening a page with a quicktime movie embedded -
Quicktime was not found. Error#1292804.  \n\n Please install Quicktime on this computer.  The another window - The plugin performed an illegal operation.  YOu are strongly advised to restart Firefox.  It's not Error#0 as above but I previously got the 0 and another number as well, but still the same symptom.

Any ideas on what I can do next?  I'm running WinXP, Firefox 1.5.0.6, QT 7.1.3 (and if I do about:plugins it also shows QT plugin 7.1.3, and the mov extension is associated with Quicktime.)

Any help would be really appreciated.  Thanks!
0
Marc ZCommented:
Sowy,

http://www.experts-exchange.com/help.jsp#hi39 will show you the way to get your questions answered.  Jumping in to another's question will only confuse and mess up both the original asker and the experts.  Please start your own posting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.