• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 327
  • Last Modified:

Cisco PIX site-to-site VPN problem

I'm trying to establish a site-to-site VPN between two PIX 506e.  PIX1 is brand-new.  PIX2 is existing and has a site-to-site VPN to another PIX.  I ran "sh crypto isakmp sa" and no tunnel exists.  When I run "sh crypto ipsec sa" everything looks ok.
Anyone have any ideas?

Once the tunnel is established, what is the best way to test it, when I really only have access to the two PIX's and not the devices behind them.

+++++++++++++++++++++
PIX1 config
+++++++++++++++++++++
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxxxxxxxx encrypted
hostname PIX1
domain-name PIX1.lcl
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list icmp permit ip any any
access-list inside permit tcp any any
access-list inside permit ip any any
access-list acl_in permit icmp any any
access-list outside permit tcp any host 98.98.98.173 eq www
access-list outside permit tcp any host 98.98.98.173 eq https
access-list outside permit tcp any host 98.98.98.173 eq ftp
access-list outside permit udp any host 98.98.98.173 eq 21
access-list outside permit tcp any host 98.98.98.173 eq ftp-data
access-list outside permit udp any host 98.98.98.173 eq 20
access-list outside permit tcp any host 98.98.98.173 eq smtp
access-list outside permit tcp any host 98.98.98.173 eq 50000
access-list outside permit udp any host 98.98.98.173 eq 50000
access-list outside permit tcp any host 98.98.98.173 eq 50001
access-list outside permit udp any host 98.98.98.173 eq 50001
access-list outside permit tcp any host 98.98.98.173 eq 50002
access-list outside permit udp any host 98.98.98.173 eq 50002
access-list outside permit tcp any host 98.98.98.173 eq 50003
access-list outside permit udp any host 98.98.98.173 eq 50003
access-list outside permit tcp any host 98.98.98.173 eq 50004
access-list outside permit udp any host 98.98.98.173 eq 50004
access-list outside deny ip any any
access-list 101 permit ip 10.1.4.0 255.255.255.0 10.1.3.0 255.255.255.0
access-list 102 permit ip 10.1.4.0 255.255.255.0 10.1.3.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 98.98.98.174 255.255.255.248
ip address inside 10.1.4.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 98.98.98.173 10.1.4.2 netmask 255.255.255.255 0 0
access-group outside in interface outside
access-group icmp in interface outside
access-group inside in interface inside
route outside 0.0.0.0 0.0.0.0 98.98.98.169 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set PIX1 esp-3des esp-md5-hmac
crypto map newmap2 15 ipsec-isakmp
crypto map newmap2 15 match address 102
crypto map newmap2 15 set peer 99.99.99.225
crypto map newmap2 15 set transform-set PIX1
crypto map newmap2 interface outside
isakmp enable outside
isakmp key ********** address 99.99.99.225 netmask 255.255.255.255
isakmp policy 15 authentication pre-share
isakmp policy 15 encryption 3des
isakmp policy 15 hash md5
isakmp policy 15 group 2
isakmp policy 15 lifetime 1000
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
console timeout 0

+++++++++++++++++++++
PIX2 config
+++++++++++++++++++++
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxxxxxx encrypted
hostname PIX2
domain-name PIX2.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit ip 10.1.3.0 255.255.255.0 192.168.21.0 255.255.255.0
access-list 100 permit ip 192.168.21.0 255.255.255.0 10.1.3.0 255.255.255.0
access-list 100 permit ip 10.1.3.0 255.255.255.0 10.1.4.0 255.255.255.0
access-list inbound permit tcp any host 99.99.99.226 eq smtp
access-list inbound permit tcp any host 99.99.99.226 eq 3389
access-list inbound permit tcp any host 99.99.99.226 eq www
access-list inbound permit tcp any host 99.99.99.227 eq www
access-list inbound permit tcp any host 99.99.99.227 eq 12321
access-list inbound permit tcp any host 99.99.99.227 eq https
access-list inbound permit icmp any any echo-reply
access-list inbound permit icmp any any time-exceeded
access-list inbound permit icmp any any echo
access-list inbound permit tcp any host 99.99.99.227 eq 3389
access-list inbound permit tcp any host 99.99.99.224 eq 3389
access-list inbound permit tcp any host 99.99.99.224 eq 444
access-list inbound permit tcp any host 99.99.99.224 eq https
access-list inbound permit tcp any host 99.99.99.224 eq 4125
access-list inbound permit tcp any host 99.99.99.224 eq smtp
access-list inbound permit tcp any host 99.99.99.224 eq www
access-list 120 permit ip 10.1.3.0 255.255.255.0 10.1.4.0 255.255.255.0
access-list 110 permit ip 10.1.3.0 255.255.255.0 192.168.21.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 99.99.99.225 255.255.255.128
ip address inside 10.1.3.23 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 99.99.99.226 10.1.3.12 netmask 255.255.255.255 0 0
static (inside,outside) 99.99.99.227 10.1.3.37 netmask 255.255.255.255 0 0
static (inside,outside) 99.99.99.224 10.1.3.3 netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 99.99.99.129 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 30 set transform-set myset
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 110
crypto map newmap 10 set peer 97.97.97.194
crypto map newmap 10 set transform-set myset
crypto map newmap 15 ipsec-isakmp
crypto map newmap 15 match address 120
crypto map newmap 15 set peer 98.98.98.174
crypto map newmap 15 set transform-set myset
crypto map newmap interface outside
isakmp enable outside
isakmp key ********** address 97.97.97.194 netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp key ********** address 98.98.98.174 netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet 10.1.3.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
console timeout 0
terminal width 80

0
blotto99
Asked:
blotto99
  • 4
  • 3
1 Solution
 
Freya28Commented:
try these 2 commands on your isakmp policy.  you have the identity address command on one but not hte other.

isakmp identity address
isakmp nat-traversal 20

i would also confirm the pre-shared key is the same on both sides.  try that and see what a sh crypto isakmp sa tells us
0
 
Freya28Commented:
also you have the isakmp key statements mismatched.
pix1  isakmp key ********** address 99.99.99.225 netmask 255.255.255.255

on this one you do not have no-xauth no-config-mode.  this should be the same on both sides of the tunnel
0
 
blotto99Author Commented:
On PIX1 I added:

isakmp identity address
isakmp nat-traversal 20
isakmp key *********** address 99.99.99.225 netmask 255.255.255.255 no-xauth no-config-mode

I removed and re-added the isakmp key on both sides so that I know the pre-shared key is the same, but still no tunnel.

I ran "sh crypto isakmp sa" and still 0 tunnels.

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Freya28Commented:
do a

debug crypto ipsec
debug crypto isakmp

post the results.  make sure you turn on logging

logging on
logging monitor
logging console

what is the status od the tunnel when you do a sh crypto isakmp sa?
0
 
blotto99Author Commented:
"sh crypto isakmp sa" shows 0 tunnels

Here is some info from the debug:

ISAKMP (0): beginning Main Mode exchange
crypto_isakmp_process_block:src:99.99.99.225, dest:98.98.98.174 spt:500 dpt:5
00
return status is IKMP_NO_ERR_NO_TRANSIPSEC(key_engine): request timer fired: cou
nt = 1,
  (identity) local= 98.98.98.174, remote= 99.99.99.225,
    local_proxy= 10.1.4.0/255.255.255.0/0/0 (type=4),
    remote_proxy= 10.1.3.0/255.255.255.0/0/0 (type=4)

ISAKMP (0): deleting SA: src 98.98.98.174, dst 99.99.99.225
ISADB: reaper checking SA 0xdfd41c, conn_id = 0  DELETE IT!

VPN Peer:ISAKMP: Peer Info for 99.99.99.225/500 not found - peers:0
IPSEC(key_engine): request timer fired: count = 2,
  (identity) local= 98.98.98.174, remote= 99.99.99.225,
    local_proxy= 10.1.4.0/255.255.255.0/0/0 (type=4),
    remote_proxy= 10.1.3.0/255.255.255.0/0/0 (type=4)

0
 
blotto99Author Commented:
I changed the "isakmp policy 10 group" from 2 to 1 on PIX1, so they both matched and that seems to have done the trick.  THANKS!
0
 
Freya28Commented:
i was jsut going to send you that.   thank you.  glad this was cleared up.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now