Studio11 on Solaris 8 problem

Hi Experts!
I am stuck installing Studio11 on Solaris 8. I installed Java 2 SDK 1.4.2.11 32 bit and then 64 bit following all the Sun's instructions.
Now when I want to install Studio11 I get different messages depending on the java version used.

The 32 bit version is at : /usr/j2se/bin
The 64 bit version is at: /usr/j2se/bin/sparcv9

If I put the 32 bit version first in my $PATH and run Studio11 installer I get, java.lang.NoClassDefFoundError
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:141)

and many more lines following.

If I put the 64 bit version in my $PATH, I get: Attach to native processs failed.

I am not sure what should be my $CLASSPATH and have tried different ones without much difference.

Please let me know if you know how to go about resolving this.



mehranalmasiAsked:
Who is Participating?
 
yuzhConnect With a Mentor Commented:
For Solaris 8, you need to apply the patchs list in:
http://docs.sun.com/source/819-3052/patches.html#91424

before you can install Studio11, you can find the details about the patch from:
http://sunsolve.sun.com/pub-cgi/show.pl?target=patchpage

just type in the patch number in "find patch", eg for 109147-37, type in
109147 to read the README file, and download the latest version.

0
 
yuzhCommented:
Have you apply patchs list in:

http://docs.sun.com/source/819-3052/patches.html

also please read the instructions in:
http://docs.sun.com/app/docs/doc/819-3052
0
 
yuzhCommented:
Make sure that you are running the correct Java version, type in
which java

and
java -version

If it is wrong, you need to set the PATH to use the correct Java version, eg:

PATH=/pathto/java 1.4.2_11/bin:$PATH
export PATH
and then  try again

0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
mehranalmasiAuthor Commented:
Is there anything in the errors that point to a patch incompatibility? For technical reasons. I prefer not to apply any patches to the OS unless if I am sure its needed.
0
 
NopiusCommented:
Possibly you are using non-standard locale.
use LANG=C and see what hapens after running application.
0
 
NopiusCommented:
also unset CLASSPATH if already set. I have no CLASSPATH or any JAVA_* variable, just java executable in PATH.
0
 
mehranalmasiAuthor Commented:
Hi Nopius,
I tried LANG=C and no CLASSPATH with no difference in result.
What troubles me is that I can not find any documentation that tells me exactly what causes the error "Attach to native processs failed."
My other confusion is the way java 64 bit version installed. As mentioned above, the 32 bit version is in /usr/j2se/bin while the installation of the 64 bit went to /usr/j2se/bin/sparcv9.

Does this mean that I may need the 32 bit version when I am working using 64 bit Solaris?

I have no problem with patching up the OS as yuzh has suggested but I have no solid reason to believe that my errors are caused from the lack of latest patches.
0
 
NopiusCommented:
About 64bit/32bit java, I know only that both versions should work fine in 64bit Solaris.

java.lang.NoClassDefFoundError - that's a problem, you may find in the Internet.
If you have sunsolve access, you may find mention of this error for some Java applications.
I agree with yuzh, try suggested patches. Why do you need them all?
Because they are all mentioned in 'Installation and Setup Guide for Solaris Platforms Sun Studio 11", it's a _requirement_ from Sun that guarantees successfull installation of sunstudio.
0
 
NopiusConnect With a Mentor Commented:
You may also ask, why it's a requirement :-)
Go here: http://docs.sun.com/source/819-3052/introduction.html#pgfId-11109
and read list of requirements, one of them is:
J2SE Technology  J2SE 1.4.2_08 technology or J2SE 5.0 Update 3 technology, and required OS patches
0
 
mehranalmasiAuthor Commented:
Apparently I have no choice but to install patches and report back when done.
May take some time...

thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.