• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 579
  • Last Modified:

Win2k Server - BAD_POOL_CALLER / DRIVER_IRQL_NOT_LESS_OR_EQUAL / DISK IS FULL

2 weeks ago we installed a HP 6402 controller into a HP ML370 G3 to connect a MSA. No drivers were installed at this time (phase 1 of an upgrade). Yesterday, users reported issues with the same server, not being able to save documents (Excel & Word) "Disk is full" but files could be copied onto and off of the server.

Our initial thoughts were that the Cisco Catalyst 4006's required a reboot along with the server. The issue of saving appeared to resolve itself. Today, further calls were made to report the same issue that occured yesterday - Microsoft Excel was issuing an error "Disk is full" when trying to save. The partition on the Windows 2000 Server had enough space to save and files could be copied via Explorer quite happily.

From this afternoon, the following errors have been occuring frequently but with no obvious instigating circumstances:

BSoD Stop error BAD_POOL_CALLER (0xC2)
BSoD Stop error DRIVER_IRQL_NOT_LESS_OR_EQUAL (0xD1) - Mvstdi5x.sys

MS articles pointed to device drivers, faulty memory, SCSI adapters, NICs etc.

We tried to catch the minidump file but the system was not generating this dump file - the server was ASR'ing and not going to physical dump of memory.
We applied the latest drivers from the HP support pack. We applied the MS rollup pack 1 to refresh any bad files.
We disabled AV from running
We tried to run memtest86 - no errors occured.
We tried re-seating all SCSI, NIC and RAM components in the server.
We deleted and re-installed the latest NIC drivers.

The issue was resolved when we removed the Antivirus software (McAfee Virus Scan 8.0) and re-installed it. It appears that ePO had auto-distributed a signature that the system did not react well with (signature 4751 or 4752).

The first sign of progress was that we were able to edit and save MS Office files without the "Disk is full" error message appearing.

A clean installation of Virus Scan was re-applied after confirming that all was OK.

During the last 14 hours we've read alot around this subject and found that the BAD_POOL_CALLER is a common error in various flavours of Windows the majority of the resolutions posted are related to:-

Faulty RAM - remember it could just be a single stick or the memory could just need re-seating
Drivers - any software / hardware that has been applied in the last few days - remember that some software won't kick in until a reboot is carried out.

To make life easier, if there is more that one of you managing / administering servers, make sure that you have change control procedures in place (a spreadsheet of who did what, when and why).

Another obvious tip is to make sure that you only change one thing at a time when troubleshooting.  It's much nicer to walk away from an issue knowing what fixed it (a bonus is to know what caused it too). Otherwise you'll just pray that the same mysterious issue doesn't re-occur.

thanks for reading :)
0
it-dept
Asked:
it-dept
  • 3
1 Solution
 
cpc2004Commented:
Refer the following case and it is the software of nVidia Firewall
http://www.windowsbbs.com/showthread.php?t=51550
0
 
cpc2004Commented:
Correction.
It is the software error at McAfee Anti-Virus Mini-Firewall
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now