• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4648
  • Last Modified:

"netdom query fsmo" returns error

Hi all,

When I try to run "netdom query fsmo" from the command prompt on a Windows Server 2003 SBS w/ SP1 installed, it returns an error:

Unable to update the password.  The value provided as the current password is incorrect.

Troubleshooting steps taken:
- Disabled Kerberos, rebooted, reset machine account (ala http://support.microsoft.com/default.aspx?scid=kb;en-us;325850)
- Raised domain functionality level to Windows 2003 native
- Reset the password of the administrator account I'm using

Any ideas?

Thanks,
Dave
0
dsstao
Asked:
dsstao
1 Solution
 
Jay_Jay70Commented:
any other errors you are noticing, can you run dcdiag and check all clears
0
 
Sam PanwarSr. Server AdministratorCommented:
Since ADPREP / FORESTPREP is failing we need to verify the FSMO roles. You can run NETDOM QUERY FSMO to do so. If this is fine run a DCDIAG /V as sometimes NETDOM QUERY FSMO will return the correct FSMO holder but when you run DCIDAG it will fail knows of FSMO holders test. If this is the case use
NTDSUTIL to seize the FSMO roles to itself.

http://www.computerperformance.co.uk/w2k3/W2K3_FSMO_Advice.htm
0
 
Jay_Jay70Commented:
forestprep? where did that come from :) did i miss something obvious here
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
dsstaoAuthor Commented:
No other errors in dcdiag... when I attempt netdom query fsmo, I get this:

Unable to update the password.  The value provide as the current password is incorrect.  The command failed to complete.

Indeed - where did "forestprep" come in?
0
 
Kini pradeepPrincipal Cloud and security consultantCommented:
hey check this out.
i am sure this will help resolve the problem.

http://support.microsoft.com/default.aspx?scid=kb;en-us;842715
0
 
dsstaoAuthor Commented:
Nah, all the admin shares were OK... I ended up calling MS and they're helping me fix it... so far they found duplicate name servers in DNS, one with an incorrect FQDN, plus an "A" record pointing to it.  Fixing that solved the netdom query fsmo problem.
0
 
Jay_Jay70Commented:
excellent, i am actually surprised that dcdiag didnt pick up on that dodgy pointer........

well done though, glad all is well
0
 
Jay_Jay70Commented:
no problem at all
0
 
GranModCommented:
Closed, 400 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now