Cannot get desktop to connect to wireless network.

Posted on 2006-05-02
Last Modified: 2012-06-27
OS: Windows 2000 Pro
Wireless PCI Card: AIRNET AWD154 802.11g
Cable Modem: Motorola Surfboard
Wireless Router: Linksys WRT54G v. 4
Wireless Range Extender: D-link DWL-G710 Wireless G Range Extender

The Linksys Wireless Router is at one end of the house, and about 150 feet away, the desktop is in a bedroom. The desktop receives a signal the Wireless Router, but it is weak and not reliable. The D-link Wireless Range Extender is located at the end of the hall, in a closet, about 20 feet away from the desktop. It picks up and amplifies the signal from the Linksys Router just fine.

Here is the physical setup:

Cable modem<------>Linksys Wireless Router))))))D-link Wireless Range Extender)))))AIRNET Wireless PCI Card<--->Desktop

This desktop can connect to the Router via patch cable, and then it connects to the Internet just fine. But running 150 feet of patch cable down the hall is unacceptable. Hence, the wireless solution. (Or, should I say, the wireless attempt.)

There are 2 wireless networks set up in this house, one for the Linksys Wireless Router, and another for the D-link Range Extender. But the desktop cannot connect to either one. There is a laptop which conncects wirelessly to the Linksys Wireless Router, but it cannot connect to the D-link Range Extender.

What is really curious is that the Wireless Utility provided by Airnet shows a very strong signal from the D-link Wireless Extender. But no matter what I try, I cannot connect to it.

Occasionally, the Linksys Router wireless shows up on the desktop's Airnet utility, as a weak signal. However, I can't connect to that one, either.

Both wireless networks are set up as encrypted networks. I try using the WEP key, as a 40-bit Passphrase, but I can't get a connection.

I got on the phone with D-link Tech Support, and they said I needed to call Linksys and see how to configure the Range Extender on the Linksys Wireless Router. I called Linksys, and after an hour of waiting, I was disconnected. I don't have time to repeat that attempt.

Surely, I have configured something incorrectly. What do I need to do? Thanks.
Question by:coderlen
    LVL 5

    Assisted Solution

    Have you tried initally making it an open (unsecure) connection? You should be able to connect with everything open, if you can't connect that way you might have a compatability issue. We have seen a Netgear wireless NIC not connect to a Westell WAP but the same NIC would connect to a Netgear WAP just fine. (Even in the incomaptability the Netgear could "see" the Westell but could never properly connect).
    LVL 4

    Author Comment

    No, I haven't tried an unsecure connection. I'll try that and see.

    I don't have the luxury of just running over to the computer and trying this. The setup is in a client's home, so I have to wait until I can make arrangements to get over there.

    Thanks for your response. Hopefully, there will be other responses as well, and then I can have a whole bunch of solutions to try.
    LVL 1

    Expert Comment

    I agree with The_IT_Garage, the first thing to try when troubleshooting wireless is to disable security.

    If I was there, I would also attempt changing the channels or even dropping down to 802.11b.  

    If you have the luxury, bring a portable USB Wireless device out there to test and eliminate possibilities.

    I'll admit I've never used an extender before.... and because the computer is a desktop, you probably don't have the luxury to "move" it and take the extender out of the picture and at least see if that particular card can connect to the router without it.  

    One question that's worth asking:  Does the client have a 900mhz phone in the house?  That can interfere with the wireless as well.  

    LVL 4

    Author Comment

    trivalent (Jason),

    OK, I'll try changing channels to see what happens the next time I'm there.

    I don't know what you mean by a "USB Wireless device". Please explain. I know that USB connections can be used in lieu of CAT5 cables on routers. For your information, I did bring a wireless laptop with me, and it also had trouble connecting to the Wireless Range Extender. It was able to connect to the router, both wirelessly and wired with a CAT5 cable. I just couldn't get it to connect to the Range Extender. That's what makes me think I haven't configured it right.

    I did move the desktop to the room where the router is. That's how I know that it can connect to the router & to the Internet via a CAT5 patch cable. But, no, I couldn't get the desktop to connect wirelessly to anything.

    I'll check the next time I'm there to see if the client has a 900 MHz phone. Thanks for that suggestion. However, the other wireless network works just fine.
    LVL 1

    Accepted Solution

    Oh, what I meant by a USB Wireless device was something resembling a USB-plugin Wireless adapter.  Belkin makes a handy one.  You plug it into an open USB port, XP detects it, set the configuration and voila' you have wireless access.  More handy than using an actual card that goes into a PCI slot in my opinion.

    All evidence seems to be pointing to this extender network by what I'm reading.

    I have stated before that I've never actually used an extender, but it seems odd to me that it would actually require its own network?  It seems like the more logical usage would be grabbing the existing signal and then simply.... well, boosting it.  If it has to create its own network to do that, then you would almost need... a router?  

    Good luck.

    LVL 13

    Assisted Solution

    by:Nick Denny
    If possible again, I would suggest to move the desktop to a range with a strong signal and try to connect wirelessly.

    If you are not even getting that far then surely you wont with the extender.

    As discussed, drop all security and all mac filtering. (At this point if security is an issue, you can simply remove the cable between the CM [cable modem] and the router, as in order to connect wirelessly you dont need to be "netted").

    Follow thru the setup software that came with the AIRNET card (or use the network config wizard if using windows to connect).

    If you still cannot connect directly to the router this way - then post back - as this needs to be sorted first.

    There are a whole host of reasons why wireless does not connect.
    LVL 13

    Expert Comment

    by:Nick Denny
    Sorry re my last post - I meant to move desktop to range of Linksys Router
    LVL 4

    Author Comment

    I need to remind you all of something. This is a Windows 2000 machine, NOT XP. So, a lot of things that work effortlessly with XP will not necessarily work on this Win 2000 box.

    trivalent (Jason), thanks for clearing up what you meant by a USB plug-in Wireless adapter. I don't happen to have one.
    D-link said in their setup instructions that you need to have your own separate network for the Extender. That's why I set it up that way.

    seriousnick, I did move the desktop to within range of the Linksys Wireless Router (See my original post). It detected the wireless network, with a very strong signal, but I couldn't connect. When I go out there tomorrow, I will try your suggestion (if my first attempts at configuration fail), dropping all security and filtering, to see what happens. I DID successfully connect to the desktop with a direct Ethernet cable from the Wireless Router. That is, I connected non-wirelessly to the Internet, directly via CAT5 cable. So, my wireless configuration is messed up.

    It just so happens that I also have in my shop another Windows 2000 machine, with a wireless card. I tried connecting it to my encrypted network using the Passphrase, and it failed. However, when I keyed in the 26-character HEX key, it connected perfectly. I'm now thinking that Windows 2000 has some flaw which doesn't allow wireless configuration via a Passphrase, although keying in the 26-character HEX key does successfully connect to the wireless network. So, I certainly will be testing keying in the 26-character HEX key tomorrow when I go to the client's.

    Thanks for the ideas. I will post back when I have tried the suggestions. But, trust me, if one solution works, I'm not wasting any more time out there. I've spent dozens of hours out there already on this problem, and I'm tired of it!

    LVL 4

    Author Comment

    OK, I just got back from the client's. I disconnected the D-link Extender, took it over to a working laptop, and connected it via Ethernet CAT5 cable. Then, I keyed in in an Internet Explorer window, and got into the configuration menu. I changed the channel from 6 to 7, and then selected a WEP Mode of "HEX" to see what the key would be in Hex.

    Over on the desktop, I ran Winsockxpfix, a free utility which repairs damaged Winsock files. Then I rebooted the machine.

    An error message comes up each time this machine boots. I have tried to fix it, but I don't have the Win 2000 CDs, so I just have to let it go. Here is the message:

    "Windows File Protection
    Files that are required for Windows to run properly have been replaced by unrecognized versions. To maintain system stability, Windows must restore the original versions of these files.

    Insert you Windows 2000 Professional CD now."

    The choices are 'Retry', 'More Information', and 'Cancel'. I chnose 'Cancel'.

    Then this error message comes up:

    "Windows File Protection
    You chose not to resotre the original versions of the files. This may affecty Windows stability. Are you sure you want to keep these unrecognized file versions?"

    The choices are 'Yes' and 'No'. I chose 'Yes'.

    The Wireless Configuration Utility showed the Channel as 7, just as I reconfigured it. Encryption was 'WEP'. But I still cannot connect to the Internet, either through Internet Explorer, or through Mozilla FireFox.

    Over in a DOS (Command prompt) window, ipconfig /all shows an 'Autoconfiguration IP Address' of, Subnet Mask as

    I went back to the Wireless Configuration Utility and chose a HEX key, and keyed it in. No joy. ipconfig showed the IP Address as After applying Winsockxpfix, the IP address was

    I rebooted the machine. I had to choose 'Restore Active Desktop'. The Wireless Configuration Utility showed 80 packets Sent, 0 Received.

    Then I reattached the D-link Extender to the laptop and configured it for a Non-secure connection. I did this by unchecking the 'WEP' checkbox. Then I plugged in the Extender and went to the desktop. Still no joy.

    Then I attached a Linksys Wireless-G Portable USB Adapter. This is a USB device with a little antennae for receiving wireless signals. I then disabled the other wireless PCI card.

    I gave up on the PCI card's Wireless Configuration Utility, and used a utility called "Boingo Wireless". I disabled encryption for the Dlink network. No joy. I tried the established network (which has a weak signal, which is the original reason for the Extender). I still couldn't connect to that network, either. There was even another unsecured signal put out by one of the neighbors, but I couldn't connect to it, either.

    I really feel like this is a problem with Windows 2000. Perhaps those messages I get when the computer boots up are the key to this problem. (You are probably reading this and wondering why I went past those messages. Well, I thought I could get away with it! Apparently I couldn't.)

    I suggested to the client that we install Window XP, which should recognize just about anything. The client will get back to me on that.

    Even though we didn't solve the problem here, I will award points for your suggestions. After all, your suggestions should have worked, if the OS wasn't getting in the way.

    trivaent gets the most points for the USB suggestion. That helped me determine that it wasn't me, after all. Thanks, guys.

    The_IT_Garage 125
    trivalent 250
    seriousnick 125

    LVL 1

    Expert Comment

    Hi Coderlen,

    The D-Link device needs some more configuration.  According to the "Quick Start Guide" , you need to "Click the radio button next to the SSID of the wireless network whose signal you wish to repeat." in the "Site Survey" area on the D-Link.

    The extender is operating in "infrastructure mode" by default and is like Jason said, a "repeater".

    Right now it doesn't know what you want it to repeat; you need to associate it with the Linksys network because it won't automatically start repeating the Linksys.

    See this document it explains everything (and the manual doesn't!!):

    LVL 4

    Author Comment


    Thanks for the further information. I wish I had that information when I was at the client's! It appears there are some steps I missed.

    In particular, there are 3 things I did not do:
    1.) I did not click on 'Site Survery'. This gives a very nice view of all available wireless networks.
    2.) The Site Survey states "Click the radio button next to the SSID of the of the wireless network whose signal you wish to repeat." I did not do that, and I certainly should have.
    3.) I chose a 5-character key for the Passphrase, and the instructions in your link specifically state that it should be 8-63 characters.

    I guess 'Better late than never'. Now, at least I have some specifics on what I should have done. Thanks for that link. Maybe I'll get another chance with the client, if their patience level is high.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
    This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…
    This video discusses moving either the default database or any database to a new volume.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    23 Experts available now in Live!

    Get 1:1 Help Now