[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13791
  • Last Modified:

restarting inetd

I made a change to my /etc/inet/inetd.conf on a solaris 8 server and restarted inetd with the follwoing

/usr/bin/pkill -HUP inetd
and tried
/usr/bin/kill -HUP 178

this does not kill the process ?  Is there anohter way of restarting inetd

Thanks

Mick
0
mickge
Asked:
mickge
1 Solution
 
BobHBCommented:
I  hardened a Solaris 8 box about 2 years ago and remember having the same problem.  I'll research my notes.

The best way would be to reboot the server; is that a possibility for you?
0
 
BobHBCommented:
I believe the very best and absolutely the safest way to restart inedt is to restart the machine.  My notes say (quoting somebody) is that this way the "sanity" of the machine is ensured since the startup scripts have a certain order and dependencies.  The inetd.conf file is started in /etc/rc2.d/S72inetsvc and itself controls the starting of quite a number of services, services which you would have to stop (or kill) by yourself if you didn't reboot.
0
 
BobHBCommented:
I believe the very best and absolutely the safest way to restart inedt is to restart the machine.  My notes say (quoting somebody) is that this way the "sanity" of the machine is ensured since the startup scripts have a certain order and dependencies.  The inetd.conf file is started in /etc/rc2.d/S72inetsvc and itself controls the starting of quite a number of services, services which you would have to stop (or kill) by yourself if you didn't reboot.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
durindilCommented:
you can use:

/etc/init.d/inetsvc restart

or

/etc/init.d/inetd restart
0
 
NukfrorCommented:
RTFM - A SIGHUP doesn't stop inetd - it makes it reread its configuration file and makes it take place immediately.
0
 
TintinCommented:
BobHB.

There's absolutely no need to reboot.  inetd doesn't start any services until it receives a connection on the appropriate port.

durindil

Solaris init scripts don't recognise 'restart', you have to do a 'stop' and 'start'

If you really want to stop/start inetd without effecting other services do:

/usr/bin/pkill -x -u 0 inetd
/usr/sbin/inetd -s

But as ahoffmann, has pointed out, the standard way to reread the configuration is to send a hangup signal to the inetd process.
0
 
mickgeAuthor Commented:
My mistake here lads.  I thought that the process was killed and restarted.  So I was looking at the timestamp of the process - not knowing that it just re read the config file.

Also, really should of looked more carefully at the config as it blocks telnet inbound and I was trying to telnet outbound after giving it the HUP - which is why I didnt think my kill had worked
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now