Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 244
  • Last Modified:

NLB causing IE to not load certain websites properly

I have two 2003 Terminal Servers running NLB and Session Directory.  Everything is working the way it's suppose to except there's one small problem:

When both servers are running, IE on both systems are unable to completely open certain websites.  The title bar of the website does appear, but the body never opens and IE continues to try to load the page without success or error.  But when I unplug the second server from the network, IE on the first server works normally.

Please help!!!
0
CapitalHospice
Asked:
CapitalHospice
  • 3
  • 3
  • 2
  • +1
1 Solution
 
mcp_jonCommented:
Which NLB are we talking about : Windows-Based or Hardware-Based ??

Best Regards !
0
 
PowerITCommented:
Can you paste you NLB configuration here: ports bound to which NIC, multiple NICs IP adresses, unicast/multicast, ...
+ also the network metrics.
A first hint which could solve your problem: the metric on the NIC's should not be set to automatic and the NIC which you reserve for outgoing traffic should have the lowest metric.

J.
0
 
markpower60Commented:
seems like a DNS resolution issue. did you verify TCP/IP settins as well as DNS forward or NLB settings?

Good luck
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
CapitalHospiceAuthor Commented:
It's Windows-based NLB.  There are two NICs per server and the TCP/IP settings are as follows:

SERVER1:

NIC1 properties:
Cluster Parameters= IP address 10.7.0.23 255.255.0.0; unicast
Host Parameters=  Priority (unique host id) is 2, no dedicated IP conifguration, Default state= started.
TCP/IP Properties= IP address 10.7.0.23 255.255.0.0 DG 10.7.0.1; Preferred DNS 10.7.0.17
Advanced TCP/IP settings= Interface metric is 2

NIC2 properties:
NLB not enabled
TCP/IP settings: 10.7.0.27 255.255.0.0; Preferred DNS 10.7.0.17
Advanced TCP/IP settings= Interface metric is 1

Server2 properties:

NIC1 properties:
Cluster Parameters= IP address 10.7.0.23 255.255.0.0; unicast
Host Parameters=  Priority (unique host id) is 1, no dedicated IP conifguration, Default state= started.
TCP/IP Properties= IP address 10.7.0.23 255.255.0.0 DG 10.7.0.1; Preferred DNS 10.7.0.17
Advanced TCP/IP settings= Interface metric is 2

NIC2 properties:
NLB not enabled
TCP/IP settings: 10.7.0.25 255.255.0.0; Preferred DNS 10.7.0.17
Advanced TCP/IP settings= Interface metric is 1

Thanks!
0
 
PowerITCommented:
That looks good except for one thing: you should disable the default gateway on the NLB adapter (leave it empty) - NIC1 in your case - and enable it on the NIC for outbound traffic (NIC2 for you).

J.

0
 
mcp_jonCommented:
You should never have two Gateways on the same Windows System :)

Do what PowerIT stated and you'll be fine, however, I must warn you that Windows NLB is very tricky, but I see you already got it because you are using two NIC 's :D

Best Regards !
0
 
CapitalHospiceAuthor Commented:
So all I need to do is move the Default Gateway from NLB adapter to the administrative adapter (NIC1 to NIC2) for each server?  I will try it tonight during network maintenance and keep you posted!  Thank you gentlemen!
0
 
mcp_jonCommented:
No problem !

Just keep it coming !

Best Regards !
0
 
CapitalHospiceAuthor Commented:
It worked! It worked!  Moving the Default Gateway setting to the non-NLB adapter did the trick!  Thank you so much!
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now