dcpromo no promo

Posted on 2006-05-02
Last Modified: 2010-07-27
Short and sweet. I have a small domain with one 2K DC. The server is being replaced with a new 2K3 server. I planned to run dcpromo on the 2K3 DC, migrate all server roles, and then run dcpromo (demote) the old 2K server. I ran 'adprep /forestPrep', 'adprep /domainPrep', and 'adprep /domainPrep /gpprep'. No errors. I also ran 'dcdiag /s:server' and passed all tests.

However, when I run dcpromo on the 2K3 server, it fails. I get this error message:
"The version of the Active Directory schema of the source forest is not compatable with the version of Active Directory on this computer."

It further tells me to run adprep on the schema master. I tried to run the adprep commands again and get this message:

Forest-wide information has already been updated.
Adprep did not attempt to rerun this operation.

How can I promote the new server if it doesn't recognize that the tools have been run? I did attempt to run dcpromo once before remembering to run the adprep tool. After running the tools, I rebooted the 2K3 server, in case there was some kind of cached results, but it still fails, and I have tried 3-4 times.
Question by:rwhipple
    LVL 2

    Expert Comment

    Do you have Service pack 4 on th W2k server and Sp1 on the Win2003 server?

    Are you running the adprep command on the old W2k  or on the new Win2003?

    Before you can promote an additional Windows Server 2003 domain controller into a Windows 2000 forest,
    you must successfully run adprep /forestprep on the schema operations master and run adprep /domainprep
    on the infrastructure master in the Windows 2000 forest...

    You should check all of the steps in this;en-us;555040

    Good luck!

    LVL 4

    Expert Comment

    you have to run the dcpromo from the second server cd  (Windows 2003 server) on the 2k box. There is a new version of dcpromo on there.
    LVL 1

    Author Comment

    Both servers are fully up-to-date on all patches and service packs.

    I ran adprep on the old 2K server. adprep can only be run on a domain controller.

    I have only one server/DC, so it holds all the server roles.

    Microsoft needs to get their proof readers on that article. Anyway, typos notwithstanding, while it seemed more aimed at upgrading an existing DC, I went through the different points listed. The only suggestion that I found that I didn't already meet was WINS. I went ahead a verified that WINS was running on the new (2K3) server, and made sure that both servers ipconfig knew where to look for WINS. Unfortunately, it still failed.

    The only remaining point that may be important from the article was whether or not the 2K3 AD attributes were added to the old 2K DC. How can you tell, and more importantly, since adprep will not run on that server again, if the attributes are not there, how can I force them?

    JD76 - I shall keep that in mind, but until I can promote the new (2K3) server, I don't want to demote the old (2K) server.
    LVL 5

    Accepted Solution

    If you are running Windows 2003 R2, then the ADPREP that you must run for the domain and forest is located on the R2 (2nd CD). I had this same error as you weeks ago.

    See this post
    LVL 1

    Author Comment

    Not the adprep.exe that is in the i386 folder, the adprep.exe that's hidden on the second CD. You gotta love Microsoft! (You're not allowed to dissent.)

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
    In this article we will discuss all things related to StageFright bug, the most vulnerable bug of android devices.
    In this sixth video of the Xpdf series, we discuss and demonstrate the PDFtoPNG utility, which converts a multi-page PDF file to separate color, grayscale, or monochrome PNG files, creating one PNG file for each page in the PDF. It does this via a c…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now