libintl.so on HP-UX

Hi Members,

I couldn't find a TA for HP-UX. Hence posting it here.

This is the error when I invoke Bash shell in HP-UX 11.2.

"/usr/lib/hpux32/dld.so: Unable to find library 'libintl.so'  "

I tried searching for the library and couldn't find it. Searching in the net took me to "gettext" and "libiconv" tools. Both are installed and this hasn' solved the problem.

I also modified SHLIB_PATH to include /usr/lib/hpux32. This did not work as the Shared Library is not present.

Any pointers willbe highly appreciated.

LVL 12
catchmeifuwantAsked:
Who is Participating?
 
yuzhConnect With a Mentor Commented:
The GNU bash need to have gettext libgcc libiconv packages installed, you can downlaod them (binary package) including bash from:

http://hpux.cs.utah.edu/hppd/hpux/Shells/bash-3.1.16/

and a lot more freeware for HP-UX from the same site.

0
 
biraConnect With a Mentor Commented:
The libintl.so shared object provided wide-character translation. This functionality now resides in libc on Solaris systems.


HP-UX does not have a libintl.so shared object. Some of the message-handling functions as identified are not present on HP-UX by default.

Most of the wide-character functionality is present in libc.so on HP-UX systems. You can alse get the same functionality as the functions on Solaris systems from the GNU gettext package.

take a look at this URL
http://www.gnu.org/software/gettext/gettext.html
0
 
catchmeifuwantAuthor Commented:
thanks both. I fixed the problem by installing gcc.

I split the points for your response.
0
 
jskang0lCommented:
FYI in case some one else comes across this thread. The referenced URL to a system at utah.edu no longer exists.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.