?
Solved

Linksys can connect to AP but get private IP

Posted on 2006-05-02
5
Medium Priority
?
496 Views
Last Modified: 2012-05-05
Hi i have a linksys WRT54GS (uk version) - net update told me i did not need any more firmware
This computer - (XP Pro) - Linksys WRT54GS
Other computer - XP Home - Linksys WUSB54G
Second computer, after running the the setup wizard...it connects to the AP, but says cannot locate the internet. IP Config either comes back as 0.0.0.0 or as a 169.x.x.x address.
Everything has been uninstalled and re-installed, and re-booted. Router has been reset, and re-programmed using the CD, just changed default IP range on the router.
From second PC i cannot ping the router 192.168.16.1

Its as if the router is not answering DHCP requests from the second PC
0
Comment
Question by:j4jack
  • 3
5 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 16589672
>changed default IP range on the router.
Did you change both the LAN ip address and the DHCP addresses?
0
 
LVL 13

Accepted Solution

by:
Nick Denny earned 2000 total points
ID: 16592518
==>  "it connects to the AP"   ==> "comes back as 0.0.0.0 or as a 169.x.x.x address."

This is conflicting information. 0.0.0.0 = acquiring IP,  169.x.x.x = "Limited or No connectivity" - (read "no connectivity" for this).

By "AP" do you mean the WRT54GS router?

Have you checked that mac filtering has not been enabled (shouldn't default to enabled after a factory reset).

Is the WUSB54G set to obtain an IP automatically?

Might be worth some research into "Limited or No connectivity".

http://www.pchell.com/support/limitedconnectivity.shtml
http://support.microsoft.com/?kbid=892896

or corrupt winsock
http://www.spychecker.com/program/winsockxpfix.html
0
 
LVL 13

Expert Comment

by:Nick Denny
ID: 16592556
There are actually  many many other reasons this may not be working.

Does the XP pro PC receive an IP from the router ok or is it manually assigned?
How may IP's are allowed in the router?
Is the DHCP table full?
Can you ping the router from the 1st computer?
Have you set any encryption?
Has this connection ever worked before?
Is this new equipment?
Maybe faulty WUSB54G if 1st PC is ok?
Can you connect wired from 2nd PC?
"but says cannot locate the internet" - how is it saying this? What error message?


0
 
LVL 1

Author Comment

by:j4jack
ID: 16594625
In the end i did a factory reset on the device again, and ran the wisock fix.....then it worked fine :) thanks.
0
 
LVL 13

Expert Comment

by:Nick Denny
ID: 16594632
Nice 1 and thx  :)
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question