[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 394
  • Last Modified:

file replication on windows 2003 domain controllers

We have two domain controllers.  SERVER1 is the GC server.  SERVER2 is the DNS and WINS server.
Every week or so the AD domain controller SERVER1 start incrementing 13508 errors.
   
The File Replication Service is having trouble enabling replication from SERVER2 to SERVER1 for c:\windows\sysvol\domain using the DNS name SERVER2.domain.com. FRS will keep retrying.
 Following are some of the reasons you would see this warning.
 
 [1] FRS can not correctly resolve the DNS name SERVER2.domain.com from this computer.
 [2] FRS is not running on SERVER2.domain.com.
 [3] The topology information in the Active Directory for this replica has not yet replicated to all the Domain Controllers.
 
This indicates they cannot replicate AND cannot resolve - HOWEVER the servers can ping each other and can resolve each other both via ip or FQDN. This nonsense started about 4 minutes after the servers were booted Saturday morning and after it incremented 13516 - which says they are communicating.

Microsoft says that 13508 is cool as long as it is followed by a 13509....eventually.  I have never seen a 13509.  Microsoft offers a variety of tools to probe and troubleshoot but they all come up clean.   None make the errors go away.

I have tried:

Net diag
Dc diag
ntfrsutl ds <server name>
repadmin /queue <server name>
repadmin /showreps

On SERVER2 the following error increments:

Event ID 13568

The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.
 
 Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"
 Replica root path is   : "c:\windows\sysvol\domain"
 Replica root volume is : "\\.\C:"
 A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons.
 
 [1] Volume "\\.\C:" has been formatted.
 [2] The NTFS USN journal on volume "\\.\C:" has been deleted.
 [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal.
 [4] File Replication Service was not running on this computer for a long time.
 [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:".
 Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state.
 [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service.
 [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set.
 
WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again.
 
To change this registry parameter, run regedit.
 
Click on Start, Run and type regedit.
 
Expand HKEY_LOCAL_MACHINE.
Click down the key path:
   "System\CurrentControlSet\Services\NtFrs\Parameters"
Double click on the value name
   "Enable Journal Wrap Automatic Restore"
and update the value.
 
If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item.
 Type the value name exactly as shown above.

Does anyone know if the actions suggested by the error log are a safe thing to do?


0
wpstech
Asked:
wpstech
  • 2
1 Solution
 
Netman66Commented:
Yes.  In cases of Journal Wrap (as above) just set that registry key and reboot the server.  You should see it clear up.

As for the resolution issues, servers use GUIDs to find each other.  The errors show the friendly names, but you want to make sure the server GUID is registered in DNS.  This is as simple as looking at the Forward Lookup zone and finding all the GUIDs and matching IPs to servernames in there.  If all GUIDs are accounted for then you should be okay.

Let us know.
0
 
dooleydogCommented:
Reboot is not necessary, you can stop and restart the File Replication Service and you do not have to bounce the box.

I do this at least once a week at my job, yes lots of servers...

Good Luck,
0
 
wpstechAuthor Commented:
The problems start four minutes AFTER rebooting......

Seems like if the GUID was a problem then DC DIAG would not pass

The GUIDs are all accounted for - I will set the registry key reboot if you think it is safe
0
 
wpstechAuthor Commented:
you guys are awesome - set the registry key and rebooted and have not had a problem in a week.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now