[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 318
  • Last Modified:

Confiuring FTP on RedHat AS 2.1

I need to move a few very large files about 20 feet from a Windows machine to a Linux RedHat AS2.1 server.  I installed wu-ftp and it appears to be running.  However, when I attempt to connect from the Windows machine, like    "ftp 192.168.1.10"  I get a message "Connected to 192.168.1.10" immediately followed by "Connection closed by remote host."

Is there a configuration file required to specify addresses allowed into ftp?  Or something like that?  The server has the firewall feature turned off - it is on a very private network, so there are no security concerns.  If someone could help me (or suggest another way to move files to this Linux novice) I would really appreciate it.  Thanks!

Dave
0
dkreines
Asked:
dkreines
  • 5
  • 3
2 Solutions
 
m1tk4Commented:
I'd start with looking what is getting written into the Linux server logs - in /var/log. The ones to check are /var/log/messages, secure, wu-ftpd log.

Also 2.1 was quite a while ago - can you refresh my memory and look it up if wu-ftpd was run as a stand-alone daemon or started by inetd? You'd see this by running

ps ax

if former, you'll see wu-ftpd running, if latter, initd.
0
 
dkreinesAuthor Commented:
It looks like xinetd is running, and not wu-ftp.  The FTP service itself appears to be running properly, because if I
  ftp localhost
I do get the "Name: " prompt, but I can't get it from a client, even though I can ping from the client.
0
 
m1tk4Commented:
ok, go to /etc/xinetd.d and look up wu-ftpd's config file, I bet it has

only_from = 127.0.0.1

there. Fix that, restart xinetd.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
m1tk4Commented:
Also, to verify that firewall is off:

iptables-save

and check the results.
0
 
dkreinesAuthor Commented:
There is no only_from line in the wu_ftpd file.  Also, I ran iptables-save and it just returned a # prompt.  ???
0
 
m1tk4Commented:
Post the full content of wu_ftpd file here.

If you have no output from iptables-save your firewall is indeed down, that's normal.
0
 
dkreinesAuthor Commented:
Well, I can now connect but there is still something wrong.  When run FTP from the client, it waits for over a minute before coming back with the Name: prompt.  After that, all appears normal.  I don't think I did anything to make it work, and the long delay doesn't seem right.  Any ideas?
0
 
decoleurCommented:
Unless you need to have ftp I would suggest using an alternative method for the file transfers, ftp is not a very secure service and has historically been the source of a myriad of exploits in the past. wu-ftp has cleaned up their act and vsftp is a really promising solution

But instead of fighting with your ftp config, might I recomend trying SCP instead. I prefer to keep a minimum number of applications running on a Linux machine, I feel it means less to maintain and less to secure.

SCP is already installed with the SSH server and it will also encrypt all traffic to and from your server using the existing user accounts. There is a reasonably good windows SCP client called WinSCP available from http://winscp.net/eng/download.php.

let me know if I can be of assistance,

-t
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now