[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

PIX 501 - VPN won't connect after IP change

Posted on 2006-05-02
9
Medium Priority
?
707 Views
Last Modified: 2013-11-16
Hi,

Have a PIX-501 running 6.3(5).  Had it running for a couple of years, company office moved and we had to get a new IP address.  Changed the IP address and now the VPN won't work.  We have always used the Cisco client, but using PDM, I tried setting up a pptp connection, but no result.  I deleted all the VPN lines last weekend and re-ran the wizard in PDM, and now the client log shows nothing when I try to make a connection.  The bosses are complaining about the loss of remote access, so any help is appreciated.

Below is my latest running config:

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname shield
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 192.168.1.48 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.48 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 69.xx.xx.xx 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 192.168.1.50-192.168.1.60 mask 255.255.255.0
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 69.64.103.254 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 132.163.135.103 source outside
ntp server 132.163.135.132 source outside prefer
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup SFS_VPN address-pool VPN
vpngroup SFS_VPN dns-server 192.168.1.2
vpngroup SFS_VPN idle-time 1800
vpngroup SFS_VPN password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local VPN
vpdn group PPTP-VPDN-GROUP client configuration dns 192.168.1.2
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username xxxxx password *********
vpdn enable outside
terminal width 80
: end

0
Comment
Question by:simba327
9 Comments
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 16593951
Have you rebooted the PIX and any other network devices between it and the Internet since the changes were implemented?
0
 
LVL 13

Expert Comment

by:td_miles
ID: 16594474
Do you get anything at all ? Turn on logging in the VPN client and see where it gets up to.
0
 

Author Comment

by:simba327
ID: 16595538
keith_alabaster:  Yes, the PIX has been rebooted, and it is directly connected to the Internet.

td_miles:  At this point I am not getting any response from the remote network.  The VPN client hangs at "Conntacting security gateway at xx.xx.xx.xx".  No problems at the site using the Internet, just no remote access.  I have verified the IP address as well, the PIX just isn't responding.
0
Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

 
LVL 9

Expert Comment

by:stressedout2004
ID: 16596116
Try adding the following line:

isakmp identity address

Then re-apply the crypto map on the interface to reinitialized it.

no crypto map outside_map interface outside
crypto map outside_map interface outside
clear crypto isa sa
clear crypto ipsec sa

From the VPN client try to see if you can ping the PIX IP address outside, then try to initiate the VPN session.
If you still can't connect, turn on the following debugs on the PIX to check if it receives any request from
the client:

debug crypto isa
debug crypto ipsec
term mon



0
 

Author Comment

by:simba327
ID: 16597668
stressedout2004:

I added the line and reapplied the crypto map on the interface.  

I also temporarily added the following:

icmp permit any echo-reply outside

However, I cannot ping the PIX on the outside.

Here is the debug info, I don't understand any of it.  The client still shows nothing, but this is from the PIX monitor:

crypto_isakmp_process_block:src:71.126.xx.xxx, dest:69.64.xx.xx spt:500 dpt:50
0
OAK_AG exchange
ISAKMP (0): processing SA payload. message ID = 0

ISAKMP (0): Checking ISAKMP transform 1 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      extended auth pre-share (init)
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 256
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 2 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash MD5
ISAKMP:      default group 2
ISAKMP:      extended auth pre-share (init)
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 256
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 3 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 256
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 4 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash MD5
ISAKMP:      default group 2
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 256
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 5 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      extended auth pre-share (init)
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 128
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 6 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash MD5
ISAKMP:      default group 2
ISAKMP:      extended auth pre-share (init)
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 128
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 7 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 128
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 8 against priority 20 policy
ISAKMP:      encryption AES-CBC
ISAKMP:      hash MD5
ISAKMP:      default group 2
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP:      keylength of 128
ISAKMP (0): atts are not acceptable. Next payload is 3
ISAKMP (0): Checking ISAKMP transform 9 against priority 20 policy
ISAKMP:      encryption 3DES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      extended auth pre-share (init)
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP (0): atts are not acceptable.
ISAKMP (0): retransmitting phase 1 (0)...
ISAKMP (0): retransmitting phase 1 (1)...
ISAKMP (0): retransmitting phase 1 (2)...
ISAKMP (0): retransmitting phase 1 (3)...
ISAKMP (0): retransmitting phase 1 (4)...
ISAKMP (0): deleting SA: src 71.126.xx.xx, dst 69.64.xx.xx
ISADB: reaper checking SA 0xb0d814, conn_id = 0  DELETE IT!

VPN Peer:ISAKMP: Peer Info for 71.126.xx.xxx/500 not found - peers:0
0
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 2000 total points
ID: 16598194
The PIX configuration looks fine. From the debugs there are retransmission which could mean that the negotiation is possibly being block somewhere. You said that the PIX has a new IP, did you get it from the same ISP or different one?
I would give them a call and inform them that you are no longer able to VPN into the PIX since the IP change and verify
with them that the following ports are open:

udp 500
udp 4500
protocol ESP

There are several occassion in my experience where those ports are being blocked by ISP. It doesn't hurt to double check.

Also by default, ping to the PIX outside interface is allowed unless otherwise configured. By adding the command you added (icmp permit any echo-reply outside), you explicitly denied ping to the PIX outside interface from the internet and only allowed PIX to be able to ping any outside IP. If that is what you wanted you can leave it as it is. But if you want
to be able to ping the PIX outside interface from the internet from troubleshooting purposes, then you have to remove
the command you added and make sure that when you do "show icmp", nothing should come up on the output.  
Now if after doing this, and you still can't ping the PIX outside IP address from the internet, then chances are, your ISP
is also blocking ping.
0
 

Author Comment

by:simba327
ID: 16598350
New IP is a different provider than the old one.  I have a call into them regarding the ports.

I removed the icmp permit... line and "show icmp" returns nothing, but I am still unable to ping.  In my earlier conversation with the ISP tech, he told me that they were not blocking anything outside of their servers, which are on a different subnet.
0
 
LVL 9

Expert Comment

by:stressedout2004
ID: 16599212
Put it this way, if from the PC you are using to connect with the VPN client you can ping other IP on the internet except for the PIX outside interface, then that means that ping is not being blocked by that PC's ISP. If you can't ping any IP on the internet from that same PC, then their ISP is blocking it and you are using the wrong PC to test the ping.

If from the PIX, you can ping out to the internet, but cannot ping the PIX itself from host on the internet and you don't have the icmp command on the PIX, then chances are outbound ping is permitted but inbound is not. If icmp is not working both ways, and your ISP is telling you that they are not blocking any ports either the person you were talking to don't know any better or they are not exactly being honest to you.





0
 

Author Comment

by:simba327
ID: 16601807
stressedout2004, your answer gave me the idea to look at the firewall at the test site.  Sure enough it was blocking the ipsec traffic.  Thanks to you,  keith_alabaster and td_miles for all your assistance.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question