Port 3389 blocked after Windows Update

I am running Windows 2003 server with a public IP.  After performing the most recent Windows update and rebooting I am no longer able to RDP to it either via the internal or external IPs.  I can't Telnet to it either.  (Error:  "Could not open connection to the remote host on port 3389:  Connect Failed")  I can Telnet on port 25.  This is a Windows 2003 Server running Exchange.  I have another Win2k3 server connected physically the exact same way and I am able to RDP to it.   I haven't run the updates b/c I'm now afraid to.  I have checked canyouseeme.org and it says that port 3389 is blocked.  It hasn't been blocked in the past.  I was using it to run the Windows updates that caused me to lose connectivity.  I don't see anywhere obvious that the port is blocked.  It is not blocked on my firewall b/c the other devices are still accessible.  It isn't blocked in the TCP/IP properties.  What else can I check?

Thanks!
ddalrympleAsked:
Who is Participating?
 
Rob WilliamsConnect With a Mentor Commented:
Though you are actually getting a message the port is blocked verify the service running/listening, perhaps it didn't restart.
On the server at a command line enter (substitute port # if not using default 3389):
  netstat  -an  |find  "3389"
You should get the following result:
TCP   0.0.0.0:3389    0.0.0.0:0    listening
If not go to Start  | Run | services.msc and see if Terminal Services is started and set to automatic
0
 
Keith AlabasterConnect With a Mentor Enterprise ArchitectCommented:
If you right-click the My Computer icon and select properties - remote, does it still show remote desktop still enabled?
0
 
ddalrympleAuthor Commented:
Oh yes, it does.  I forgot to add that.  It specifically says the port is blocked.  
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
Rob WilliamsCommented:
Just in case you haven't looked into it:
What updates? SP1? If so are you aware it adds a firewall? You mentioned "It is not blocked on my firewall b/c the other devices are still accessible." were you referring to the Windows Firewall in Control Panel ?
0
 
ddalrympleAuthor Commented:
Yes, I checked the Windows firewall as well but it is disabled.  The updates were KB912812, 908981, 911567, 911562 and 908531.
0
 
Rob WilliamsCommented:
None of those updates look suspicious after reading outlines.
0
 
ddalrympleAuthor Commented:
I agree that none of them look like the culprit.  Could be a coincidence that that reboot is when the problem occured.  However, I was remotely connected when I did the updates and I couldn't connect remotely after the reboot.  That is why I was asking for ideas of other places/methods to check what might be blocking the port.  It's clearly blocked just on that machine.  This is my main way to administer this machine since I am almost never within physical proximity so I really need it resolved.  Thanks!
0
 
ddalrympleAuthor Commented:
When I try that command it just returns me to the command prompt with no errors or confirmations.  However, the Terminal Services service is started.  

Any other thoughts?
0
 
Rob WilliamsCommented:
It won't work if it is not listening. Just to double check try simply
  netstat -an
This will list all open or listening ports. Manually go through the list. Should see under local address  0.0.0.0:3389 unless you have used the registry hack to manually change the port remote desktop uses. If it is there but not shown as "listening" perhaps it thinks it is in use. If it is not there at all we will have to look further.
Make sure it is enabled under My computer | Properties | Remote | Allow users to remotely connect to this computer - just in case somehow it got switched off.
0
 
Keith AlabasterEnterprise ArchitectCommented:
That was my first question Rob (hi by the way). Something doesn't quite seem to ring right here does it.
0
 
Rob WilliamsCommented:
Ah, yes Keith, sorry I missed that on last reading. See it took me 10 steps to get that far. I must be getting old and slow. <G> Take care.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Hardly. Mr Whizz lol
0
 
Rob WilliamsCommented:
:-) Tks
0
 
Keith AlabasterEnterprise ArchitectCommented:
Thank you :)
0
 
Rob WilliamsCommented:
Thanks ddalrymple. Was it somehow switched off during the update process?
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.