Urgent: how to install/enable suidperl (using perl 5.8.8)

i have installed perl 5.8.8 from source  and now i am installing AUC.pm and it says it requires suidperl

 i don't know what i am missing, please help me if you can.

I think i have to recopile the perl once again, but still not sure how to enable suidperl :
LVL 12
str_kaniAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Suhas .Senior QA ManagerCommented:
suidperl : for use with setuid perl scripts

suidperl is the perl interpreter for suid perl scripts, a part of the
    perl package. A maliciously implemented feature causes the interpreter
    to spawn the /bin/mail program to inform the superuser of its usage,
    thereby passing on untrusted environment that causes /bin/mail to
    execute arbitrary commands as user root.


http://rpmfind.net/linux/RPM/freshrpms/yellowdog/2.3/perl/perl-suidperl-5.6.1-34.99.6.ppc.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
str_kaniAuthor Commented:
i have installed 5.8.8 already... do you think installing this will do?
Suhas .Senior QA ManagerCommented:
The 'suidperl' is an optional component which is not installed, or even built, by default.
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

str_kaniAuthor Commented:
you meant to say,
i have to install this separately and it cannot be configured with the default perl?

and i need to do this on a linux machine so please make sure the rmp you linked is correct.

Suhas .Senior QA ManagerCommented:
sorry,
that is for version 5.6,

The below link gives you the rpm for version 5.8.8:
http://rpmfind.net/linux/RPM/fedora/devel/ppc/perl-suidperl-5.8.8-4.ppc.html
Suhas .Senior QA ManagerCommented:
Hope this link will give you the details:

http://www.cpan.org/src/5.0/sperl-2000-08-05/sperl-2000-08-05.txt
str_kaniAuthor Commented:
ok, tried that but that reqquire some additional rps, and the other requires some other :(
i am a bit new to this, can you please tell me an easy way of installing all required rpms easily?

i tried with yum! but that too failed to help me... it give me the following when i try to run yum

Traceback (most recent call last):
  File "/usr/bin/yum", line 6, in ?
    import yummain
  File "/usr/share/yum-cli/yummain.py", line 23, in ?
    import yum
ImportError: No module named yum

** i am trying this as root
str_kaniAuthor Commented:
i got this fixed by isntalling some other version, now i have yum working....
but when i run
#> yum list updates
Gathering header information file(s) from server(s)
Server: Fedora Linux / stable for Red Hat Linux 9 (i386)

it hangs after showing the above two lines... sounds like i need to configure something...?

Suhas .Senior QA ManagerCommented:
try #>yum check-updates
str_kaniAuthor Commented:
i got the folowing... for
#>yum check-updates


> root]# yum  check-updates
Error: Cannot find baseurl or name for server 'updates'. Skipping

    Usage:  yum [options] <update | upgrade | install | info | remove | list |
            clean | provides | check-update | groupinstall | groupupdate |
            grouplist >

         Options:
          -c [config file] - specify the config file to use
          -e [error level] - set the error logging level
          -d [debug level] - set the debugging level
          -y answer yes to all questions
          -t be tolerant about errors in package commands
          -R [time in minutes] - set the max amount of time to randonly run in.
          -C run from cache only - do not update the cache
          --installroot=[path] - set the install root (default '/')
          --version - output the version of yum
          -h, --help this screen
Suhas .Senior QA ManagerCommented:
sorry,not updates its check-update

#>yum check-update

then you came to know the list of updates
str_kaniAuthor Commented:
Ok no problem.
no i get this.... and yum take some time return to the prompt...

# yum check-update
Error: Cannot find baseurl or name for server 'updates'. Skipping
Gathering header information file(s) from server(s)
Server: Red Hat Linux 9 - i386 - Base
str_kaniAuthor Commented:
no problem, now i got that working... don't know that started working.  restarted the machine once...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Perl

From novice to tech pro — start learning today.